 紹介

紹介

Top Next

IrfanViewはコンパクトで使いやすい画像閲覧ソフトです．それだけでなく, IrfanView上で直接画像を編集したり，いろいろな効果を生成したりすることもできます．IrfanViewはIrfan Skiljanが作成しました．

Windowsのスタートメニューをクリックするかデスクトップ上のアイコンをダブルクリックしてIrfanViewを起動してください．

ファイルメニューをクリックし，開くを選んでビューアーで使うファイルを選ぶことができます．ダイアログボックスで閲覧したいファイルを選ぶことができます．「開く」ダイアログのプレビューチェックボックスをチェックすると，ファイルを開く前に小さな画像で確認することができます．

ビューアーで開いた画像は，様々な処理を施すことができます．画像を修正する機能のほとんどは編集メニューか画像メニューの中にあります．

画像を操作し終わったら，ディスクに保存してください．その後で他の画像を開くか, IrfanViewを終了してください.

さらに詳しい機能説明は下の画像の各部をクリックしてください：

最小化 閉じる IrfanViewについて 基本設定 フォルダ内画像順 マルチページTIFF マルチページTIFF 次ファイル 前ファイル ズームアウト ズームイン 画像情報 元に戻す 貼り付け コピー 切り取り 画像を削除 保存 スライドショー 開く ヘルプメニュー 表示メニュー オプションメニュー 画像メニュー 編集メニュー ファイルメニュー


 よくある質問

よくある質問

Top Previous Next

IrfanViewやバグレポートなど有用な質問を紹介します．

Q:画像をCD-ROMに焼いて，IrfanViewもCDにコピーしておこうと思います．どうやったらドライブにCDを入れた時に自動でIrfanViewスライドショーをさせられるようになりますか？
A: スライドショーダイアログを使って，EXE形式のスライドショーファイルを作ることもできますし，オリジナルの画像をCDにコピーすると共に設定を書いたTXTファイルを作成することでもできます．詳しくはスライドショーCDページの例を見てください．
Q:トラブル：AVIファイルを再生しようとしたら，「Video not available, cannot find MJPG decompressor」というエラーメッセージが出ました．
A:
方法1
「基本設定→ビデオ / サウンド」の「DirectShowを使用する」を有効にしてください．
方法2
以下のサイトなどからMJPG（Motion JPEG）ビデオコーデックを入手してインストールしてください．
  • http://www.free-codecs.com/Motion_JPEG_Codec_download.htm
  • http://www.mainconcept.com/downloads.shtml
  • http://www.morgan-multimedia.com
  • http://www.fourcc.org/indexcod.htm
Q:トラブル：IrfanViewでAVIやMPGを再生しようとすると，いつも「MMSYSTEMxxx, no device ...」というエラーメッセージが出ます．
A:Microsoftのサイトhttp://www.microsoft.com/でこのメッセージナンバーの情報を検索してください．バグフィックスが出ている場合もあります．
Q:ビデオファイルに関する一般的なトラブル：AVIファイルを再生しようとしたら，「Video not available, cannot find XXX decompressor」というエラーメッセージが出ます．
A:正しいビデオコーデックがインストールされていません．以下のサイトで正しいコーデックを入手してください．（コーデックの名前は画像→画像の情報で確認してください）
  • http://www.fourcc.org/indexcod.htm
  • http://www.codec-download.com
  • http://codecs.necromancers.ru
  • http://www.free-codecs.com
  • http://www.microsoft.com/downloads/results.aspx?productID=&freetext=media+8&DisplayLang=en
  • http://www.videohelp.com

K-Lite Codec Packがお薦めです．このコーデックパックには主要なビデオ/オーディオコーデックが含まれています．

Q:どうやったらファイルサイズをXXからYY KBに小さくできますか？
A:ワンクリックでできるような方法は用意していません．ごめんなさい．以下の手順で行ってください．
  1. 画像を開きます．
  2. 画像→リサイズ/リサンプルを選び，画像サイズを小さくしてください．
  3. ファイル→名前を付けて保存で，JPGを選んで新しいファイルとして保存してください．その際，JPGオプションを低画質にしたり，元EXIF情報を保存というオプションを無効にしたりするとさらにデータは小さくなります．
  4. 新しいファイルのサイズを確認し，まだ大きい場合は，さらに画像サイズを小さくしたり，画質を落としたりするなど，上述の手順を繰り返してください．
  • X. イメージがたくさんある場合は，ファイル→一括変換 形式/名前メニューの詳細設定を使用してください．
注：バージョン4.20からはJPGの保存設定に新しくファイルサイズというオプションが加わっています．利用にはIrfanViewにRIOTプラグインが必要です．
Q:バグレポート：昨日からIrfanViewで画像を閲覧すると，いつも白黒になります．
A:「基本設定→JPG / PCD / GIF」にあるJPGの表示方法オプション「グレイスケールで表示」が有効になっていないか確認し，チェックを外してください．
注：保存ダイアログを表示し，JPG形式の保存設定を確認してください．「グレイスケールで保存」にチェックが付いていたら，チェックを外してください．
Q:バグレポート：IrfanViewで中国語，日本語，ポーランドetcのファイル名/パス名が読めません．
A: 基本設定→言語で開始時に UNICODE プラグインを読み込むを有効にしてください．
Q:一括変換モードでJPGロスレス変換（回転，IPTC，コメント）を利用するにはどうしたらよいですか？
A:JPGファイルのあるフォルダでサムネイルウィンドウを開き，操作したいJPGを全て選択してサムネイルのファイルメニューからJPGロスレス変換を選び，サブメニューから加えたい操作を選択してください．注：選択画像でロスレス回転を行うは，EXIFの画像方向タグが適切に保存されている時にのみ有効です．
Q:USBメモリやCD-ROMなどに入れて使える，ポータブル版のIrfanViewはありませんか？
A:どのバージョンのIrfanViewもポータブル版として持ち歩くことができます．以下の方法どれかを行ってください．
  1. PCにインストールしたIrfanViewをフォルダごとUSBメモリにコピー（推奨）
  2. インストーラを使ってUSBメモリにIrfanViewをインストールする．
  3. ZIP版のIrfanViewをUSBメモリに解凍する．
Q:なぜ編集メニューに使えないメニューがあるのですか？なぜ赤目補正メニューが使えなくなっているのですか？
A:編集メニューや赤目補正は，選択範囲にのみ適用することができます．まず，画像に選択範囲を設定してからメニューを選んでください．
Q:どうやったらIrfanViewがデフォルトビューアーになりますか？
A:IrfanViewを起動し，「基本設定→ファイルの関連付け」でIrfanViewをデフォルトビューアーにしたいファイルタイプを関連付けしてください．
Q:RAW形式（例えばCR2のようなカメラRAW形式）は読み込みが遅いのですか？
A:これは，「基本設定→PlugIns」のRAWプラグインオプションの状態に依存します．組み込みプレビュー画像の読み込みが一番速く，半分のサイズの画像の読み込みも高速です．もし，どちらのオプションも有効になっていない場合，フルRAW画像を読み込みますので，とても遅くなります．
Q:撮影時間順に写真を並べるにはどうしたらいいですか？
A: サムネイルウィンドウ を開いてフォルダを読み込み，オプション→サムネイルをソートからEXIF情報の撮影日付を選んでください．
Q:IrfanViewはMSのJPEG脆弱性に影響されますか？
A:いいえ．IrfanViewではMSのGDI+JPEGデコーダを使用していません．
Q:どうやったら「JPG」という大文字の拡張子を一括で小文字の拡張子「jpg」にできますか？
A: 一括変換 形式/名前ダイアログで，$N.jpgというパターンを使ってファイル名を変換してください．
Q:どうやったら自動スライドショーやEXE/SCRスライドショーにBGMを付けられますか？
A: スライドショーダイアログのスライドショーファイルリストにMP3ファイルを加えてください．MP3はリスト先頭か音楽を鳴らしたい画像の前に加えます．そうすると，読み込まれたMP3はファイルが終わるか，次のMP3をリストから読み込むまで鳴り続けます．この機能を使うには，少なくともMP3プラグインをIrfanViewにインストールしておく必要があります．
Q:一括変換：いろいろな入力フォルダのファイルを一括変換している時に，どうやったらそれぞれを元のフォルダに保存できますか？
A:入力ファイルが同一ドライブ上にあるならできます．まず，一括変換の詳細設定を使用で新しくフォルダを作成して格納を有効にします．元のメイン一括変換ダイアログに戻り，保存先ディスクのルートフォルダを設定します．例えば，入力ファイルがCドライブにあるならC:\にします．
Q:フルスクリーンモードで，なぜモニタより大きくズームした画像を上下キーでスクロールできないのですか？
A:画像が実際にはモニタより大きくなく，かつ，基本設定→ブラウジング / 編集→Pageキーかマウスホイールで常に次の画像を表示が有効になっているのだと思います．オプションを無効にしてください．
Q:なぜ保存したJPGファイル元のJPGファイルより大きいのですか？
A:JPGファイルのサイズは保存ダイアログの画質設定に依存します．通常画質は75か80ぐらいです．それより大きな値にすると，保存ファイルは大きくなります．
Q:どうやったらVCD (Video CD)にBGMを付けられますか？
A:VCDの仕様によりBGMは付けられません．
Q:IrfanViewは64bit版Vista/XPでも使えますか？
A:はい，32bit版ソフトの約95%が64bit OSでも使えるのと同じように，IrfanViewも使用できます．
Q:IrfanViewに関連付けしたファイルのアイコンはどうやったら替えられますか？
A: 基本設定→ファイルの関連付けでアイコンボタンを押すと，他のアイコンセットを選択できます．
Q:バグレポート：昨日から画像が全部歪んで表示されます/拡大されて表示されます．
A:表示メニューの「画像をデスクトップに合わせる」などの表示オプションが有効になっていないか確認し，有効になっているならチェックを外して推奨設定を使用してください．
Q:EXEスライドショーから画像を抽出するにはどうしたらいいですか？
A:EXEを起動しEを押してください．フォルダを指定すると自動的に抽出します．（スライドショー実行中にF1を押すとスライドショー中のショートカットキーを参照できます）
Q:どうやったらJPG IPTCデータ/コメントを一括で変更できますか？
A: サムネイルウィンドウ上で変換したいJPG画像ファイルを全て選択し，JPGロスレス変換→選択画像にIPTCデータ/コメントを設定を使用してください．最初の画像に設定したデータが全ての画像に適用されます．IPTCダイアログには付加オプションがあります．
Q:JPGのIPTCデータ/コメントの編集はロスレスですか？
A:はい，画像自体は再圧縮しません．
Q:ブラウズ中に特定のファイル種類だけ読み込むにはどうしたらよいですか？
Q:フォルダをブラウズ中，特定のファイル拡張子（例えば TXT）だけ読み込まないようにするにはどうしたらよいですか？
Q:IrfanViewは例えばCR2ファイル読み込めますが，サムネイルウィンドウでは表示しないようにするにはどうしたらよいですか？
A: 基本設定→ファイルの関連付けで，指定したファイル形式を表示フィールドのファイル拡張子を編集してください．表示したくない拡張子を削除し，（サポートされている）表示したい拡張子を追加します．
Q:バグレポート：8BPP以下に減色したのに，保存したJPGがいつも24 BPPになります．
A:JPGファイルは24BPPか8BPPのグレイスケールでしか保存できません．JPGの仕様では，それ以外のBPP値が利用できません．もし他のBPP値を利用したい場合は，PNG，TIF，BMPなどの形式を利用してください．
Q:どうやったらデスクトップ上のIrfanViewアイコンを変更できますか？
A:これは，標準的なWindowsの機能で変更することができます．デスクトップのアイコン上で右クリックし，「プロパティ」を選択してください．アイコンの変更で別なアイコンにしたり，起動ショートカットキーを設定したりすることができます．
Q:どうやったらブラウズ中に拡張子のないファイルを読み込むことができますか？
A: 基本設定→ファイルの関連付けで，指定したファイル形式を表示フィールドに入力してあるファイル拡張子の末尾に「|」を追加してください．これで拡張子が空のエントリーが作られたことになります．必要なら基本設定→ファイル操作の誤った拡張子のリネームを確認するオプションを無効にしてください．
Q:画像の一部だけ印刷するにはどうしたらよいですか？
A:印刷したい範囲を範囲選択し，印刷メニューを使用してください．あるいは，編集→選択範囲を切り出すを行ってから印刷してください．
Q:たくさんのファイルを一括印刷するにはどうしたらよいですか？
A: サムネイルウィンドウ上で印刷したい画像/ファイルを選択し，ファイルメニューから選択画像を一枚ずつ印刷を使用してください．
Q:どうやったらPDFファイルをIrfanViewで読み込むことができますか？
A:IrfanViewとプラグインをインストールした上で，http://sourceforge.net/project/showfiles.php?group_id=1897（日本語版：http://auemath.aichi-edu.ac.jp/~khotta/ghost/）などからGhostscriptをインストールしてください．
Q:複数の画像を1ページに印刷するにはどうしたらよいですか？
A: サムネイルウィンドウ上で, ファイルメニューから選択画像でコンタクトシートを作成を選択し，結果画像を印刷してください．
Q:IrfanViewはWindows 95やWindows 98でも使えますか？
A:はい，IrfanViewは全Win9x-とそれ以降のバージョンのWindowsで使うことができます．Win9xの意味は，Windows 95, 98, 98 SE, MEです．
Q:ADFスキャナを持っていなくても一括スキャンする方法はありませんか？
A:はい，File→スキャン/一括スキャン→画像取得後にTWAINダイアログを閉じるのチェックを外してください．
Q:テキストの挿入ダイアログでUnicode（例：中国語）テキストを使うにはどうしたらいいですか？
A:Windowsのコントロールパネルで地域と言語のオプションを開き．詳細設定タブを選択してください．「Unicode 対応でないプログラムの言語」で「中国語」などを選択してください．
Q:IrfanViewでQuickTime (MOV) ファイルを再生するにはどうしたらよいですか？
A:QuickTimeファイルを再生するには，Apple QuickTimeをインストールし，IrfanViewのQuickTimeプラグインもインストールしてください．基本設定→ビデオ / サウンドでQuicktimeプラグインを有効にしてください．
Q:バグレポート；IrfanViewの設定が保存されません．
A:可能性が2つ有ります．
  1. INI（i_view32.ini）ファイル（あるいはIrfanViewフォルダ全体）が読み取り専用に設定されている．
    →設定を変更してください．
  2. 「自動」ディスク・クリンナップツールやリストアツールの中には必要なファイルまで消してしまう物もあります．
    →ソフトの設定を確認し，IrfanViewのファイルやフォルダを操作から除外してください．
Q:バグレポート：スライドショーや一括処理のダイアログで追加を押しても選択したファイルがファイルリストに追加されません．
A:Windowsのエクスプローラに登録されている拡張子は表示しないという「機能」があります．この初期設定（かつ，ばかげた設定）を無効化して，拡張子の付いた本当のファイル名が表示されるようにしてください．
Q:バグレポート：1フォルダにたくさんのファイルを保存しているのですが，サムネイルウィンドウがクラッシュしました．
A:これはWindows 9x/XPのバグで，フォルダに保存できるファイルの最大数はシステムに依存します．WinNTやWin2Kには上限がありません．ファイルを複数のフォルダに分散してください．
Q:バグレポート：ビデオをキャプチャするとスクリーンが真っ黒になるのはなぜですか？
A:スクリーンショットを撮る間，ビデオアクセラレータを無効にしてください．設定の場所は以下の通りですが，ビデオカードのドライバをインストールしている時は，そちらを使ってください．
Windows Vista
[スタート] ボタン→コントロール パネル→デスクトップのカスタマイズ→個人設定→画面の設定→詳細設定→トラブルシューティング タブをクリックし，設定の変更
Windows XP
デスクトップを右クリックし，プロパティ→設定タブ→詳細設定→トラブルシューティング] タブ
Windows 2000
[スタート] ボタン→設定→コントロール パネル→画面→設定タブ→詳細→トラブルシューティング タブ
Windows 98 / Windows 95
[スタート] ボタン→設定→コントロール パネル→システム→パフォーマンス タブ→グラフィックス
あるいは，2つめのプレーヤーを起ち上げて，そちらでキャプチャを試してください．
Q:バグレポート（Windows 95）：サムネイルウィンドウで，サムネイルをクリックしても何も起きず，メインウィンドウに画像が表示されません．
A:古いバージョンの「comctl32.dll」を使用しています．MSのホームページでComctl32.dllを検索し，このWindowsコンポーネントをアップデートしてください．
Q:トラブル：IrfanViewに関連付けしたファイルをダブルクリックすると，「Cannot find the file [path] or one of its components」というエラーメッセージが出ます．何が問題なのですか？
A:IrfanViewを起動し，「基本設定→ファイルの関連付け」でファイルを関連付けし直してください．
Q:バグレポート：IrfanViewの起動/実行がとても遅いです．
A:古いアンチウィルスソフトやその他のバックグラウンドで実行するソフトウェアがあると，そのような問題が起きる場合があります．システムを確認してみてください．
Q:バグレポート：IrfanViewで作成したスクリーンセーバーが，画像を数枚表示しただけで終了してしまいます．
A:他の実行中のソフトウェアがスクリーンセーバーを停止してしまうことがあります．システムを確認してみてください．
Q:アップグレード：新しいバージョンをインストールする前に古いバージョンをアンインストールする必要がありますか？
A:必要ありません．新しいバージョンは古いバージョンに上書インストールしてください．インストール後，基本設定→ファイルの関連付けで関連付け/オプションを更新してください．
Q:Linux上でIrfanViewを使えますか？
A:使えます．Linux向けのネイティブ版IrfanViewはありませんが，WINE, Windows Linuxエミュレータ，Linuxベース仮想マシンのようなLinuxプログラムと一緒に使うことでIrfanViewを利用することができます．以下の解説を参照してください．
http://www.wine-reviews.net/applications/irfanview-410-on-linux-with-wine.html
Q:基本：例）BMP画像/ファイルをJPGにするにはどうしたらいいですか？
A: ファイル→開くメニューを使ってBMPファイルを開きます．次にファイル→名前を付けて保存メニューをクリックし，出力ファイルの種類としてJPGを選んで新しいファイル名/フォルダ名を設定して保存してください．ファイルをたくさん変換したい場合は，一括変換 形式/名前を使用してください．
参照：この操作の動画http://www.youtube.com/watch?v=cj-rDx1hH4A
Q:基本：IrfanViewプラグインは必要ですか？
A:必ずしも必要ありません．基本的なオプション/機能/プラグインはIrfanViewの標準インストールに含まれています．プラグインはたいてい特殊なファイル形式向けです．特殊なプラグインが必要な時にはIrfanViewがエラーメッセージを表示しますので，その時に他のプラグインをインストールすればよいでしょう．
Q:IrfanViewにはスパイウェアやウィルスなどが含まれていますか？
A:いいえ．もしお使いのアンチウィルスソフトが，公式サイトからダウンロードしたIrfanViewにウィルスやスパイウェアがあるという警告を出すのなら，アンチウィルスソフトをアップデートするか，もっと良いソフトに替えてください．
Q:上級者向け：ツールバーやステータスバーのように，プログラムメニューやキャプションを永久に隠す方法はありませんか？
A:あります．INI fileの[Menu] セクションにActive=0と書き入れるとメニューが隠され， [Caption] セクションにActive=0と書き入れるとプログラムタイトルが隠されます．
Q:システム管理者です．全サーバ/PCのIrfanViewを同一設定に保つにはどうしたらいいですか？
A:
  1. IrfanViewをサーバ/PCにインストールします．
  2. IrfanViewのオプション（基本設定など）を設定した後で，INIファイル「i_view32.ini」を読み取り専用にします．これでユーザはIrfanViewの設定を変更できなくなります．
  3. レジストリの変更（関連付け）を防ぐため，基本設定→ファイルの関連付けダイアログを隠します．INIファイルに以下のように書き入れてください．
    [Extensions]
    ShowExtensionsDlg=0
Q:システム管理者です．共用のサーバ/PC1台にIrfanViewをインストールし，INIファイルだけユーザごとに保存するにはどうしたらいいですか．
A:
  1. IrfanViewをサーバ/PCにインストールします．
  2. INIファイル（i_view32.ini）に次のように書きます．
    [Others]
    INI_Folder=folder
    • 例1：INI_Folder=C:\TEMP
    • 例2：INI_Folder=%TEMP%
    • 例3：INI_Folder=%APPDATA%\IrfanView
    • 例4：INI_Folder=C:\TEMP\%環境変数%
    • 例5：INI_Folder=%環境変数%\フォルダ名
Q:システム管理者です． IrfanViewをサイレントモードでインストール/アンインストールするにはどうしたらいいですか？
A:ZIP版IrfanViewとプラグインをダウンロードし，ファイルを展開してください．自己インストール版IrfanViewを使う場合はサイレントインストール用の特殊なオプションがあります．（例はバージョン4.20）
  1. IrfanView
    iview420_setup.exe /silent /folder="c:\test folder\irfanview"
    iview420_setup.exe /silent /folder="c:\test folder\irfanview" /desktop=1 /thumbs=1 /group=1 /allusers=0 /assoc=1 /ini="%APPDATA%\irfanview"
    iview420_setup.exe /silent /folder="c:\test folder\irfanview" /ini="c:\temp"
    オプション
    folder | フォルダの位置．指定しない時は，以前のバージョンのIrfanViewフォルダが使われる．以前のバージョンが存在しない時は，「Program Files」 フォルダが使用される．
    desktop | デスクトップにショートカットを作るか．0 = 作らない, 1 = 作る（デフォルト：0）
    thumbs | デスクトップにサムネイルのショートカットを作るか．0 = 作らない, 1 = 作る（デフォルト：0）
    group | スタートメニューにショートカットを登録するか．0 = 登録しない, 1 = 登録する（デフォルト：0）
    allusers | 全ユーザのデスクトップ/スタートメニューにショートカットを作るか．0 = カレントユーザのみ, 1 = 全ユーザ
    assoc | ファイルの関連付け．0 = 関連付けしない, 1 = 画像のみ, 2 = 全ファイル (デフォルト: 0)
    assocallusers | 全ユーザで関連付けを行う．（Windows XPのみ）
    ini | INIファイルのフォルダ．（システム環境変数が使用できる）
  2. プラグイン
    irfanview_plugins_420_setup.exe /silent
  3. アンインストール
    iv_uninstall.exe /silent
Q:IrfanViewのアイコンは何なのですか？熊か悪魔か何か他の物ですか？
A:赤い猫で，轢かれた猫です．ただし，私は猫が好きで，コレは単なるジョークです．;-)

その他

特定の機能/操作のチュートリアルを作ってくれたユーザもいます．みんな，ありがとう！

インストール | http://www.downloadtube.com/IrfanView-4-20-demo-installation-windows.html（英語）
一般 | http://www.downloadroute.com/IrfanView-Irfan-Skiljan/tutorials.html（英語）
一般 | http://www.sticksite.com/irfanview/（英語）
一般 | http://www.indeavors.com/resources/tutorials.htm（英語）
一般 | http://www.cam-web.co.uk/IrfanviewTutorials（英語）
一般 | http://www.pc-tinkering.de/search.php?search=Irfanview&language=1（英語）
一般 | http://www.fotowelt-online.de/software/irfanview/index.php（ドイツ語）
一般 | http://www.lehrerfortbildung-bw.de/werkstatt/bild/irv/（ドイツ語）
一般 | http://www.henner.info/irfan.htm（ドイツ語）
一般 | http://www.infografik.ch/bro11_irfan.pdf（ドイツ語，PDF）
一般 | http://home.casema.nl/sve/irfanview/irfanview.htm（オランダ語）
一括サイズ変更 | http://www.lancelotgroup.com/tutorials/HowToResize-IrFanView-Start.asp（英語）
一括サイズ変更 | http://www.coffeedrunk.com/2008/10/08/how-to-do-a-batch-resize-using-irfanviewtutorial/（英語）
コマンドライン | http://www.netikka.net/tsneti/info/tscmd137.htm（英語）
一括変換 | http://www.photosapiens.com/article.php?id_article=1224（フランス語）
一括変換 | http://www.youtube.com/watch?v=dWvlvu_4NQc (spanish)
コンタクトシート | http://www.photosapiens.com/article.php?id_article=1694（フランス語）
切り抜き | http://www.peterkjohnson.com/helpSheet/demoCroppingIrfanview/croppingIrfanview.html（英語）
スライドショー | http://www.zisman.ca/Irfanview/（英語）
スクリーンセーバー | http://www.furytech.net/tutorials/irfanviewtutorials/using_irfanview_to_make_screensa.htm（英語）
インストール サイズ変更 | http://www.hp-h.com/p/paradj/tshootimg/irfanview/（英語）
インストール他 | http://www.kulak.ac.be/renwv/nazorg/wegwijsweb/（オランダ語）
JPG | http://netzreport.googlepages.com/hidden_data_in_jpeg_files.html（英語）
フラクタル | http://benscheele.com/ag/fractal_art.htm（英語）

Windows固有の問題に関する情報

エクスプローラにおけるサムネイルの問題点 | http://www2.whidbey.net/djdenham/Tweekz.htm
ビデオツール/変換 | http://www.videohelp.com


 インストール

インストール

コンピュータに慣れたユーザー

IrfanViewをダウンロードし，ファイルを好きなディレクトリに解凍してください．その後，ショートカットをWindowsスタートメニューのプログラムやデスクトップに作ってください．

コンピュータに不慣れなユーザー

インストーラ付きのIrfanViewをダウンロードし，インストールファイルを起動してください．

訳注：本家IrfanViewのインストーラ付きファイルなら，スタートメニューへの登録，デスクトップへのショートカット作成，コントロールパネルのプログラムへの追加と削除への登録が自動でできます．IrfanView日本語版ファイルだと，ファイルを指定したフォルダに展開するだけなので，これらは手動でしなければなりません．

追加情報：

ファイル構成

ダウンロードファイルを解凍すると，以下のファイルが作成されます．

i_about.txt
IrfanViewの紹介と作者について
i_changes.txt
プログラムの更新履歴
i_options.txt
プログラムの拡張機能概要説明
i_view32.exe;
IrfanViewのメインプログラムです．
i_view32.hlp，i_view32.cnt
ヘルプファイルです．

ショートカットの作り方

ショートカットとはスタートメニューでクリックするメニューやデスクトップアイコンのことで，プログラムを起動するための印です．インストーラが付いていないファイルからIrfanViewをインストールした場合，ショートカットは作成する必要があります．

スタートメニューに登録するには，スタートボタン上で右クリックしてエクスプローラか開くを選び，登録したいフォルダを開いてから, IrfanViewをインストールしたフォルダからi_view32.exeのアイコンをAltを押しながらドラッグ＆ドロップします．

デスクトップにショートカットを作る場合，一番簡単な方法はIrfanView自体を使う方法です．IrfanViewを起動し，オプションメニューから基本設定を選択します．ダイアログボックスが開くので，その他を選択します．ほとんど一番下にデスクトップにIrfanViewのショートカットを作るというボタンがあります．それをクリックすれば，デスクトップにIrfanViewのアイコンができます．OKボタンを押してダイアログを閉じます．今度からビューアーを使いたい時は，アイコンをダブルクリックするかCtrl+Shift+Iを同時に押すだけで起動できます．

更新インストール

IrfanViewは，以前のバージョンに新しいバージョンを上書きでインストール／アップデートできます．古いバージョンをアンインストールする必要はありません．

関連付け

インストール時に関連付けの設定をしなかった場合は，インストール後に基本設定→関連付けの設定で関連付けを更新してください．


アンインストール

インストーラ付きファイルでインストールした場合

Windowsスタートメニュー > プログラム > IrfanViewとたどり，IrfanViewのアンインストールをクリックします．

もしくはコントロールパネル > プログラムの追加と削除でIrfanViewをダブルクリックしてください．

これらが見つからない場合は，IrfanViewフォルダの中のiv_uninstall.exeをダブルクリックしてください．

訳注：本家IrfanViewのインストーラ付きファイルでインストールした場合には，スタートメニューや，コントロールパネルのプログラムへの追加と削除にアンインストール用ショートカットが登録されていますが，IrfanView日本語版ファイルからインストールした場合は，登録がありません．

手動でインストールした場合

IrfanViewのフォルダを削除し，作成したショートカットを削除してください．


 サポートファイル形式

サポートファイル形式

以下に現バージョンのIrfanViewがサポートするファイル形式/拡張子を列挙します．

AIF¹, ANI, AU¹, AVI, AWD, B3D, BMP, CAM, CLP, CPT, CRW/CR2, CUR, DAT¹, DCM/ACR, DCX, DDS, DIB, DJVU, DLL/EXE, DXF/DWG/HPGL/CGM/SVG, ECW, EMF, EPS/PS/PDF/AI, EXR, FITS, FLI/FLC², FPX, FSH, G3, GIF, HDP/WDP, HDR, ICL, ICO, IFF/LBM, IMG, JLS, JP2, JPG/JPEG, JPM, KDC, LDF, LWF, Mac PICT², MAG, MED, MID, MNG/JNG, MOV¹², MP3, MPG/MPEG¹, MrSID, NLM/NOL/NGG/NSL/OTB/GSM, OGG, PBM, PCX, PDF, PGM, PIC, PhotoCD, PNG, PPM, PSD, PSP, PVR, QTIF², RAS/SUN, RealAudio, RAW, RLE, RMI, SFF, SFW, SGI/RGB, MrSID, SWF/FLV, SND¹, TGA, TIF/TIFF, TTF, TXT, WAD, WAL, WAV, WBMP, WMF, WMA, WMV, WBC/WBZ, WSQ, XBM, XPM, (DNG, EEF, NEF, ORF, RAF, MRW, DCR, PEF, SRF, X3F, RW2, NRW).

¹ Microsoft's Media Playerが必要です．

² Apple's QuickTimeが必要です．

注：サポートファイル形式は，プラグインを用いる物が多いです．下の表を確認し，「i_plugins.txt」にある追加情報もお読みください．

プラグインダウンロード：http://www.irfanview.com/plugins.htm

IrfanViewフォーマット一覧

拡張子 | フォーマット名 | 閲覧 | 保存
AIF | サウンドファイル, Audio Interchange Format | ○¹ ³ |
ANI | Microsoft WindowsのAnimated Cursor（アニメーションカーソル）形式 | ○ |
AU, SND | SunやNeXTで使われるエンコード済みオーディオフォーマット | ○¹ ³ |
AVI, WMV, ASF | Audio Video Interleaved: Microsoft Video for Windows形式 | ○ |
B3D | MAXONのテクスチャツールBodyPaint 3D形式 | ○³ |
BMP, DIB | Windowsビットマップ | ○ | ○
CAM | Casioのデジタルカメラファイル | ○³ (JPGバージョン) |
CLP | Windowsのクリップボード形式 | ○ |
CPT | CorelDraw Photopaint画像 | ○ (CPT バージョン 6) |
CRW, CR2 | Canon RAW 画像 | ○³ |
CUR | Microsoft Windowsのカーソルリソースフォーマット | ○ |
DCM, ACR, IMA | 医用画像向けDicom/ACRファイル形式 | ○³ |
DCX | マルチページPCXファイル形式 | ○ |
DDS | マイクロソフトのDirectDraw Surface（テクスチャやキューブ(環境)マップのファイル形式） | ○³ |
DJVU, IW44 | DjVu画像圧縮方式のファイル形式 | ○³ |
DXF, DWG, HPGL, CGM, SVG | CAD形式 | ○³ |
ECW | Enhanced Compressed Wavelet | ○³ | ○³
EMF | Enhanced Metafile Format | ○ | ○
EPS, PS, PDF, AI | PostScript形式 | ○³ |
EXR | OpenEXR形式（HDRI画像ファイルフォーマット） | ○³ |
FITS | Flexible Image Transport System（天文の世界でデータ交換に使われるデータフォーマットの規格） | ○³ |
FLI, FLC | オートデスクアニメーション形式 | ○² ³ |
FPX | FlashPix形式 | ○³ |
FSH | EA Sports FSH形式 | ○³ | ○³
G3 | 文書伝送用グループ3ファクシミリ装置形式 | ○³ |
GIF | Graphics Interchange Format | ○ | ○
HDP, WDP | Microsoft HD Photo形式 | ○³ |
HDR | High Dynamic Range | ○³ |
ICL, EXE, DLL | アイコンライブラリ形式 | ○ (アイコン) |
ICO | Windowsアイコン | ○ | ○
IFF, LBM | Interchange File Format | ○ |
IMG | GEM Rasterファイル | ○³ |
JLS | JPEG-LS, ロスレスJPEG | ○³ |
JP2, JPC, J2K | JPEG 2000形式 | ○³ | ○³
JPG, JPEG | Joint Photographic Experts Group | ○ | ○
JPM | JPEG2000/Part6, LuraDocument.jpm | ○³ | ○³
KDC | Kodakデジタルカメラ形式 | ○³ |
LDF | LuraDocument Format | ○³ | ○³
LWF | LuraWave Format | ○³ | ○³
Mac PICT, QTIF | Macintosh PICT形式 | ○² ³ |
MED | MED/OctaMEDサウンド形式 | ○³ |
MID, RMI | Musical Instrument Digital Interface (MIDI) | ○³ |
MNG, JNG | Multiple Network Graphics | ○³ |
MOV, MP4 | QuickTime Movie形式 | ○² ³ |
MP3 | MPEGオーディオ レイヤー3形式 | ○³ |
MPG, MPEG | Moving Pictures Experts Group形式 | ○¹ ³ |
MrSID, SID | Multi-Resolution Seamless Image Database. LizardTechのSID Wavelet形式 | ○³ |
DNG, EFF, NEF, MRW, ORF, RAF, DCR, SRF, ARW PEF, X3F, RW2, NRW | DigitalカメラRAW形式 (アドビ, エプソン, ニコン, ミノルタ, オリンパス, 富士フイルム, コダック, ソニー, ペンタックス, シグマ) | ○³ |
NLM, NOL, NGG, OTB, GSM | Nokia LogoManagerファイル | ○³ |
OGG | OGG Vorbis音声ファイルフォーマット | ○³ |
PBM | ポータブルビットマップファイル形式 | ○ | ○
PCX | ZSoft CorporationのPC Paintbrush形式 | ○ | ○
PCD | Kodak Photo CD | ○ |
PGM | Portable Graymapファイル形式 | ○ | ○
PIC | Softimage PICT | ○³ |
PNG | Portable Network Graphics | ○ | ○
PPM | ポータブルピクセルマップ形式 | ○ | ○
PSD | Adobe PhotoShop形式 | ○ |
PSP | Paint Shop Proファイル形式 | ○³ |
RAS, SUN | Sun Raster形式 | ○³ |
RA | RealAudioサウンド形式 | ○³ |
RAW | Raw (バイナリ) データ | ○³ |
RLE | Utah RLE形式 | ○³ |
SFF | Structured Fax File | ○³ |
SFW | Seattle Film Works形式 | ○³ |
SGI, RGB, RGBA | Silicon Graphics形式 | ○³ |
SWF, FLV | Macromedia's Flash/Shockwave形式 | ○³ |
TGA | Truevision Advanced Raster Graphics Adapter (TARGA) | ○ | ○
TIF, TIFF | Tagged Image File Format | ○ | ○
TTF | True Typeフォント | ○³ |
TXT | テキスト (アスキー) ファイル | ○ |
WAD | WAD3ゲーム形式 | ○³ |
WAL | Quake 2 textures | ○³ |
WAV, WMA | Windowsオーディオファイル | ○³ |
WBC/WBZ | WebShots形式 | ○³ |
WBMP | WAPビットマップ形式 | ○³ |
WMF | Windowsメタファイル形式 | ○ |
WSQ | Wavelet Scaler Quantization（指紋認識によく使われる） | ○³ |
XBM | X11ビットマップ | ○³ |
XPM | X11 Pixmap | ○³ |

¹ Microsoft's Active Movieが必要です．

² Apple's QuickTimeが必要です．

³ プラグインが必要です．上述のサイトからダウンロードしてください．


 プラグイン

プラグイン

IrfanViewとPlugInは常に最新版を使ってください．

IrfanViewプラグインのインストールの仕方

  1. IrfanViewのホームページを開いてください．http://www.irfanview.com (またはミラーサイト)
  2. 「PlugIns」に移動します．
  3. プラグインをダウンロードしてください．
  4. プラグインファイルをクリックします．
  5. すると，プラグインがIrfanViewの「PlugIns」フォルダにインストールされます．

ダウンロード

以下のサイトから全プラグインをダウンロードできます．

http://www.irfanview.com/plugins.htm

IrfanViewフォルダにある「i_plugins.txt」も読んでください．プラグインの追加情報が書かれています．

利用可能なプラグイン

8BF_FILTERS IrfanViewでAdobe Photoshopの8BFフィルタを読み込めるようにします．
注：このプラグインは他にシステムDLLが必要です．（「i_pluglins.txt」に記載の詳細を参照してください）
ANSI2UNICODE | IrfanViewでUnicode文字を含むファイル名を読めるようにします．
AWD | IrfanViewでArtweaverファイルを読めるようにします．
B3D | IrfanViewでBodyPaint 3Dファイルを読めるようにします．
BURNING IrfanViewでスライドショーをCDに焼けるようにします．
Windows XP以降が必要です．NeroオプションではData DVDとVCDが焼けます．
CRW IrfanViewでキャノンCRW/CR2ファイル (高解像度画像バージョン)．
注：このプラグインには他にキャノンのDLLが必要です．（「i_pluglins.txt」に記載の詳細を参照してください）
CADIMAGE IrfanViewでCADファイル（DXF, DWG, HPGL, CGM, SVG）を読めるようにします．シェアウェア，サードパーティプラグイン．
注：「i_pluglins.txt」に記載の詳細と，最新版へのリンクを確認してください．
DICOM | IrfanViewでDicomメディアファイル（DCM, ACR, IMA）読めるようにします．
DJVU | IrfanViewでAT&T DJVUファイルを読めるようにします．
EA_FSH | IrfanViewでEA Sports FSHファイルを読み書きできるようにします．
ECW | IrfanViewでECWファイルを読み書きできるようにします．
Effects | 画像に特定の効果を与えられるようになります．
EMAIL | IrfanViewで表示した画像をE-mailとして送信できるようになります．
EXIF | IrfanViewでJPGファイルのEXIF情報を表示できるようにします．
EXR | IrfanViewでEXRファイルを読めるようにします．
Filter Factory | IrfanView でFilter Factory 8BFファイル（Photoshopプラグイン）を使えるようにします．
FLASH | IrfanViewでMacromedia Flash/Shockwaveファイルを読めるようにします．
Formats IrfanViewで以下の珍しい画像形式を読めるようにします．
利用可能な形式： PSP, IFF/LBM, G3, RAS/SUN, Bio-RAD, Mosaic, XBM, XPM, GEM-IMG, WBMP, SGI, RLE, TTF, RAW, CRW, CR2, DNG, NEF, ORF, RAF, MAG, MRW, ERF, DCR, SRF, ARW, PEF, EFF, X3F, DDS, CAM, SFW, WAD, WAL, PIC, FITS, HDR, PVR, SIF
FPX | IrfanViewでFlashPixファイルを読めるようにします．
Filters Unlimited IrfanViewでFilters Unlimitedファイル（Photoshopプラグイン）を使えるようにします．
詳細は「FUnlimited_Readme.txt」を参照してください．
FTP | IrfanViewでサムネイルウィンドウからFTPを使ってファイルを転送できるようにします．
HDP | IrfanViewでHDP/WDPファイル（Microsoft HDフォト）を読めるようにします．
Icons | IrfanViewに関連付けしたファイルの追加アイコンです．
ICS | IrfanViewでICS/IDSファイルを読めるようにします．
IMPDF | IrfanViewでPDFファイルを保存できるようにします．
IPTC | IrfanViewでJPGファイルのIPTC情報やコメントを閲覧/編集できるようにします．
IV_Player でIrfanViewビデオ/サウンド/オーディオCDファイルを再生できるようにします．
利用可能な形式： AVI, MPG, WAV, MIDI, CDA, WMA, ASF, AIF, SND, WMA/WMV, etc.
JPEG2000 | IrfanViewでJPEG 2000ファイルを読み書きできるようにします．
JPEG_LS | IrfanViewでJLSファイル（JPEG-LS, JPEGロスレス）を読み書きできるようにします．
JPG Transformation | IrfanViewでJPGロスレス変換できるようにします．
JPM | IrfanViewでJPMファイルを読み書きできるようにします．
KDC | IrfanViewでKodakデジタルカメラファイルを読めるようにします．
LCMS | IrfanViewでJPG/TIFファイルの埋め込みカラープロファイルを利用できるようにします．
LDF | IrfanViewでLuraDocument LDFファイルを読み書きできるようにします．
LOGOMANAGER IrfanViewでNokia Logo ファイルを読めるようにします．
NLM/NOL/NGG/NSL/OTB/GSM.
LWF | IrfanViewでLuraWave LWFファイルを読み書きできるようにします．
MED | IrfanViewでMED/OctaMEDオーディオファイルを再生できるようにします．
MNG | IrfanViewでMNG/JNGファイルを読み込み/再生できるようにします．
MP3 | IrfanViewでMP3/MP2/MP1ファイルを再生できるようにします．
MPG | IrfanViewでMPEGファイルからフレームを抽出できるようにします．
MRC | IrfanViewでMRCファイルを読めるようにします．
MrSID | IrfanViewでLizardTech's SIDファイルを読めるようにします．
NERO IrfanViewでNero Burning ROMを利用してスライドショーデータやビデオCDを焼くことができます．
ダウンロードはこちら：http://www.nero.com
OCR_KADMOS IrfanViewにOCR機能を追加します．
ダウンロードはこちら：http://rerecognition-download.ch/irfan/kadmos44/KADMOS.htm
訳注：KADMOS OCRは，英語/ドイツ語版のみで，欧州諸語は辞書ファイル選択で文字認識できる物も多いですが，日本語には対応していません．
PAINT | IrfanViewにペイント機能（線・円を描く，画像を整えるなど）を追加します．
PhotoCD | IrfanViewでKodak Photo CDファイルを読めるようにします．
PNGOUT | IrfanViewでPNGを最適化して保存できるようにします．
POSTSCRIPT IrfanViewでPS/EPS/PDF/AIファイルを読めるようにします．
注：Ghostscriptが必要です．http://sourceforge.net/projects/ghostscript/
日本語版：http://auemath.aichi-edu.ac.jp/~khotta/ghost/
QuickTime | IrfanViewでApple QuickTimeムービーを再生できるようにします．（MOV, 3GP, MP4, FLI/FLC）
RA_Player | IrfanViewでRealAudio RAファイルを再生できるようにします．
REGIONCAPTURE | IrfanViewでモニタ上の選択範囲の画面を取り込みできるようにします．
RIOT | IrfanViewでJPG/GIF/PNGファイルを最適化して保存できます．
SFF | IrfanViewでSFF (Structured Fax) ファイルを読めるようにします．
Slideshow | IrfanViewでEXEやSCR形式（スタンドアロン実行形式/スクリーンセーバー）のプレゼンテーションを作成できるようにします．
SoundPlayer | IrfanViewでOGGオーディオファイル（Ogg Vorbis）を再生できるようにします．
VIDEO IrfanViewでビデオ/サウンドファイルを再生できるようにします．
（AVI, MPG/MPEG, WAV, MOV, MID/RMI, AIF, AU/SND, WMA, WMV）
VTF | IrfanViewでVTF (Valve Texture) ファイルを読めるようにします．
WBZ | IrfanViewでWebShots (WBZ/WBC/WB1) ファイルを読めるようにします．
WSQ | IrfanViewでWSQ (Wavelet Scaler Quantization) ファイルを読めるようにします．


 コマンドラインオプション

コマンドラインオプション

コマンドラインオプションを使うと，あらかじめ機能の設定をしつつIrfanViewを起動することができます．

IrfanViewコマンドラインオプション一覧

/one | 起動時に他のIrfanViewが開いている場合は，閉じてから開く．
/fs | フルスクリーンモード
/bf | 「画像をデスクトップに合わせる」モード
/title=text | ウィンドウのタイトルを「text」する．（画像を開かないと反映されません）
/pos=(x,y) | ウィンドウ位置をx,yにする．
/convert=filename | 入力ファイルを「filename」に変換してIrfanViewを閉じる． （パターンの項のファイル名の追加オプション参照）
/slideshow=txtfile | 「txtfile」ファイル記載のファイルリストでスライドショーを再生．
/slideshow=folder | 「folder」内ファイルでスライドショーを再生．
/reloadonloop | ファイルを最後まで再生したらループして再生．（/slideshowオプションで使用）
/filelist=txtfile | インプットファイルとして「txtfile」ファイル記載のファイルリストを使用．下記の例を参照．
/thumbs | サムネイルウィンドウを開く．
/killmesoftly | 全てのIrfanViewを閉じる．
/closeslideshow | 最後まで再生したらスライドショーを終了し，IrfanViewも閉じる．
/page=X | 入力した複数ページ画像のXページを開く．
/crop=(x,y,w,h) | 入力画像を左上位置x, y，幅w，高さhで切り抜く．
/print | 入力画像を標準のプリンタで印刷し，IrfanViewを閉じる．
/print=「Name」 | 入力画像を「Name」で指定したプリンタで印刷し，IrfanViewを閉じる．
/resize=(w,h) | 入力画像を幅w，高さhにリサイズする．
/resize_long=X | 入力画像を，長辺を横としてリサイズする．
/resize_short=X | 入力画像を，短辺を横としてリサイズする．
/resample | リサンプルする（高画質）．（リサイズ時に使用）
/capture=X | モニタ全体またはウィンドウを取り込む．下記の例を参照．
/ini | INI/LSTファイルの読み込み/保存にWindowsフォルダを使用する．
/ini=「Folder」 | INI/LSTファイルの読み込み/保存フォルダに「Folder」を使用する．
/clippaste | クリップボードから画像を貼り付ける．
/clipcopy | クリップボードに画像をコピーする．
/silent | コマンドライン操作時の読み込み/保存で，エラーメッセージを表示しない．
/invert | 画像の色を反転する．（ネガ/ポジ変換）
/dpi=(x,y) | DPI値を変更する，スキャン時のDPI値を設定する．
/scan | TWAIN機器から画像を取得する． - TWAINダイアログ表示．
/scanhidden | TWAIN機器から画像を取得する． - TWAINダイアログ非表示．
/batchscan=(options) | ファイルメニュー→一括メニューをシミュレート．下記の例を参照．
/bpp=BitsPerPixel | 入力画像の色数をBitsPerPixelに変更する．
/swap_bw | 白黒反転する．（入力画像が白黒2値の時のみ反映）
/gray | 入力画像をグレイスケールに変換する．
/rotate_r | 入力画像を右回転する．
/rotate_l | 入力画像を左回転する．
/hflip | 上下反転する．
/vflip | 左右反転する．
/filepattern="x" | ファイル名パターンが「x」のファイル名のみ閲覧する．
/sharpen=X | 画像を開き，シャープフィルタを値Xで適用する．
/contrast=X | 画像を開き，コントラストを値Xで適用する．
/bright=X | 画像を開き，明るさを値Xで適用する．
/gamma=X | 画像を開き，ガンマ補正を値Xで適用する．
/advancedbatch | 画像にINI ファイルから読み込んだ一括変換詳細オプションを適用する．
/hide=X | ツールバー(X=1)、ステータスバー(X=2)、メニューバー(X=4)、キャプション(X=8)を隠す．2つ以上隠したい時は値を足す．下記の例を参照．
/transpcolor=(r,g,b) | GIF/PNG/ICO保存時にrgbを透過色に設定する．
/aspectratio | 画像の比を保持する．（/resizeと/resampleオプションで使用）
/info=txtfile | 画像情報をtxtfileファイル に書き出す．
/fullinfo | EXIF, IPTC, コメントデータを出力する．（/infoオプションで使用）
/append=tiffile | tiffileファイルに画像をTIFページとして追加する．
/multitif=(tif,files) | 入力画像から複数ページTIFを作成する．
/panorama=(X,files) | 入力ファイルからパノラマ画像を作成する． Xは連結方向（1か2）．
/jpgq=X | JPG保存画質をXに指定する．
/tifc=X | TIF保存圧縮形式をXに指定する．
/wall=X | 画像を壁紙にする．
/extract=(folder,ext) | 複数ページファイルから全ページを抽出する．
/import_pal=palfile | palfileをパレットして読み込み，画像に適用する．(PAL形式の時に使用)
/jpg_rotate=(options) | JPGロスレス変換．下記の例を参照．
/monitor=X | 実行形式スライドショーをモニタXで起動する．
/window=(x,y,w,h) | 実行形式スライドショーのウィンドウ位置（左上隅x,y）とサイズ（幅w 高さh）を設定する．
注：
  • コマンドラインオプションは小文字のみです．大文字は使わないでください．
  • ファイル名が必要な場合は，必ず最初のパラメータとして記載してください．
  • ファイル名にスペースを含む場合は，「"」を使用してください．
    例："c:\images\dummy test file.jpg"
  • ファイル名は常にドライブレターを含んだフルパスで記述してください．
  • 1つのコマンドラインで複数のオプションを利用することができます．
  • ワイルドカード(*)は/convert, /print, /info , /jpg_rotateでのみ使用できます．
  • コマンドラインの文字列の長さはWindowsファイルシステムの制限を受けます．ですので，短いファイル名/パスを使ってください．
  • ほとんどの設定はINIファイルから読み込みます．通常のINIと違う設定を使いたい場合は，INIファイルと/ini=folderオプションを利用してください．
  • IrfanViewのexit codeは0です．/convertや/printを使用した場合には，読み込み/保存エラーで1や2になる場合もあります．

変換の例

  • i_view32.exe c:\test.bmp /convert=c:\test.jpg
    「c:\test.bmp」を「c:\test.jpg」に GUIを出さずに変換します．
  • i_view32.exe c:\*.jpg /convert=d:\temp\*.gif
  • i_view32.exe c:\*.jpg /resize=(500,300) /convert=d:\temp\*.png
  • i_view32.exe c:\*.jpg /resize=(500,300) /aspectratio /resample /convert=d:\temp\*.png
  • i_view32.exe /filelist=c:\mypics.txt /resize=(500,300) /aspectratio /resample /convert=d:\temp\*.png
  • i_view32.exe c:\test.bmp /convert=c:\test_$Wx$H.jpg
  • i_view32.exe c:\test.bmp /resize=(100,100) /resample /aspectratio /convert=d:\$N_thumb.jpg
  • i_view32.exe c:\*.jpg /advancedbatch /convert=c:\temp\*.jpg
  • i_view32.exe c:\test.bmp /transpcolor=(255,255,255) /convert=c:\giftest.gif
注： オーディオ/ビデオ形式以外のIrfanViewで読み書きできる全形式をサポートしています．

スライドショーの例

  • i_view32.exe /slideshow=c:\mypics.txt
    注：「c:\mypics.txt」には1行に1ファイル名を記載しておきます．ファイル名はフルパスか「i_view32.exe」からの相対パスで指定してください．
  • i_view32.exe /slideshow=c:\mypics.txt /reloadonloop
  • i_view32.exe /slideshow=c:\images\
  • i_view32.exe /slideshow=c:\images\ /reloadonloop
  • i_view32.exe /slideshow=c:\images\*.jpg
  • i_view32.exe /slideshow=c:\images\test*.jpg

/closeslideshowを使用しない場合は，TXTファイル最後の画像を表示した後，IrfanViewを手動で終了しなければなりません．

/closeslideshow の例

  • i_view32.exe /slideshow=c:\mypics.txt /closeslideshow
    「c:\mypics.txt」記載のファイルを最後まで表示すると，IrfanViewは自動で終了します．

サムネイルの例

  • i_view32.exe c:\test\image1.jpg /thumbs
    「image1.jpg」を開くとともに「c:\test」フォルダのサムネイルを表示する．
  • i_view32.exe c:\test\ /thumbs
    「c:\test」フォルダのサムネイルを表示する．
  • i_view32.exe /filelist=c:\mypics.txt /thumbs
    「c:\mypics.txt」ファイルからファイル名を読み込み，サムネイルとして表示する．

/filelist の例

  • i_view32.exe /filelist=c:\mypics.txt
  • i_view32.exe /filelist=c:\mypics.txt /convert=d:\test\*.jpg
  • i_view32.exe /filelist=c:\mypics.txt /thumbs

/killmesoftly の例

  • i_view32.exe /killmesoftly
    全てのIrfanViewを終了する．

/page の例

  • i_view32.exe c:\test.tif /page=3
    複数ページ画像「c:\test.tif」の3ページ目を開く．

/crop の例

  • i_view32.exe c:\test.jpg /crop=(10,10,300,300)
  • i_view32.exe c:\test.jpg /crop=(10,10,300,300) /convert=c:\giftest.gif
    「c:\test.jpg」を開き，左上位置x=10, y=10, 幅=300, 高さ=300ピクセルで切り出す．

/print の例

  • i_view32.exe c:\test.jpg /print
    「c:\test.jpg」を開き，標準プリンタで画像を印刷してからIrfanViewを閉じる．
  • i_view32.exe c:\test.jpg /print="Printer Name"
    「c:\test.jpg」を開き，「Printer Name」で指定したプリンタで画像を印刷してからIrfanViewを閉じる．
  • i_view32.exe c:\*.jpg /print
    「C:\」フォルダにある全JPGファイルを印刷し，IrfanViewを閉じる．
注：印刷設定はINIファイルの設定を使用します．

/resize の例

  • i_view32.exe c:\test.jpg /resize=(300,300) /resample
    「c:\test.jpg」を開き，幅=300，高さ=300にリサンプルする．
    注：リサンプル設定はINIファイルの設定を使用します．
  • i_view32.exe c:\test.jpg /resize=(300,300) /aspectratio
    「c:\test.jpg」を開き，アスペクト比を保存できるサイズのうち幅=最大300，高さ=最大300になるようリサイズする．
  • i_view32.exe c:\test.jpg /resize_long=300 /aspectratio /resample
    「c:\test.jpg」を開き，長辺=300，短辺=アスペクト比からの計算値になるようリサンプルする．
  • i_view32.exe c:\test.jpg /resize=(300,0)
    「c:\test.jpg」を開き，幅=300，高さ=元サイズでリサイズする．
  • i_view32.exe c:\test.jpg /resize=(300,0) /aspectratio
    「c:\test.jpg」を開き，幅=300，高さアスペクト比からの計算値になるようリサンプルする．
  • i_view32.exe c:\test.jpg /resize=(150p,150p)
    「c:\test.jpg」を開き，幅=150%，高さ=150%にリサイズする．

/capture の例

  • i_view32.exe /capture=0
    画面全体を取り込む．
  • i_view32.exe /capture=5
    取り込みダイアログ設定でキャプチャモードを起動する．

captureの値

  • 0 = 画面全体
  • 1 = マウスのある位置
  • 2 = アクティブウィンドウ
  • 3 = アクティブウィンドウの内側（作業エリア）
  • 4 = マウスで領域選択
  • 5 = 取り込みダイアログ設定でキャプチャモードを起動する．（他のパラメータと同時には指定できません）

応用例

  • i_view32.exe /capture=2 /convert=c:\test.jpg
    アクティブウィンドウを取り込み，「c:\test.jpg」に保存する．
  • i_view32.exe /capture=2 /convert=c:\capture_$U(%d%m%Y_%H%M%S).jpg
    アクティブウィンドウを取り込み，日付の入ったファイル名で保存する．

/ini の例

  • i_view32.exe /ini
  • i_view32.exe c:\test.jpg /ini
  • i_view32.exe c:\test.jpg /ini=「c:\temp\」

/clippaste の例

  • i_view32.exe /clippaste
  • i_view32.exe /clippaste /convert=c:\test.gif

/clipcopy の例

  • i_view32.exe c:\test.jpg /clipcopy
  • i_view32.exe c:\test.jpg /clipcopy /killmesoftly

/invert の例

  • i_view32.exe c:\test.jpg /invert

/dpi の例

  • i_view32.exe c:\test.jpg /dpi=(72,72)

/scan の例

/scan パラメータは/print, /dpi, /gray, /convertとのみ同時に指定できます．

  • i_view32.exe /scan
  • i_view32.exe /scanhidden
  • i_view32.exe /scanhidden /dpi=(150,150)
  • i_view32.exe /scan /convert=c:\test.gif
  • i_view32.exe /scanhidden /gray /convert=c:\test.gif
  • i_view32.exe /print /scan

/batchscan=(options) の例

optionsには一括スキャンダイアログの8つのオプションを指定します．
filename（ファイル名）, index（インデックス）, increment（増分）, digits（桁数）, skip（スキップ）, dest-folder（出力フォルダ）, save-extension（保存形式）, multi-tif（複数ファイルTIF）
  • i_view32.exe /batchscan=(scanfile,1,1,2,1,c:\temp,bmp,0)
  • i_view32.exe /batchscan=(scanfile,1,1,2,1,c:\temp,bmp,0) /dpi=(150,150)
  • i_view32.exe /batchscan=(scanfile,1,1,2,0,c:\temp,tif,1)
  • i_view32.exe /batchscan=(scanfile,1,1,2,1,c:\temp,bmp,0) /scanhidden

/bpp の例

  • i_view32.exe c:\test.jpg /bpp=8
    「c:\test.jpg」を開き，256色に減色します．指定できるBPP値：1, 4, 8, 24（減色/増色）

/filepattern の例

  • i_view32.exe c:\images\ /thumbs /filepattern="*.jpg"
    「c:\images」フォルダを開き，JPGファイルのみをサムネイルに表示する．
  • i_view32.exe c:\images\ /thumbs /filepattern=「123*.jpg」
    「c:\images」フォルダを開き，「123*」という名前のJPGファイルのみをサムネイルに表示する．

/sharpen の例

  • i_view32.exe c:\test.jpg /sharpen=33

Example for /hide

値の意味（加算で複数指定）

ツールバー | 1
ステータスバー | 2
メニューバー | 4
ウィンドウタイトル | 8
  • i_view32.exe c:\test.jpg /hide=1
    「c:\test.jpg」を開き，ツールバーのみ隠す．
  • i_view32.exe c:\test.jpg /hide=3
    「c:\test.jpg」を開き，ツールバーとステータスバーを隠す．
  • i_view32.exe c:\test.jpg /hide=12
    「c:\test.jpg」を開き，ウィンドウタイトルとメニューバーを隠す．
  • i_view32.exe c:\test.jpg /hide=15
    「c:\test.jpg」を開き，上記4カ所全てを隠す．

/info の例

  • i_view32.exe c:\test.jpg /info=c:\test.txt
  • i_view32.exe c:\test.jpg /info=c:\jpgs.txt /fullinfo
  • i_view32.exe c:\*.jpg /info=c:\jpgs.txt

/append の例

  • i_view32.exe c:\test.jpg /append=c:\test.tif
    「c:\test.jpg 」を開き，そのファイルを「c:\test.tif」に追加する．

/multitif の例

記述法: /multitif=(tifname,file1,...,fileN)
最初のファイル名は出力TIFファイル名．
  • i_view32.exe /multitif=(c:\test.tif,c:\test1.bmp,c:\dummy.jpg)
    「c:\test1.bmp」と「c:\dummy.jpg」から複数ページTIF「c:\test.tif」を作成する．

/panorama の例

記述法: /panorama=(X,file1,...,fileN)
最初のパラメータXは連結方向．1 = 水平方向, 2 = 垂直方向
  • i_view32.exe /panorama=(1,c:\test1.bmp,c:\dummy.jpg)
    「c:\test1.bmp」と「c:\dummy.jpg」から水平方向に連結した画像を作成する．

/jpgq の例

  • i_view32.exe c:\test.jpg /jpgq=75 /convert=c:\new.jpg
    「c:\test.jpg」を開き，画質75でファイル名「c:\new.jpg」に保存する．, quality = 75. 画質の範囲は1 - 100．

/tifc の例

  • i_view32.exe c:\test.jpg /tifc=4 /convert=c:\new.tif
    「c:\test.jpg」を開き，圧縮形式Fax4でファイル名「c:\new.tif」に保存する．

圧縮形式：

0 = 無圧縮, 1 = LZW, 2 = Packbits, 3 = Fax3, 4 = Fax4, 5 = Huffman, 6 = JPG, 7 = ZIP

/wall の例

  • i_view32.exe c:\test.jpg /wall=0
    「c:\test.jpg」を開き，壁紙に設定する．（中央に表示）

wallの値

0 (中央に表示), 1 (並べて表示), 2 (拡大して表示), 3 (アスペクト比保存で拡大して表示)

/extract の例

  • i_view32.exe c:\multipage.tif /extract=(c:\temp,jpg)
    「c:\multipage.tif」を開き，全ページを「c:\temp」フォルダに単一JPGファイルとして保存する．

実行形式スライドショーの例

  • MySlideshow.exe /monitor=2
    スタンドアロンスライドショーをモニタ2で実行する．
  • MySlideshow.exe /window=(0,0,800,600)
    スタンドアロンスライドショーを左上隅，ウィンドサイズ800x600で実行する．

/advancedbatch の例

  • i_view32.exe c:\test.jpg /advancedbatch /convert=c:\image.jpg
    （以下の一括変換詳細オプションはサポートされていません：上書き, 削除, サブフォルダ, 全ページ）
    「c:\test.jpg」を開き，INIファイルの一括変換詳細オプションを適用して新しいファイル「c:\image.jpg」に保存する．

/jpg_rotate=(options) の例

optionsにはJPGロスレス変換ダイアログの8つのオプションを指定します．
transformation（反転/回転）, optimize（最適化）, EXIF date（EXIF撮影日付）, current date（現在日付）, set DPI（DPI指定）, DPI value（DPI値）, marker option（マーカーオプション）, custom markers（カスタムマーカー）
注：このパラメータは元画像を上書きします．

値の意味

Transformation | None (0), Vertical (1) ... Auto rotate (6)
Optimize | 0 か 1
Set EXIF date | 0 か 1
Keep current date | 0 か 1
Set DPI | 0 か 1
DPI value | 数値
Marker option Keep all (0), Clean all (1), Custom (2)
カスタムマーカーの値（加算で複数指定）
Keep Comment | 1
Keep EXIF | 2
Keep IPTC | 4
Keep others | 8
  • i_view32.exe c:\test.jpg /jpg_rotate=(6,1,1,0,1,300,0,0)
    自動回転，最適化，EXIF撮影日付は元ファイルの通り，DPI = 300，マーカーは維持．
  • i_view32.exe c:\test.jpg /jpg_rotate=(6,1,1,0,0,0,2,6)
    自動回転，最適化，EXIF撮影日付は元ファイルの通り，EXIFとIPTCマーカーは維持．
  • i_view32.exe c:\test.jpg /jpg_rotate=(3,1,0,1,0,0,1,0)
    90度回転，最適化，現在のファイルの日付，マーカーは全部削除．
  • i_view32.exe c:\images\*.jpg /jpg_rotate=(6,1,1,0,0,0,0,0)
    全JPGファイルについて，自動回転，最適化，EXIF撮影日付は元ファイルの通り，マーカーは維持．


ツールバー

ツールバーを使うとIrfanViewでよく使う機能に素早くアクセスできます．

ツールバーの表示/非表示は，表示メニューのツールバーを選択するたびに切り替わります．ツールバーの画像はリンク先を参照してください．

オプション→基本設定→ツールバーダイアログで別のスキン（ボタンデザイン）を選んだり，ツールバーボタンの追加/削除をしたりすることができます．

IrfanViewホームページにはもっとたくさんのスキンが用意されており，ダウンロードして利用できます．


 開く

開く

ファイルメニューから開くを選択します（またはツールバー上の開くツールを使います）．ダイアログが表示され, IrfanViewで閲覧したいファイルを開くことができます．

ダイアログが表示されたら，ファイルの場所欄からファイルを探すか，ファイル名欄にファイル名を入力してください．ファイルの種類欄で，表示するファイルの種類（例えばJPG）を絞り込むことができます．ファイルの種類欄は初期設定では一般的な画像 ファイルになっています．（注：IrfanViewが扱えるファイル種類すべてを1度に表示できないのでこう表示しています）

プレビューをチェックすると，画像ファイルを一覧上で選択した時に小さな画像でファイルの中身を確認できます．もう一度クリックするとIrfanViewで開くことができます．ファイル名をダブルクリックしても開けます．

ファイルを開かずにダイアログを閉じるには，キャンセルをクリックするか，右上角のXをクリックします．

ファイルを開く操作の後，画像がメイン画面に表示されます．もしIrfanViewで扱えない種類のファイルだった場合にはエラーメッセージが表示されます．

大きな画像を開いた時には，画像全体を見るためにスクロールバーを使います．上下左右の矢印キーやpage up/down, home/endのキーでもスクロールできます．また，マウスの右ボタンでもスクロールできます：右ボタンを押したままマウスを動かします．

関連情報

  • 再読み込み
  • 外部エディタで開く


再読み込み

ファイルメニューの再読み込みを選択すると，最後に開いていたファイルを読み込み直します．ただし，実体のあるファイルに限ります．（削除済みファイル，クリップボード画像をペーストして保存する前の表示画像などは再読み込みできません）

関連情報

  • 開く
  • 外部エディタで開く


 外部エディタで開く

外部エディタで開く

ファイルメニューの外部エディタで開くを選択し，サブメニューから外部エディタを選択すると，そのエディタで画像が開きます．（例：Adobe Photoshop, Paint Shop Proなど）

このメニューを使うには，先に外部エディタを設定しておく必要があります．

関連情報

  • 開く
  • 再読み込み


 形式を指定して開く

形式を指定して開く

ファイルメニューの形式を指定して開くを選択すると，サブメニューが表示されます．

16進形式（HEXファイル）：全ファイル形式をHEXビューアーウィンドウで閲覧できます．

開いたファイルは，全バイトをHEXとASCIIで閲覧できます．（上級ユーザー向け）

アスキー形式：全ASCIIファイル形式（TXT, HTM, INIなど）を開いて，画像として閲覧できます．

RAW 形式：全ファイル形式開き，RAW 画像としての読み込みを試行できます．（上級ユーザー向け，Formats/RAWプラグインを使用します)


 サムネイル

サムネイル

選択したフォルダから画像を1つ開く開きます．ファイルメニューからサムネイルを選ぶと，新しいウィンドウが開き，そのフォルダ内の画像がサムネイル表示されます．

左側にはドライブとフォルダがツリー形式で表示されます．

サムネイルをダブルクリックすると，その画像がメインウィンドウで表示されます．

CTRLキーを押したまま個々のサムネイルをクリックしたり，オプションメニューの全て選択を使用したりして，一度に複数のファイルを選択することもできます．

サムネイルウィンドウを閉じるには，メニューバー上の閉じるをクリックするか，ESCキーを押してください．

ファイルメニュー

選択画像の移動
サムネイル上で選んだファイルを全て別のフォルダに移動します．
選択画像のコピー
サムネイル上で選んだファイルを全て別のフォルダにコピーします．
補足：マウスを使って，ファイルやサムネイルをフォルダツリー上の別のフォルダにコピー/移動させることもできます．WindowsのエクスプローラでやるようにSHIFTキーを押したままファイルを移動させてください．
選択した画像を削除
サムネイル上で選んだファイルを全て削除します．
選択画像でスライドショーを実行
サムネイル上で選んだファイルでスライドショーを開始します．設定は，現在のスライドショー設定を使用します．
注：IrfanViewのスライドショーslideshow.lstファイルは変更されません．
選択画像をスライドショートして保存
サムネイル上で選んだファイルをIrfanViewスライドショーslideshow.lstファイルに保存します．
選択画像を現在のスライドショーに追加
サムネイル上で選んだファイルをIrfanViewスライドショーslideshow.lstファイルに追加します．
選択画像で一括変換を行う
サムネイル上で選んだファイルをリストに入れた状態で一括変換ダイアログを開きます．
選択画像をFTPで送信
FTPダイアログを開き，サムネイル上で選んだファイルを送信する．
選択画像のファイル名をテキストに保存
サムネイル上で選んだファイルのファイル名をテキストファイルに保存する．
JPGロスレス変換
サムネイル上で選んだファイルでJPGロスレス変換ダイアログを開き，JPGファイルを変換します．回転，反転，切り抜き，最適化，JPGコメントやIPTC情報の削除/設定ができます．
注：JPGロスレス変換にはJPG_Transform プラグインが必要です．IPTC情報やJPGコメントの閲覧/編集にはIPTCプラグインが必要です．
選択画像でコンタクトシートを作成
サムネイル上で選んだファイルを並べた大きな画像（コンタクトシート/カタログ）を作成することができます．ダイアログが表示されるので，オプションを選択してください．
選択画像でパノラマダイアログを開く
サムネイル上で選んだファイルでパノラマダイアログを開きます．
選択画像を1枚の画像として保存
サムネイル上で選んだファイルを1画像にして保存します．ダイアログが表示されるので，保存フォルダを選択してください．できあがる画像は，サムネイルウィンドウでの表示を選択画像だけで再現した状態になります．背景色・個々の画像の大きさなどの形式を変えたい場合は，サムネイルのオプション自体を変更してください．
選択画像を個々の画像として保存
選んだファイルのサムネイルでの表示を，個別の画像ファイルとして保存します．ダイアログが表示されるので，保存フォルダを選択してください．
選択画像でHTMLファイルを作成
ウェブブラウザで閲覧したり，インターネット上に公開するためのサムネイルページを作成します．ダイアログが表示されるので，HTMLファイル作成オプションと保存フォルダを指定してください．HTMLファイル作成ヘルプでHTMLファイルに使える変数の情報，例を参照してください．
デフォルトHTMLテンプレートファイルはIrfanViewの「HTML」サブフォルダです．このファイルは編集したり変更したりすることができ，必要のない線・変数を消したり，CSSなど自分の好きなコードを加えたりすることができます．また，違う目的のためにいくつものテンプレートを用意しておくこともできます．
選択画像を一枚ずつ印刷
選択した画像を印刷します（一括印刷）．
選択画像をメールで送信
選択した画像をメールで送信します．（EMail プラグインが必要です）
外部エディタで開く
他のビューアーや編集プログラムで選択表示中の画像を開きます．このオプションを使用するには，外部エディタを先に設定しておくことが必要です．

オプションメニュー

現在のレイアウトと位置を記憶
現在のサムネイルウィンドウのサイズ/位置を保存します．サムネイルウィンドウのサイズ変更/移動はマウスを使って手動で行ってください．
全て選択
サムネイルに表示中のファイルを全て選択します．
サムネイルの設定

サムネイルのサイズや画質を設定することができます．

サムネイル作成時に「リサンプル」する チェックボックスにチェックを入れると，サムネイル表示の画質が良くなります．ただし，画像の表示にかかる時間が長くなります．

サムネイルの大きさでサムネイルの大きさを指定できます．コンボボックスからサムネイルのサイズを選択してください．初期設定は80 x 80ピクセルです．

サムネイルの縁/背景色を指定したり，サムネイルウィンドウの背景色も指定できます．また，また，画面が24bpp（trueカラー）でないときの警告を出さないようにすることもできます．

サムネイル表示で記憶するフォルダの履歴数（最近使ったフォルダ）も指定できます．最近開いたフォルダのリストを消す時は，消去ボタンを押してください．

サムネイルにマウスを乗せた時に画像情報テキストが表示されますが，これを表示しないようにしたり，表示情報をカスタマイズしたりすることができます．テキスト/パターンのヘルプに，利用できるテキストの情報が記載されています．

共通シェルフォルダを表示を有効にすると，フォルダツリービューのドライブの上にデスクトップ, マイ ピクチャなどWindowsの特殊なユーザフォルダが表示されます．設定の変更を反映するには，サムネイルウィンドウの表示を更新してください．

サブフォルダ読込時にフルパスでソートは，サブフォルダを読み込んだ時に，ファイル名のどの部分でソートするかを指定します．パスを含むフルネームか，ファイル名+拡張子だけの短いファイル名か選ぶことができます．短いファイル名でソートすると，複製したファイルを探すのに便利です．

設定をしたらOKボタンを押してください．設定せずにダイアログを終えるにはキャンセルを押してください．

サムネイルをソート
現在のフォルダ内のファイル/サムネイルをソートします．
注：サムネイルは，普通のウィンドウよりもソートオプションが豊富で，EXIF情報の撮影日付や画像の幅/高さなどでもソートすることができます．ソートオプションは保存されず，サムネイルウィンドウを表示中だけ有効です．
注：ドラッグ&ドロップでサムネイルを手動で並べ替えることもできます．1つずつ移動させることも複数一度に移動させることもできます．
テキストファイルからファイルリストを読み込み
カスタムファイル/サムネイルリストを読み込むことができます．（上述のファイルメニュー→選択画像のファイル名をテキストに保存も参照）
全てのサブフォルダのサムネイルを読み込む
現在フォルダのサブフォルダを全て参照して，サムネイルに表示します．

表示メニュー

ディレクトリをツリー上に表示
サムネイルウィンドウ左部にあるディレクトリツリーの表示/非表示を設定します．
最近開いたフォルダ
サムネイルウィンドウ上部にある最近開いたフォルダを選択するコンボボックスの表示/非表示を設定します．
選択サムネイルをリストから削除
サムネイルリスト上から選択中のサムネイルを除外します．非表示にするだけで，ディスク上のファイルは削除されません．
最新の情報に更新
フォルダツリー，フォルダ中の全画像，全サムネイルを更新します．


HTMLファイルの作成

サムネイル - HTMLファイルの作成

IrfanViewインストールフォルダにある「HTML」というフォルダにはテンプレートHTMLファイルが3つあります.

テンプレート1 | thumbnails.html または thumbnails.htm, thumbnails.php, thumbnails.asp →いずれかの拡張子を使用可能
テンプレート 2 | frame.html または frame.htm, frame.php, frame.asp →いずれかの拡張子を使用可能
テンプレート 3 | slideshow.html

テンプレートは編集したり変更したりしてかまいません．要らない行やプレースホルダ/変数を削除したり，CSSスタイルなどのようなコードを加えることができます．また，違った目的のため，フォルダを用意して別々のテンプレートを用意することもできます．

テンプレートファイルはそれぞれイメージ/サムネイルに関するプレースホルダ/変数を含んでいます．IrfanViewはプレースホルダの外観をそれぞれあらかじめ定義されたデータに置換します．

以下の例でテンプレートやプレースホルダをどう使うかを示します．

変数 | 置換結果
File name | 「image1.jpg」 サムネイルウィンドウで選択された画像のファイル名
Thumbs-subfolder | 「thumbs」 サムネイルを格納するサブフォルダ：HTMLファイル作成ダイアログで指定
Thumbs-prefix | 「t」 ファイル名接頭語：HTMLファイル作成ダイアログで指定
Images-subfolder | 「images」 画像を格納するサブフォルダ名：HTMLファイル作成ダイアログで指定

テンプレート 1

thumbnails.html (または thumbnails.htm, thumbnails.php, thumbnails.asp)

使用可能なプレースホルダ/変数

変数 | 置換結果
#TITLE# | ページタイトル (HTMLファイル作成ダイアログで指定)
#BGCOLOR# | サムネイルウィンドウの背景色(サムネイルの設定で指定)
%IMAGE_BEGIN% | サムネイルtableブロックの開始を示し，（プレースホルダ内部に）画像とリンク/データを含む。
#LINK# | ・HTMLでブラウジングを選択しなかった場合→「./images/image1.jpg」 = HTMLファイル出力フォルダからみた画像のパス ・HTMLでブラウジングを選択した場合→「image1.html」 = 画像を含むHTMLファイルのパス
#TARGET# | HTML設定オプション：リンク/画像 表示設定(同一ウィンドウ or 新しいウィンドウ)
#THUMB# | 「./thumbs/t_image1.jpg」 サムネイルへのパス。「サムネイルを格納するサブフォルダ」「ファイル名接頭語」「ファイル名接尾語」はHTMLファイル作成ダイアログで指定したもの。
#TXT_ALIGN# | HTML設定オプション：テキストの整列で指定したもの。
#IMAGE_TEXT# | HTML設定の「ファイル / 情報」で指定した内容。指定にはテキスト/パターンオプションを使うことができる。
%IMAGE_END% | サムネイルtableブロックの終了を示し，（プレースホルダ内部に）画像とリンク/データを含む。
#IMAGE_NAME# | 「image1.jpg」, 画像ファイル名

テンプレート 2

frame.html (または frame.htm, frame.php, frame.asp)

使用可能なプレースホルダ/変数

変数 | 置換結果
#TITLE# | ページタイトル (HTMLファイル作成ダイアログで指定)
#BGCOLOR# | サムネイルウィンドウの背景色(サムネイルの設定で指定)
#PREV_LINK# | 前/左 画像のHTMLファイルへのリンク
#IMAGE_NAME# | 「image1.jpg」, 画像ファイル名
#NEXT_LINK# | 次/右 画像のHTMLファイルへのリンク
#IMAGE# | 「./images/image1.jpg」 - 画像のパス．パスには「HTMLファイルを作成」ダイアログで指定した「画像を格納するサブフォルダ名」が使われる．
#WIDTH# | 画像の幅
#HEIGHT# | 画像の高さ
#IMAGE_TEXT# | HTML設定の「ファイル / 情報」で指定した内容。指定にはテキスト/パターンオプションを使うことができる。
#BACK_LINK# | 開始/サムネイル HTMLファイルへのリンク
#TXT_ALIGN# | HTML設定オプション：テキストの整列で指定したもの。

テンプレート 3

slideshow.html

使用可能なプレースホルダ/変数

変数 | 置換結果
#TITLE# | ページタイトル (HTMLファイル作成ダイアログで指定)
#BGCOLOR# | サムネイルウィンドウの背景色(サムネイルの設定で指定)
#IMAGES# | 一連の画像パス．パスには「HTMLファイルを作成」ダイアログで指定した「画像を格納するサブフォルダ名」が使われる．
#TEXT# | 一連の画像テキスト．初期値は画像ファイル名．
#IMAGE1# | 「./images/image1.jpg」 - 最初の画像のパス


 スライドショー

スライドショー

ファイルメニューからスライドショーを選択すると，表示ファイルを選択するダイアログが開きます．ファイルの場所やファイル名を使ってファイルを探します．ファイルの種類を使うとJPGなどファイルの種類で絞り込みをかけることができます．

使いたいファイルが見つかったらファイルを選択してください．一度に連続するファイルを複数選択したい場合は，まず選択する最初のファイルをクリックし，キーボードのShiftキーを押しながら選択する最後のファイルをクリックします．とびとびのファイルを一度に選択するには，Ctrlキーを押しながら，選択したいファイルをそれぞれマウスでクリックしてください． 選択したら，追加ボタンを押します．全て追加ボタンを押すと，表示しているフォルダ内の画像全てがスライドショーリストに追加されます． 除外や全て除外はスライドショーリストの中の選択ファイルや全てのファイルをリストから削除します．

ソートボタンを押すと，ソート順序を選択する画面が開き，ファイル名，名前（XPスタイル），日付，サイズ，拡張子のどれを使って並び替えるか選択できます．ファイルは昇順にも降順にも並べられます．並び替えを解除するには，そのままのオプションボタンを選択します．

実行ボタンを押すとスライドショーが始まります．

スライドショーを始めずにダイアログを閉じるには，キャンセルボタンか，右上のXボタンを押してください．

詳細設定

自動でスライドを選択すると，指定した時間画像を表示した後に次の画像に自動で移ります．画像を表示する時間は，その右のテキストボックス秒数を入力して指定します．スライドショーは，スライドショー中に使うショートカットキー以外のキー（ESCやEnterなど）で止められます．

マウスかキー入力でスライドを選択すると，キーボードでキーを押すか，マウスを動かすことで次に移動するようになります．操作するまで次の画像に移りません．

ランダムにスライドを選択すると，表示順がランダムになります．表示時間はその右のテキストボックスで指定します．また，スライドショーは，スライドショー中に使うショートカットキー以外のキー（ESCやEnterなど）で止められます．

マウスかキー入力でランダムにスライドを選択すると，キー入力かマウスの移動でランダムに画像を変更します．

ランダムにスライドする際，同じ画像は一度だけ表示されます．

指定時間ごとに自動でスライドする際に表示画像が変わるのを止めるには，Pauseキーを押してください．もう一度，Pauseを押すと，スライドショーが再開します．

表示設定

表示設定にはオプションがいろいろあります．チェックマークが付いているとそのオプションは有効になっています．

開始画像をスライドショーリスト上の順番で指定することができ，初期値は1になっています．終了時に最後のファイルを記憶がチェックされていると，開始画像には前にフライドショーをした時の最後に表示したファイル番号になります．開始画像は直接数字を入力しても良いですし，スライドショーリストをダブルクリックして入力することもできます．

繰り返すにチェックを入れると，リストの最後まで表示したあと引き続き最初からスライドショーが始まります．

エラーファイルは飛ばすをチェックすると，エラーファイルは飛ばされます．

MP3をBGMとして繰り返す.をチェックすると，MP3プラグインがインストールされていればMP3ファイルをBGMに使うことができます．MP3ファイルは次のMP3が読み込まれるかスライドショーが終わるまで繰り返されます．

マウスカーソルを隠すをチェックするとスライドショーをしている間はマウスカーソルが見えなくなります．

スライドショー終了時にIrfanViewを閉じるをチェックすると，最後の画像を表示後にスライドショーが終了し, IrfanViewも終了します．

表示設定の右側はテキストを表示というオプションがあります．このオプションを選択すると，画像が画面に表示されている間，その画像のファイル情報が表示されます．IrfanViewは，名前，サイズ，日時，EXIF/IPTC情報など，いろいろなファイル情報を表示することができます．テキストを表示オプションの下にあるテキストボックスで表示テキストを指定できます．指定に使えるテキスト変数はここで確認してください．

スライドショーの保存など

スライドショーは後でまた使うために保存しておくことができます．画像を選択し，スライドショーを開始すると, IrfanViewは次の名前のファイルを生成します．

Slideshow.lst

このファイルはIrfanViewのフォルダに生成されます．このファイルはIrfanViewに読み込まれまた使われます．

テキストファイルに保存ボタンを押して，好きな場所にファイルリストを保存することができます．名前を付けて保存ダイアログが現れるので，スライドショーに名前をつけて保存を押し，設定を保存してください．

保存したスライドショーリストはテキストファイルから読込むボタンで読み込むことができます．開くダイアログでファイルを探し，開くを押して読み込んでください．

スライドショーをEXEファイルやSCRファイル（単独で動作するスクリーンセーバー）として保存することもできます．まず，スライドショーを作成して実行してみてください．スライドショーのオプションが意図したとおりに動作しているのを確認したら，EXE/SCRファイルで保存ボタンを押してください．できあがっこファイルは単独で動作するので，簡単に配布することができます．この機能を使うためにはスライドショー プラグインをインストールしておかなければなりません．

EXEファイル作成でよくあるエラーは，入力ファイルが読み取れないことと，ファイル生成先のディスク（tempフォルダ＝一時ファイル作成フォルダ）がいっぱいになっていることです．

注：EXE/SCRに埋め込んだ動画や音声ファイルは，DirectXその他のWindowsにインストールしたオーディオドライバ/コーデックを利用して再生され, IrfanViewのプラグインは使用されません．

Windows XP（もしくはそれ以降）かNero Burning ROM (OEM版ではなく，製品版か無料体験版)をインストールしているなら，スライドショーをCD（データCD）に焼いたり，ビデオCD（VCD）を作成したりできます．その場合，Burning/Nero プラグインをインストールしておく必要があります．CDに書き込みボタンを押して，指示に従ってください．

スライドショーの設定はIrfanViewを使わずに作成して，後からIrfanViewに読み込むこともできます．作成には，Windowsのメモ帳のようなプレインテキストを扱うことのできるテキストエディタを利用します．設定ファイルにはスライドショーで表示したい画像の名前を1行に1ファイル名ずつ書いていきます．ファイル名はディスク上のフルパスで書きます．例えば，次のような書き方になります．

C:\Images\myimage.jpg

ファイルを作成したら，ディスクの好きな場所に保存してください．使用する時は, IrfanViewを起動し，スライドショーダイアログを開いて，テキストファイルから読込むボタンを使います．コマンドラインオプションを使って，ビューアーを開かずにスライドショーを始めることもできます．


 CDからスライドショーを起動する

CDからIrfanViewのスライドショーを起動するには？

Top Previous Next

方法1

Windows XP（もしくはそれ以降）かNero Burning ROM (OEM版ではなく，製品版か無料体験版)をインストールしているなら，一番簡単な方法は以下の通りです．

  1. スライドショーダイアログでスライドショーを作成し，動作を確認します．
  2. スライドショーダイアログのCDに書き込みボタンを押します．（注：Burning/Nero プラグインをインストールしておく必要があります）
  3. 作成オプションを選択します．データCD/DVDの作成が初期値（推奨）です．
  4. 空のCD-R/CD-RWをドライブに挿入し，CD/DVDを作成します．

方法2

手動での作成，特殊なスライドショーCDの作成

  1. IrfanViewファイルをCDのルート（一番上の階層）フォルダにコピーします．（設定の保存されたINIファイル"i_view32.iniもコピーします）
  2. 画像をCD内の任意のフォルダ（例えばフォルダ名「images」）にコピーします．
  3. スライドショーダイアログかテキストエディタを利用して，画像ファイル名を書いたTXTファイルを作成します． 画像ファイルが「image1.jpg」, 「image2.jpg」, etc. の場合，TXTは以下のように書きます．
    .\images\image1.jpg
    .\images\image2.jpg
    etc.

    ファイル名は1行1ファイルで相対パスで書きます．（コピーしたi_view32.exeからの相対パスです）

    TXTファイルを「slideshow.txt」などの名前でCDのルートフォルダに保存します．

  4. テキストエディタで「autorun.inf」ファイルを作成します．以下の2行を書いてください．
    [AutoRun]
    open = i_view32.exe /slideshow=slideshow.txt

    「autorun.inf」を保存します．

  5. ソフトウェアでCDを作成してください．


 一括変換 形式/名前

一括変換 形式/名前

入力ファイルの選択

ファイルメニューから一括変換 形式/名前を選択します．ダイアログが表示されるので，変換したいファイルがあるフォルダを選択します．ファイルの場所，ファイル名 ，ファイルの種類を使って絞り込みながら画像を探してください．

変換したいファイルが見つかったらファイルを選択してください．一度に連続するファイルを複数選択したい場合は，まず選択する最初のファイルをクリックし，キーボードのShiftキーを押しながら選択する最後のファイルをクリックします．とびとびのファイルを一度に選択するには，Ctrlキーを押しながら，選択したいファイルをそれぞれマウスでクリックしてください．

選択したら，追加ボタンを押します．全て追加ボタンを押すと，表示しているフォルダ内のファイルの種類で指定した拡張子を持つ画像全てが追加されます．除外や全て除外ボタンで，リストの中の選択ファイルか全てのファイルをリストから削除します．

下層フォルダを含めるにチェックしてから全て追加を押すと，下層フォルダから指定した種類のファイルが全て検索されてリストに追加されます．

ファイル読込ボタンでTXTファイルからファイル名を読み込みます．テキストファイルには1行ごとに1画像ファイル名をフルパスで書いておきます．

保存フォルダの設定

保存フォルダは左側中ほどに設定するところがあります．保存フォルダのフルパスが分からなければ，参照ボタンを押して探すことができます．ダイアログでフォルダを見つけたら，フォルダを選択をしてOKボタンを押すと保存フォルダ欄にパスが入力されます．

現在のディレクトリを使用ボタンを押すと，ダイアログ右側に表示しているフォルダが保存フォルダになります．

保存フォルダに入力フォルダと同じフォルダを使うときは，注意してください．オプションの中にはうまく機能しないものもあります（例：詳細設定全てのページに変更を適用（TIF 保存時））．エラーが起きた場合，置換後のファイルを元に戻すことはできません．

ファイル形式の一括変換

左側のリストボックスで変換後の形式を選択してください．この指定は上書保存や名前を付けて保存と同じように機能します．この右にある設定 ボタンでファイル形式特有の保存オプションを指定することができます．これも上書保存や名前を付けて保存と同じように機能します．

詳細設定を使用にチェックをして詳細設定ボタンを押すと，画像変換時にさまざまな操作を加えることができます．このオプションは画像メニューでの操作に近いです．加えられる操作は次の通りです．

切り抜き，リサイズ，色数の変更，色を自動補正，左右反転，上下反転，左回転，右回転，グレイスケールに変換，ネガ/ポジ 反転，シャープ，明るさ，コントラスト，ガンマ補正，彩度，カラーバランス，など
一括リサイズの補足：幅も高さも例えば640に指定し，アスペクト比を保存オプションを有効にすると，変換画像のサイズは比はそのままで幅 = 最大640，高さ = 最大640になるよう調整されます．

新しくフォルダを作成して格納オプションを使うと，保存先のフォルダに元のファイルパスと同じようなフォルダ構造を作成して保存します．

注：一括変換モードでは複数ページPDFへの変換はまだサポートしていません．名前を付けて保存メニューを利用してください．

ファイル名の一括変換

元/入力ファイルの名前を変更したり，名前を変更しながら元ファイルをコピー/移動したりすることができます．ファイル名変換には，名前の形式を利用し連番を振りながら新しい名前を付けていくことができます．

ファイル名変換の際は，最初にダミーファイルでオプションを試すなどして十分注意してください．一括変換はとても強力なツールですが，その分，危険です．不適切な名前の形式を, 画像を保存フォルダに移動して変更や入力画像を直接変更，同じ名前のファイルがあれば上書きするオプションと共に使うと，場合によっては全入力/元ファイルが無くなってしまう可能性があります．これらのオプションは，どうなるのか本当に分かっている場合にしか使わないでください．

補足：新しい名前に例えば3桁で連番を付けたい場合は，名前の形式に3回「#」を書いてください．
例：image_###という形式を1番から始めると，生成ファイルの名前は、「image_001 」, 「image_002」...となります．

名前の形式の右にある設定ボタンを押すと，ファイル名の一括変換の設定ダイアログが開き，詳細な設定ができます．

設定をしたらOKボタンを押します．指定せずにダイアログを終えるにはキャンセルを押します．

ファイル形式の一括変換後にファイル名の一括変換を行う

このオプションは，通常のファイル形式の一括変換とファイル名の一括変換の組み合わせ です．出力ファイルの名前の形式も指定できます．

実行ボタンを押すと変換が始まります．変換の進行状況を示すボックスが表示されます．止めたい時は中止ボタンを押します．変換が終わったら，閉じるを押してダイアログを閉じます．

ファイルの変換はコマンドラインオプションを使って，ビューアーを開かずに行うこともできます．

ファイルを変換せずにファイル形式の一括変換ダイアログを閉じるには，キャンセルか右上のXを押してください．


 ファイル検索

ファイル検索

ファイルメニューからファイル検索を選択すると，検索オプションを指定するダイアログが開きます．オプションにはファイル名，検索場所，ファイルの日付，検索文字列を指定できます．

ファイル名形式の例

* | 全ファイル
*.* | *と同じ
*.jpg | JPGファイルのみ
123*.jpg | 123という名前で始まるJPGのみ
*123.jpg | ファイル名のどこかに123を含むJPGのみ
image | 名前に「image」という文字列を含むファイルのみ

テキスト検索：EXIF情報（JPG，TIF，RAW形式）やIPTCデータ/コメント内（JPGs）のテキストも検索できます．

単語を複数入力すると，いずれかの単語を含むファイルが全て検索結果に表示されます．（OR検索）


 名前の変更

名前の変更

ファイルメニューから名前の変更を選ぶと，ダイアログが開きます．新しい名前を入力してOKを押してください．ビューアー上とハードディスク（あるいは他のメディア上）の両方でファイル名が変更されます．変更せずに終わるときは，キャンセルを押します．

注：このダイアログは最後の位置を保存します．


ファイルの移動

ファイルメニューから移動を選択すると，表示中のファイルを他のフォルダに移動することができます．

移動に利用するため基本設定の「移動」するデフォルトディレクトリをあらかじめ設定し，全てのファイルを同じフォルダに移動させることもできますし，移動前に確認するオプションを有効にして， 個々のファイルの移動先を指定するダイアログを表示することもできます．

移動するファイルダイアログには移動先ディレクトリを複数定義しておくことができます．

関連情報

  • 基本設定→ファイル操作


ファイルのコピー

ファイルメニューからコピーを選択すると，表示中のファイルを他のフォルダにコピーすることができます．

コピーに利用するため基本設定の「コピー」するデフォルトディレクトリをあらかじめ設定し，全てのファイルを同じフォルダにコピーさせることもできますし，コピー前に確認するオプションを有効にして， 個々のファイルのコピー先を指定するダイアログを表示することもできます．

コピーするファイルダイアログにはコピー先ディレクトリを複数定義しておくことができます．

関連情報

  • 基本設定→ファイル操作


 ファイルの削除

ファイルの削除

ファイルメニューから削除を選択すると，表示中のファイルをハードディスク（もしくは他のメディア）から削除することができます．選択と同時に削除されますので，気をつけてください．

初期設定ではファイルはゴミ箱に移動しますが，基本設定→ファイル操作でこの動作を変更することができます．

誤ってファイルを削除した場合は，すぐに画像を保存し直してください．

関連情報

  • 基本設定→ファイル操作


上書保存

ファイルメニューから上書保存を選択すると，ディスクにファイルを保存できます．

基本設定→ファイル操作で[ファイル]→[保存]メニューで保存ダイアログを表示オプションを有効にすると，上書保存を選択したとき保存ダイアログが表示されるだけになります．保存する場所とファイル名を使って，保存したいフォルダを探してください．

ファイルを別の形式で保存するには，ファイルの種類欄を使ってください．右にある▼をクリックして，ファイルの種類のドロップダウンメニューを表示させ，保存したいファイルの種類を選択します．保存を押すと，ファイルは指定した形式に変換されます．

設定ダイアログを表示にチェックをするとECW, GIF, ICO, JP2, JPG, JPM, LDF, LWF, PBM, PGM, PNG, PPM, RAW, TIFFで保存するときには追加のダイアログが自動的に表示され，設定オプションを選ぶことができます．

保存を押すとファイルが保存されます．保存せずにダイアログを終了するときは，キャンセルを押します．

注： 保存ダイアログは，最後に読み込んだ画像のあるフォルダが表示された状態で開きます．名前を付けて保存ダイアログは，最後にファイルを保存したフォルダが表示された状態で開きます．

関連情報

  • 名前を付けて保存
  • JPEG/GIF 保存設定
  • JPEG2000 保存設定
  • JPM 保存設定
  • LDF 保存設定
  • LWF 保存設定
  • PNG / PBM/PGM/PPM / ICO 保存設定
  • TIFF 保存設定


名前を付けて保存

ファイルメニューから名前を付けて保存を選択すると（もしくは ツールバーから名前を付けて保存ツールを使用すると），ディスクにファイルを保存できます．保存する場所とファイル名を使って，保存したいフォルダを探してください．

ファイルを別の形式で保存するには，ファイルの種類欄を使ってください．右にある▼をクリックして，ファイルの種類のドロップダウンメニューを表示させ，保存したいファイルの種類を選択します．保存を押すと，ファイルは指定した形式に変換されます．

設定ダイアログを表示にチェックをするとECW, GIF, ICO, JP2, JPG, JPM, LDF, LWF, PBM, PGM, PNG, PPM, RAW, TIFFで保存するときには追加のダイアログが自動的に表示され，設定オプションを選ぶことができます．

保存を押すとファイルが保存されます．保存せずにダイアログを終了するときは，キャンセルを押します．

注：名前を付けて保存ダイアログは，最後にファイルを保存したフォルダが表示された状態で開きます．保存ダイアログは，最後に読み込んだ画像のあるフォルダが表示された状態で開きます．

関連情報

  • 上書保存
  • JPEG/GIF 保存設定
  • JPEG2000 保存設定
  • JPM 保存設定
  • LDF 保存設定
  • LWF 保存設定
  • PNG / PBM/PGM/PPM / ICO 保存設定
  • TIFF 保存設定


Web用に保存

ファイルメニューからWeb用に保存を選択すると，RIOT プラグインを使ってJPG, GIF, PNG形式で最適化した画像を保存することができます．

RIOTダイアログでファイルサイズなど画像最適化オプションを選ぶことができます．

RIOTは，Radical Image Optimization Toolの略で，画像を比較しながら最適化できるソフトウェアです．IrfanViewにはそのLite版DLLが同梱されています．

RIOTのサイトからはExtended版DLLが無償でダウンロードできます．Extended版はLite版より高速で，機能も追加されています．

また，j10npのRIOT日本語化言語ファイルにはRIOTを日本語化するDLLがあります．ダウンロードファイルからRiot.JPを解凍し，RIOT.DLLがあるフォルダ（IrfanViewのPluginsフォルダ）にコピーしてください．


 JPEG/GIF 保存設定

JPEG/GIF 保存設定

JPEG

ダイアログ上半分でJPG画像の保存画質を設定します．スライダコントロールを動かして好きな設定にします．低い方に設定すると，ファイルサイズは小さくなりますが，低画質になります．高い方に設定すると，高画質になりますが，ファイルサイズが大きくなります．初期設定は80で，たいていの画像に適します．

グレイスケールで保存にチェックを付けると，画像をグレイスケールで保存します．このオプションを有効にしたかどうか忘れないでください．

Click the プログレッシブJPG形式で保存で保存をチェックすると，インターネット上でよく使われる，粗い状態からだんだん鮮明になってくる形式で保存できます．

元画像のEXIF情報/IPTC情報/JPGコメントを新しいJPGファイルに保存するかどうかも制御することができます．このオプションは，JPGから別のJPGに変換/保存する時にのみ使用できます．他の画像形式にするとき（たとえばEXIF/IPTCデータ付きのTIFやRAWにするとき）には，まだこのオプションを使うことができません．

RIOTプラグインをインストールしていれば，保存後のファイルサイズをだいたいのbyte数で指定することもできます．

GIF

ダイアログ下半分はGIF画像の設定です．

インターレースで保存をクリックすると，インターネット上でよく使われる，粗い状態からだんだん鮮明になってくる形式で保存できます．

透過GIFで保存はGIFの透過を設定します．

透過色を設定して保存を選んで保存を押すと，透過色を選択ダイアログが表示され，プレビュー画像を見ながら透過色を設定することができます．

透過設定をする色のパレット番号を選んだ場合は，透過色をパレット番号で設定します．詳しい情報は，パレットの編集を参照してください．Trueカラー画像の場合，パレットを表示するには，まず減色を使って256色にする必要があります．

注：IrfanViewではアニメーションGIF形式は保存できません．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 JPEG2000 保存設定

JPEG2000 保存設定

JPEG2000

オプションボタンから，JP2画像の画質を選択します．QualityかCompress to bytesを選んだ時は，値を入力します．Lossless compressionを選ぶと画像を劣化することなく保存します．（＝最高画質）

注：JPEG2000で保存するにはJPEG2000 プラグインが必要です．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 JPM 保存設定

JPM 保存設定

JPM

画像/色のタイプ別に標準的なプロファイルオプションが5つありますので，どれかを選択してください．また，出力JPM画像の画質も設定することができます．

プレビューを高速化するためにJPM画像にサムネイルを埋め込みたい場合は，Save thumbnailオプションにチェックしてください．

マルチページJPM画像を作りたい場合は，表示メニューから複数のページの画像→複数ページのJPMを作成をクリックしてください．

注：JPM出保存するにはJPM プラグインが必要です．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 LDF 保存設定

LDF 保存設定

LDF [LuraDocument Format]

画像/色のタイプ別に標準的なプロファイルオプションが5つありますので，どれかを選択してください．また，出力LDF画像の画質も設定することができます．

プレビューを高速化するためにLDF画像にサムネイルを埋め込みたい場合は，Save thumbnailオプションにチェックしてください．

マルチページLDF画像を作りたい場合は，表示メニューから複数のページの画像→複数ページのLDFを作成をクリックしてください．

注：LDF出保存するにはLDF プラグインが必要です．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 LWF 保存設定

LWF 保存設定

LWF [LuraWave Format]

オプションボタンから，LWF画像の画質を選択します．Quality，Compression Rate，Compress to bytesを選んだ時は，希望の値を入力します．Lossless compressionを選ぶと画像を劣化することなく保存します．（＝最高画質）

小さな画像を素早く表示するProgressive modeにするか，大きな画像に適したBaseline modeにするかも設定します．

注：LWFで保存するにはLWF プラグインが必要です．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 PNG / PBM/PGM/PPM / ICO 保存設定

PNG / PBM/PGM/PPM / ICO 保存設定

PNG

PNG画像向けに，圧縮レベルと（GIF/ICOと同様の）透過色を設定します．

注：PNGはGIFと同じく可逆圧縮フォーマットで，GIFと違ってTrueカラーをサポートしています．たいていの場合，スクリーンショットを取る際には理想的な形式です．なぜなら，そういう画像ではJPGなどよりファイルサイズが小さく，画質を劣化させずに保存でき，扱えるソフトも多いためです．

透過色を保存を選んで保存を押すと，透過色を選択ダイアログが表示され，プレビュー画像を見ながら透過色を設定することができます．

PNGを最適化するため，PNGOUT プラグインを利用することもできます．最適化でファイルサイズを小さくすることができます．

PBM, PGM, PPM

PBM/PGM/PPMのエンコードタイプをオプションボタンで設定します．アスキーコードで符号化するとファイルサイズはかなり大きくなります．

ICO

保存の際にプレビューをクリックして，透過ICO画像で保存することができます．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 TIFF 保存設定

TIFF 保存設定

TIFF

TIFFの圧縮形式をオプションボタンから選択します．左側はカラー画像用，右側は白黒画像用のオプションです．

画像編集ソフトの中にはパレット付きのグレースケールTIFをうまく扱えない物があります．その場合は，グレイスケール画像のためのパレット保存オプションを外してパレットを無効にしてください．

複数ページ画像を開いている場合は，元画像の全ページを保存を有効にすると，入力画像の全ページを出力TIFに保存します．

オプションを設定してから保存をクリックし，画像を保存すると，設定も保存されます．ファイルや設定を保存せずに終える場合はキャンセルを押してください．

新しい設定は変更するまで有効になります．

関連情報

  • 上書保存
  • 名前を付けて保存


 印刷

印刷

ファイルメニューから印刷を選ぶと，印刷設定ダイアログが表示されます．

プリンタを選択し，左側のオプションボタンで印刷の向きを選択してください．画像が縦に印刷されるか横に印刷されるかはプレビューで確認できます．

プリンタ設定ボタンで用紙サイズやプリンタの設定を変更できます．

オプションボタンで画像をどう印刷するかさらに細かく設定できます．

元のサイズを選択すると，画像のDPIから計算し，元のサイズで印刷します．DPI情報がない画像の場合は72DPIとして計算します．

注：画像が用紙サイズより大きい場合は，表示部分だけ印刷されます．

ページに合わせるを選択すると，サイズ比が変わらない範囲でできるだけ大きく印刷します．

注：アスペクト比が使用されます．

ページいっぱいに伸ばすを選択すると，印刷範囲いっぱいに画像をひきのばします．必要なら領域いっぱいにするためにどちらか一方だけでも画像を引き延ばします．

注：アスペクト比は使用されません．

カスタムを選択すると，サイズを指定して印刷できます．希望の幅，高さ，左余白，上余白をcmかインチで設定してください．

注：画像の最大値は用紙サイズまでで，アスペクト比を保存するオプションも選択できます．

倍率指定で画像サイズを指定することもできます．数値を指定してください．1.00がオリジナルサイズです．

注：最大画像サイズは用紙サイズまでです．

中央に配置にチェックをすると，画像を用紙中央に印刷します．

オプションを有効にすると，ヘッダーやフッターにファイル名など指定の文字列を印刷することができます．使用できる変数はテキスト/パターン オプションを参照してください．

印刷部数も設定することができます．

注：プレビューには印刷可能領域しか表示されません．元画像をエリア選択し，枠が表示されたまま印刷をすると，選択された部分しか印刷されません．

オプションを選択したら，印刷を押してください．

印刷せずに終える場合はキャンセルを押してください．


TWAIN対応機器の選択

ファイルメニューからTWAIN対応機器の選択を選択すると，コンピュータにインストールされた，スキャナその他のTWAINに準拠した機器（デジタルカメラ，ビデオカードなど）からソースを選択することができます．

注：このダイアログはWindowsによるもので, IrfanViewが表示しているものではありません．

使いたい機器を選んだら選択ボタンを押してください．選択せずに終える場合は，キャンセルをクリックしてください．

関連情報

  • スキャン/一括スキャン
  • コピー作業


 スキャン/一括スキャン

スキャン/一括スキャン

ファイルメニューからスキャン/一括スキャンを選びます．

1枚だけ読み取る場合

1枚だけ読み取る場合は，単一画像を選択してください．スキャナその他のTWAINに準拠した機器（デジタルカメラ，ビデオカードなど）を操作するプログラムが表示されますので，スキャナのマニュアルに従って，画像を読み取ってください．

読み取りが終わると，画像がIrfanViewに表示されます．

複数枚読み取る場合

連続して複数枚読み取る場合は，複数画像（一括モード）を選択肢，以下を設定してください．

  • 出力ファイル名
  • 出力ファイルに付ける連番の開始番号
  • 出力ファイルに付ける連番の増分（負の数値も指定できます）
  • 出力ファイルに付ける連番の桁数
  • すでに存在するファイル名を飛ばす（上書きしない）
  • 最後のスキャン番号を記憶（新しい開始番号に設定）
  • 出力フォルダ
  • 保存形式

出力ファイル形式にTIFフォーマットを選んでいる場合は，複数ページ画像として保存を選択して，読み取った画像を1ファイルで保存することもできます．

OKを押すと，スキャナその他のTWAINに準拠した機器（デジタルカメラ，ビデオカードなど）を操作するプログラムが表示されますので，スキャナのマニュアルに従って，画像を読み取ってください．

読み取った画像は出力フォルダに画像ファイルとして保存されます．ファイル名は設定の通り，例えば「読み取り画像01.bmp」，「読み取り画像02.bmp」...のように付けられます．

読み取りが終わると，画像がIrfanViewに表示されます．

関連情報

  • TWAIN対応機器の選択
  • コピー作業


 コピー作業

コピー作業

ファイルメニューからコピー作業を選ぶと，印刷設定ダイアログが表示され，スキャナその他のTWAINに準拠した機器（デジタルカメラ，ビデオカードなど）から取り込んだ画像を直接することができます．

TWAIN対応機器の選択ボタンで，リストからTWAINに準拠した機器（普通はスキャナ）を選ぶことができます．

プリンタに取り込み画像を送る前にプレビューを見たい場合は，TWAINプレビューダイアログを表示をチェックします．

画像を読み取るときのDPI値を設定します．初期値は100です．たいてい，選択したプリンタの解像度の1/2を設定しておくと，ちょうど良いようです．

選択ボタンで使用するプリンタと，そのプリンタの詳細設定をすることができます．

コピー枚数に印刷する枚数を設定します．

注：印刷時の設定は，印刷メニューのダイアログで設定したものが使用されます．

全て設定したら実行を押します．選択もコピーもせずに終える場合は，キャンセルを押してください．

関連情報

  • 印刷
  • TWAIN対応機器の選択
  • スキャン/一括スキャン


 最近開いたフォルダ

最近開いたフォルダ

ファイルメニューから最近開いたフォルダを選ぶと，サブメニューに最近使ったフォルダの名前が表示されます．その中から1つ選択すると，選択したフォルダを開いた状態で開くダイアログが表示され，そこから好きなファイルを開くことができます．

最近開いたフォルダリストは基本設定のその他にあるボタンで消去することができます．


終了

メインウィンドウでESCキーを押すと，プログラムはすぐに終了します．メニューやダイアログボックスを開いているときにESC を押すと，開いているダイアログボックスが閉じてメインウィンドウに戻りますので, IrfanViewを終了したい場合は，もう一度ESC を押してください．

ファイルメニューを表示してXキーを押すか，ファイルメニューから終了を選んでもIrfanViewを終了できます．

ウィンドウ左上にあるIrfanViewのロゴアイコンを押すと，Windows標準のメニューが出ますので，そこから閉じるを押してもIrfanViewを終了できます．また，ロゴアイコンをダブルクリックしたときも，すぐにIrfanViewを終了します．

ウィンドウ右上のXを押してもプログラムが終了できます．

注：初期設定では終了時に変更を保存するかどうか尋ねず，すぐに閉じます．保存したい画像は必ず先に保存してください．終了時に注意が出るようにするには，基本設定→開始 / 終了の終了時に変更を保存するか尋ねるオプションを有効にしてください．


元に戻す

編集メニューから元に戻すを選ぶか，ツールバーの元に戻すツールを使うと，最後にした操作を元に戻すことができます．元に戻すでIrfanViewのいろいろな操作を取り消すことができますが，1段階しか元に戻すことが来ません．オプション→基本設定のブラウジング / 編集でこの機能を使えなくすることもできます．

元に戻すを使用できる機能

  • 自動色彩調整
  • カスタム回転
  • グレイスケールに変換
  • 切り出し
  • 切り取り
  • 減色
  • 色調補正
  • 増色
  • ネガ/ポジ 反転
  • リサイズ/リサンプル
  • ペイントダイアログ
  • フィルタ 全て

訳注：と書いてあるけど，フィルタは元に戻らない気がする．


ペイントダイアログ

ペイントダイアログを表示（IrfanPaintプラグイン）

Top Previous Next

編集メニューからペイントダイアログを表示選んでください．

概要

IrfanPaintはIrfanViewのペイント用プラグインで，Irfan Skiljanと共同してMatteo Italiaが作成しました．このプラグインで，外部エディタを使わずに基本的な描画作業を行うことができます．

IrfanPaintのバージョンが最新かどうか確認してください．IrfanPaintウェブサイトから最新版をダウンロードできます．

Tips & tricks

  • 拡張ツールチップ（ [image] ）を選んでからマウスポインタを各ツールの上に動かすと，簡単な説明を表示することができます．ツールチップ上のテキストサイズはWindowsのデスクトップの外観の設定で変更することができます．
  • ペイントツールバーは磁石のようにウィンドウにくっつきます．IrfanViewウィンドウのどちら側にもドラッグでき，そこにスナップできます．大きな画像を読み込んだりウィンドウサイズを手動で変更した場合，ウィンドウと一緒に位置が移動します． 訳注：Windows Vistaでこの挙動が確認できず．
  • メインウィンドウがアクティブな時にCtrlとShiftを押しながらマウスホイールをスクロールさせるとツールを切り替えることができます．
  • PaintbrushやLineツールで描画中にShiftを押しながらマウスホイールをスクロールさせると，ペンの太さを変えることができます．

ツール

クイックリファレンス

選択 ツールの効果を選択範囲に限る
ブラシ 左/右 = 描画色/背景色
消しゴム 左/右 = 背景色/元の色に戻す
クローンブラシ ソースとした部分をターゲットにコピーする
色の置き換え 色の置き換え
テキストツール テキストを挿入する
直線 Shift/Controlで制限された直線
矢印 ツールバーを右クリックで矢印のスタイル設定
楕円 Shift = 円; Control = 起点を中央に
長方形 Shift = 正方形; Control = 起点を中央に
塗りつぶし 左/右 = 描画色/背景色
色の選択 描画色/背景色を画像から選択
回転 引いた直線が水平線になるように画像を回転
ものさし 引いた直線が水平線になるように画像を回転
ペン/ブラシ設定 線や塗りつぶしの種類
ツールチップヘルプの拡張 ツールチップにツールの名前だけ表示するか説明を表示するか
IrfanPainについて バージョン情報，製作者の表示
幅 ブラシサイズの設定
許容値 近似色とみなす許容値を設定
塗りつぶしチェックボックス 楕円ツール/長方形ツールで使用．
背景色 クリックで色を変更
描画色 クリックで色を変更

詳細説明

名前 外観 説明
選択

選択ツールを選択後，IrfanViewウィンドウに戻って選択や切り抜きなどができます．ブラシや塗りつぶしなどのIrfanPaintツールは，選択領域外には効果が適用されません．
ブラシ

左ボタンを使うと描画色で描画され，右ボタンを使うと背景色で描画されます．線幅を変更するにはシフトキー押しながらマウスホイールをスクロールするか，ツールボックス上の「幅」コントロールを使用してください．
消しゴム

マウス左クリック&ドラッグで画像を部分削除し，背景色に置き換えます．マウス右クリック&ドラッグで画像の描画部分削除し，元画像に置き換えます．削除幅を変更するにはシフトキー押しながらマウスホイールをスクロールするか，ツールボックス上の「幅」コントロールを使用してください．
クローン

右クリックでクローンソースを定義します．左クリック&ドラッグで描画先を定義し，ソースのコピー描画を開始します．クローンツールの幅を変更するにはシフトキー押しながらマウスホイールをスクロールするか，ツールボックス上の「幅」コントロールを使用してください．
色の置き換え

色の置き換えツールはドラッグした部分に描画色/背景色があった場合に，色の入れ替えを行うツールです．左ボタンでドラッグすると，背景色を描画色に置き換えます．右ボタンでドラッグすると描画色を背景色に置き換えます．色の置き換えツールの幅を変更するにはシフトキー押しながらマウスホイールをスクロールするか，ツールボックス上の「幅」コントロールを使用してください．許容値フィールドを使うと，置換色の許容範囲を調整できます．
テキスト
ツール

テキストツールは画像に整形テキストを挿入します．テキストカーソルの十字ポインタが挿入テキストのベースラインになります．\n挿入場所を起点として左寄せ，右寄せ，中央揃えを指定することができます．

画像をテキストカーソルでクリックすると，テキストの挿入ダイアログが開き，テキストや，個々の文字のフォント/サイズ/色，テキスト描画の種類，配置を指定できます．

Unicode文字も使用できます．

テキストは，縁だけの白抜き，縁の中を背景色で塗りつぶした白抜き形式，通常のテキスト，アンチエイリアスをかけたテキストから選ぶことができます．白抜きのを選ぶとテキストカラーアイコンがブラシ設定のアイコンに変化し，線と塗りのスタイルを設定することができます．

ダイアログ中のテキストは，スタイルや色も保存された形でクリップボードにコピーできます．

押している間元画像にプレビューボタンを使うと，画像中に整形したテキストを表示してみることができます．テキストの大きさが大きすぎないか，色のコントラストが適当かなどを確認してからOKボタンを押してテキストを挿入してください．
直線

マウス左クリック&ドラッグで描画色で直線を描画します．クリック後に直線の描画を中止する場合は右クリックしてください．SHIFTキーを押しながらドラッグすると直線の角度が45°の倍数になります．CTRLキーを押しながらドラッグすると起点が直線の中心になります．直線の幅を変更するにはシフトキー押しながらマウスホイールをスクロールするか，ツールボックス上の「幅」コントロールを使用してください．ブラシ設定で直線のスタイルや直線の終点のスタイルを変更できます．
矢印

使い方は直線ツールに準じます．矢印ツールボタンの上で右クリックすると起点と終点の矢印のスタイルを設定することができます．
楕円/円

クリック&ドラッグで楕円を描画します．SHIFTキーを押しながらドラッグすると円を描画します．CTRLキーを押しながらドラッグすると起点が楕円の中心になります．右クリックで描画をキャンセルできます．
長方形/
正方形

クリック&ドラッグで長方形を描画します．SHIFTキーを押しながらドラッグすると正方形を描画します．CTRLキーを押しながらドラッグすると起点が長方形の中心になります．右クリックで描画をキャンセルできます．
塗りつぶし

左クリックすると領域を描画色で塗りつぶします．右クリックすると領域を背景色で塗りつぶします．選択ツールを使用してから塗りつぶしを使用すると，その部分だけを塗りつぶします．許容値フィールドを使うと塗りつぶしの許容値を設定することができます．（推奨値：40）
色の選択

左クリックでクリック部分の色を描画色に設定します．右クリックでクリック部分の色を背景色に設定します．色の選択ツール使用後は，すぐに前に使用していたツールにフォーカスが戻ります．フォーカスを戻したくないときは．SHIFTキーを押しながらクリックしてください．
傾き修正/
回転

直線に沿ってドラッグするか，2点を指定してください．指定によって定義された直線が，画像回転後の水平もしくは垂直になります．画像の回転によって生じたキャンバスの空白部分は，現在の背景色で塗りつぶされます．IrfanViewのカスタム回転に使われる背景色でなく，IrfanPaintの背景色が使われます．
ものさし

クリック&ドラッグで距離を測りたい部分の始点と終点を指定してください．測定角度は水平線からの角度になります．クリック後に測定を止める場合は右クリックしてください．CTRLキーを押しながらドラッグすると起点が線の中心になります．SHIFTキーを押しながらドラッグすると線の角度が45°の倍数になります．ものさしツールボタンの上で右クリックすると「単位の設定」ダイアログが開きます．このダイアログで新しい単位を定義したり，既存の単位を編集/削除/並び替えしたりできます．
ペン/ブラシ
設定

ブラシ設定を開き，線や塗りのスタイル，線の先端の形状を設定することができます．この設定は，ブラシ，直線，矢印，楕円，長方形ツールに適用されます．

線の種類，線の幅，線の端の形状，線の接点（角）の形状，線の色，網掛けの種類を設定することができます．

背景タブは線の囲む領域の指定で，色や網掛けの種類を設定することができます．網掛け描画部以外の色が抜ける部分の色も指定ができ，背景色でテキストを描画した際のハイライト効果を得るために透過にすることもできます．（右ボタンを使用したブラシツールでの描画など）

主線が無いように見せるため，線と塗りつぶしに同じ色とハッチングを使うこともできます．

縁だけの白抜きテキストと，縁の中を背景色で塗りつぶした白抜きテキストもここでのブラシ設定を使用します．よほど大きな文字でない限り，線幅は1,2ピクセルにしたほうが良いでしょう．

プレビューにはおおよその設定結果を表示します．プレビューをクリックすると，前景（線）と背景の形状が入れ替わります．
ツールチップ
ヘルプの拡張

ボタン上にマウスポインタを合わせた時に表示するツールチップの内容を選択します．このボタンが押されていない時にはツールの名称を，押されている時にはツールの説明文を表示します．
IrfanPaint
について

IrfanPaintプラグインのバージョン，翻訳の情報，クレジット表示，最新版入手先IrfanPaintウェブサイトへのリンク．
線の幅

線の幅をピクセル値で指定します．直接数値を入力しても良いですし，マウスのスクロール，スピンボタン，上下キーなどでも調整できます．線幅は関係ツール使用中にも，シフトキーを押しながらマウスホイールをスクロールすることで変えることができます．
許容値

この数値を高くすると，色の置き換えツールや塗りつぶしツールで置き換えられる色の範囲が広くなります．0にすると選択したピクセルと完全に同じ色（1色）しか置き換えません．255は全色の意味で，画像全体を塗り替えます．
塗り

矢印，楕円，長方形ツールで使い，塗りつぶしにするか輪郭線にするかを選択できます．
カラーペイン

前面になっている長方形をクリックすると，描画色を設定できます．

背面にある長方形をクリックすると，背景色を設定できます．

右上の小さな両矢印をクリックすると，描画色と背景色が入れ替わります．

著作表示

このページのオリジナルテキストはBhikkhu Pesalaが作成しました．それをMatteo Italiaが引き継ぎ，画像を追加しました．


 選択範囲の指定

選択範囲の指定

編集メニューから選択範囲の指定を選ぶと，ダイアログが表示され, IrfanViewに読み込んだ画像上で範囲選択（長方形の枠）を指定することができます．

指定する時に位置，幅/高さ，アスペクト比を設定することができます．

画像上で既に選択範囲を指定している場合，現在選択中の値が表示された状態でダイアログが表示されます．

また，マウスでも選択範囲を指定することができます．マウスカーソルを選択したい範囲の角に置き，左ボタンを押すと，マウスポインタが二重十字形になります．そのままマウスを対角方向へドラッグすると，マウスの動きに合わせて枠ができます．希望の範囲になったら，マウスボタンを離してください

選択範囲の指定を取り消す場合は，枠の外にマウスカーソルを持っていくと通常のマウスポインタになりますので，そこで左クリックしてください．

マウスカーソルを選択枠の中に持っていくと，マウスポインタは虫眼鏡の形になり，そこで左クリックすると，選択範囲を拡大します．

選択枠の大きさを変える時は，マウスを修正したい辺の境界線上に合わせ，マウスポインタが細い二重矢印になったところでマウスの左ボタンを押し，そのまま境界線をドラッグします．CTRLキーを押しながら大きさを変更すると，変更前の比を保持したままリサイズすることができます．

もし，マウスボタンの設定を入れ替えている場合は上記の左ボタンの変わりに右ボタンを使ってください．

選択範囲の位置を変えたい場合は，選択範囲内でマウスの右ボタン（設定を入れ替えている場合は左）を押し，マウスポインタが細い二重十字形になったところでドラッグし，好きな場所に移動させてマウスボタンを離します．

選択範囲の左上座標，大きさ，アスペクト比はタイトルバー/キャプションに表示されます．

関連情報

  • 切り取り
  • 切り出し
  • コピー
  • 貼り付け
  • 選択範囲にテキストを挿入
  • 赤目補正


選択範囲を最大化と中央寄せ

選択範囲枠を表示していると，編集メニューから選択範囲を最大化と中央寄せを使用することができます．このメニューで設定中の選択枠のアスペクト比を保持したまま選択範囲を最大化して中央寄せにすることができます．

注：CTRLキーを押しながら選択範囲を最大化と中央寄せをクリックすると，サイズは変えずに中央寄せだけ行います．


 選択範囲にテキストを挿入

選択範囲にテキストを挿入

テキストを挿入したい画像上で範囲選択をします．編集メニューから選択範囲にテキストを挿入を選ぶと，ダイアログボックスが表示されます．

左側にあるテキストボックスに画像に挿入したいテキストを入力してください．

フォントの選択ボタンを押すと，テキストのサイズ，フォント，色などを変えることができます． 使用中のフォントはテキストボックスの下にあるフォント欄に表示されます．

テキストの透過表示のチェックを外すと背景色を選ぶことができ，選択範囲内に色が付きます．背景色の選択ボタンで色を選んでください．指定中の背景色は，ボタンの左に表示されます．

OKボタンで画像にテキストが挿入されます．テキストを挿入せずに終える場合はキャンセルを押してください．

選択範囲にテキストを挿入は編集メニューの元に戻すで取り消すことができます．

関連情報

  • 選択範囲の指定
  • テキスト/パターン オプション


 切り取り

切り取り

選択範囲の切り取り

範囲選択をし，編集メニューから選択範囲の切り取りを選ぶか，ツールバーの選択領域の切り取りツールを使うと，画像から選択範囲内部が削除されます．削除された部分は初期設定では黒色で塗りつぶされます．切り取り部分はクリップボードにビットマップ画像として保存され，他の場所，他のソフト上に貼り付けることができます．

選択範囲以外を削除

範囲選択をし，編集メニューから選択範囲以外を削除を選ぶと，選択枠の外側の画像が削除され，定義した色で塗りつぶされます．

注：切り取り時の背景色は基本設定→ブラウジング / 編集で設定することができます．

切り取りは編集メニューの元に戻すで取り消すことができます．

関連情報

  • 切り出し
  • コピー
  • 貼り付け
  • 選択範囲の指定


 切り出し

切り出し

選択範囲を切り出す

範囲選択をし，編集メニューから選択範囲を切り出すを選択すると，選択枠の外側が無くなり，内部だけが残り，画像の大きさが変わります．

この機能は，画像から必要の無い部分を取り除いたり，写真の構図を直したりすることに使うことができます．

縁を自動切り取り

編集メニューから縁を自動切り取りを選択すると，画像の同じ色の部分/枠を削除します．

切り出しは編集メニューの元に戻すで取り消すことができます．

補足： JPG画像の場合は，オプション→JPG ロスレス切り抜きを利用した方が画質を保つことができます．

関連情報

  • 切り取り
  • コピー
  • 貼り付け
  • 選択範囲の指定


 コピー

コピー

範囲選択をし，編集メニューから選択範囲をコピーを選ぶか，ツールバーの選択範囲をコピーを使うと，選択部分がクリップボードにビットマップ画像として保存され，他の場所，他のソフト上に貼り付けることができます．

範囲を選択せずに画像全体がクリップボードにコピーされます．

関連情報

  • 切り取り
  • 切り出し
  • 貼り付け
  • 選択範囲の指定


 貼り付け

貼り付け

範囲選択をし，編集メニューから選択範囲を貼り付けを選ぶか，ツールバーの貼り付けを使用します．

画像上で範囲選択を行っている場合は，クリップボードに保存されたビットマップファイル，メタファイル，テキストが選択範囲内に貼り付けられます． クリップボードの内容が画像だった場合，選択範囲の大きさに合わせて大きさが変更され，選択範囲外の画像には変更が加わりません．この機能は画像編集時にとても便利です．選択範囲に貼り付けのオプションは，基本設定→ブラウジング / 編集で変更することができます．

範囲選択を行っていない場合は，画像全体をクリップボードの内容と入れ替えます．画像はクリップボードに保存しているサイズになり，リサイズは行われません．

関連情報

  • 切り取り
  • 切り出し
  • コピー
  • 選択範囲の指定


 画像を閉じる

画像を閉じる

編集メニューから画像を閉じるを選ぶと, IrfanViewで表示している画像を閉じます．このメニューで画像に変更が加えられることはありません．


 クリップボードを消去

クリップボードを消去

編集メニューからクリップボードを消去を選択すると，クリップボードの内容が削除されます．


 画像の情報

画像の情報

画像メニューから画像の情報を選ぶかツールバーの画像の情報ツールを使うと，画像の情報ウィンドウが開き，以下の画像情報が表示されます．

  • ファイル名
  • ファイルの場所
  • フルパス
  • 圧縮形式
  • 解像度：DPIの値を変更して変更を押すと解像度を変更できます．
  • 元の大きさ（幅/高さ：ピクセル）
  • 現在の大きさ（幅/高さ：ピクセル）
  • 印刷サイズ（cmかインチ：画像のDPIから算出）
  • 元の色数（BitsPerPixel）
  • 現在の色数（BitsPerPixel）
  • 使われている色の数
  • ディスク上のサイズ（KB）
  • メモリ上のサイズ（KB）
  • フォルダ内の順位
  • ファイルの更新日時
  • 表示に要した時間

EXIF情報の付いたJPG/TIF/DigiCam-RAW画像を読み込んでいる場合は，左下にEXIF 情報ボタンが表示されます．ボタンをクリックすると，別のウィンドウが開き，画像に関する公開情報を全て見ることができます．

カーソルを上下させて情報をスクロールさせてください．ファイル変更日時，画像サイズ，絞り，ズームレンズ設定，画質設定，シャッタースピード，フラッシュの使用，ISOスピード，CCD設定，カメラのメーカーや型番などが分かります．テキスト/パターン オプションのEXIFタグリストを参照してください．この情報はテキスト（.txt）形式です．テキストを選択してクリップボードにコピーできますので，ワードプロセッサソフトに貼り付けて印刷したり，写真のあるフォルダに保存して後で参照することができます．

注：EXIF情報を扱うにはEXIF プラグインが必要です．

JPG画像を読み込んでいる場合は，左下にIPTC 情報ボタンが表示され，IPTC情報を表示/編集することができます．IPTCの編集は画質劣化のない操作ですので，JPG画像自体は変更されません．TIF/DigiCam-RAW形式ファイルのIPTCデータも表示することはできますが，まだ編集機能はありません．

注：IPTC情報を扱うにはIPTC プラグインが必要です．

JPG画像を読み込んでいる場合は，右下にコメントボタンが表示され，JPGコメントを表示/編集することができます．コメントの編集は画質劣化のない操作ですので，JPG画像自体は変更されません．

注：JPGコメントを扱うにはIPTC プラグインが必要です．
注：JPGファイルを読み込んでいて，EXIF/IPTC/コメントデータが既にある場合は，「*」印がそれぞれのボタン上のテキスト横に表示されます．

情報の表示を終わらせる場合はOKボタンを押してください．


 新規作成

新規作成

画像メニューから新規作成を選ぶと，ダイアログが表示され，新たな（空の）画像を作成することができます．

ダイアログでは画像の幅/高さ，色数(BPP)かグレイスケール，背景色（初期値は黒）を指定できます．


 パノラマ画像の作成

パノラマ画像の作成

画像メニューからパノラマ画像の作成を選ぶと，ダイアログが表示され，画像を水平方向か垂直方向に連結してパノラマ画像を作成することができます．

連結したい画像を入力画像欄に指定します．連結される画像はリストに挙げたものだけで，表示中の画像には連結されません．リスト先頭の入力画像は以降の画像のベースとして使用されます．

入力画像それぞれの左上にファイル名を入れたり，画像間にスペースを追加（初期値は0ピクセル＝スペース無し）したりすることもできます．


 回転

左回転 / 右回転 / カスタム回転

左回転

画像メニューから左回転を選択すると，画像が90度左回りに回転します．（画像上側が左側になります）

右回転

画像メニューから右回転を選択すると，画像が90度右回りに回転します．（画像上側が右側になります）

補足： JPG画像の場合は，オプション→JPG ロスレス切り抜きを利用した方が画質を保つことができます．

カスタム回転

画像メニューからカスタム回転を選択すると，ダイアログが表示され，-360°から360°までの好きな角度で画像を回転させることができます．

画像は正の値（例：30）を入力すると右に，負の値（例：-30）を入力すると左に回転します．数を大きくすればするほど画像は大きく回転します．初期値は45です．また，回転でできた空白を埋める色も指定することができます．

注：カスタム回転はEffects プラグインをインストールしている時だけ使用することができます．

関連情報

  • 上下反転
  • 左右反転


 上下反転

上下反転

画像メニューから上下反転を選ぶと，画像左右の位置は元のままで上下が逆になります．

補足： JPG画像の場合は，オプション→JPG ロスレス切り抜きを利用した方が画質を保つことができます．

関連情報

  • 左右反転
  • 左回転 / 右回転 / カスタム回転


 左右反転

左右反転

画像メニューから左右反転を選ぶと，画像鏡のように左右が逆になります．

補足： JPG画像の場合は，オプション→JPG ロスレス切り抜きを利用した方が画質を保つことができます．

関連情報

  • 上下反転
  • 左回転 / 右回転 / カスタム回転


 リサイズ/リサンプル

リサイズ/リサンプル

画像メニューからリサイズ/リサンプルを選ぶと，ダイアログが表示され，画像の新しいサイズを指定することができます．リサンプルフィルタは，画像を拡大する場合だけ使用できます．

一般的な大きさは選択肢として用意しました．また，数値を入力することもできます．初めの数字が幅，2番目の数字が高さで，どちらもピクセルです．アスペクト比に保存にチェックを付けると，一方に数字を入力した時，もう一方に自動で計算値が入力されます．

リサンプルを選ぶと，高画質になります．特に拡大時に効果的です．リサイズの方を選ぶと，リサンプルせずに処理しますので，ぼやけた画像になる可能性があります．

注：リサンプルフィルタは拡大時にのみ使用されます．縮小時には特定の高速なリサンプルフィルタを使用します．

OKを押すと，画像をリサイズします．

リサイズは編集メニューの元に戻すで取り消すことができます．


 縁の追加

縁の追加

画像メニューの縁の追加を選ぶと，画像の周りに縁をつけて画像サイズを拡げることができます．ダイアログが開いたら，画像の各辺に付ける縁のサイズと縁の色を指定してください．

注：縁の追加はEffects プラグインをインストールしている時だけ使用することができます．

OKを押すと画像に縁が付きます．

縁の追加は編集メニューの元に戻すで取り消すことができます．


 増色

増色

画像メニューから増色を選ぶと，選択可能な色数がダイアログに表示されるので，1つ選択してください．

OKを押すと色数が変わります．

増色は編集メニューの元に戻すで取り消すことができます．

関連情報

  • 減色


 減色

減色

画像メニューから減色を選ぶと，選択可能な色数がダイアログに表示されるので，1つ選択してください．

OKを押すと色数が変わります．

減色は編集メニューの元に戻すで取り消すことができます．

関連情報

  • 増色


 グレイスケールに変換

グレイスケールに変換

画像メニューからグレイスケールに変換を選ぶと，画像をモノクロにできます．

グレイスケールは，厳密にはRGBのようなカラーモードの1種で，白黒2階調よりも情報量が多い写真です．カラーからグレイスケールへの変換は，カラーから白黒にするよりも，たいてい奇麗な効果を得ることができます．

グレイスケールに変換は編集メニューの元に戻すで取り消すことができます．


 ネガ/ポジ 反転

ネガ/ポジ 反転

画像メニューからネガ/ポジ 反転を選ぶと，画像の色が元と逆の色に反転します．

注：範囲選択してからネガ/ポジ 反転を選ぶと，選択範囲だけ色を反転させることができます．

ネガ/ポジ 反転は編集メニューの元に戻すで取り消すことができます．


 色調補正

色調補正

画像メニューから色調補正を選ぶと，スライダコントロールのあるダイアログが表示されます．このスライダコントロールを左右に動かして，明るさ/コントラスト/ガンマ補正/彩度/RGBバランスの値を増やしたり減らしたりすることができます．

注：これらの効果は範囲選択を行って部分的に適用することもできますし，画像全体に適用することもできます．
色調補正はEffects プラグインをインストールしている時だけ使用することができます．

画像の変化を見ながらスライドコントロールを動かして調整することができます．元画像に変更を適用ボタンを押すと，元画像に変更を適用してみることができますが，この段階ではまだ変更が本当に適用されたわけではありません．

次の画像にも同じ変更を加えたいときは，終了時に値を保存を押してダイアログ中の色の値を保存してください．

納得のいく結果になったら，OKを押してください．画像を変更せずに終える場合はキャンセルを押してください．

色調補正は編集メニューの元に戻すで取り消すことができます．

注：このダイアログは最後のサイズ/位置を保存します．


 ヒストグラム

ヒストグラム

画像メニューからヒストグラムを選んでください．画像のヒストグラムを示すダイアログが表示され，ヒストグラムを見たいカラーチャンネルを選ぶことができます．

ヒストグラムを見終わったら，Exitを押してください．


 自動色彩調整

自動色彩調整

画像メニューから自動色彩調整を選択すると，明るさとガンマ値から自動計算して画像の明るさを改善します．

注：画像の主要な部分を範囲選択してからこのメニューを選択すると，選択範囲にだけ適用することができます．また，範囲選択をしたあとでCTRLキーを押しながらメニューを選択すると，計算は選択範囲の明るさ・ガンマ値から行いますが，効果は全体に適用します．

自動色彩調整は編集メニューの元に戻すで取り消すことができます．


 赤目補正

赤目補正

画像メニューから赤目補正を選択してください．

このメニューは範囲選択をしている時のみ使用でき，選択範囲の赤みを減少させます．効果の強さはフィルタの設定で変更できます．

フィルタの設定ダイアログを使うと猫/犬など向けにGreen Eye ReductionやYellow Eye Reductionも行うことができます．

赤目補正は編集メニューの元に戻すで取り消すことができます．


 フィルタ

フィルタ

画像メニューからフィルタを選択すると，種々の効果メニューが表示されます．

注： Filter Factory以外の効果は全て，画像全体に適用するだけでなく，選択した一部分だけに適用することもできます．画像に効果を適用するには，それぞれのフィルタ プラグインが必要です．

フィルタで適用した効果は全て，編集メニューの元に戻すで取り消すことができます．

訳注：と書いてあるけど，戻せない気がする．

利用可能な効果

立体ボタン

画像メニューからフィルタを選択し，立体ボタンをクリックしてください．

画像の周りにベベル（斜角）が加えられ，中央が盛り上がったようになります．縁の太さはフィルタの設定で変更することができます．

ぼかし

画像メニューからフィルタを選択し，ぼかしをクリックしてください．

ぼやけたような外観になり，画像がソフトになります．ぼかし量はフィルタの設定で変更することができます．

エンボス

画像メニューからフィルタを選択し，エンボスをクリックしてください．

背景が灰色になり，彫刻を施したような外観になります．

油絵画

画像メニューからフィルタを選択し，油絵画をクリックしてください．

油絵具で描いたようなテクスチャ効果を与えます．テクスチャの適用量はフィルタの設定で変更することができます．

輪郭検出

画像メニューからフィルタを選択し，輪郭検出をクリックしてください．

画像から主線を検出し，その色を補色に置き換えると同時に塗りを暗くして背景にします．画像は「ベルベットに描いた」ような外観になります．適切な効果を得るには，色数が256色以下でなければなりません．

中間値フィルタ

画像メニューからフィルタを選択し，中間値フィルタをクリックしてください．

ピクセルグループの明るさを「平均」化します．ほとんどの場合，この操作で画像が「滑らか」になります．フィルタの適用量はフィルタの設定で変更することができます．

点描

画像メニューからフィルタを選択し，点描をクリックしてください．

暗いピクセルが破裂し，画像が粉砕されたようになります．ほとんどの場合，この操作で画像はまるで点描のようになります．点描の適用量はフィルタの設定で変更することができます．

モザイク

画像メニューからフィルタを選択し，モザイクをクリックしてください．

ピクセルを大きく作り替えたかのように，画像を荒くします．モザイクの適用量はフィルタの設定で変更することができます．

セピア

画像メニューからフィルタを選択し，セピアをクリックしてください．

画像の彩度を落とし，茶色の色調にしてセピア風になります．

水滴

画像メニューからフィルタを選択し，水滴をクリックしてください．

ランダムに水滴を落としたような効果を画像に与えます．

その他のメニュー

フィルタの設定

画像メニューからフィルタを選択し，フィルタの設定をクリックしてください．ダイアログが開き，いろいろなフィルタについて，設定をすることができます．詳しい説明はフィルタの設定のヘルプを参照してください．

Adobe 8BFフィルタ

画像メニューからフィルタを選択し，Adobe 8BFフィルタをクリックしてください．ダイアログが開き, Adobe Photoshop用プラグイン・8BFフィルタをIrfanView上で利用できます．このメニューを使うには，8BF_Filters プラグインが必要です．

フィルタファクトリー

画像メニューからフィルタを選択し，フィルタファクトリーをクリックしてください．ダイアログが開き, Adobe Photoshop向けにフィルタファクトリーで作成した8BFファイルをIrfanView上で利用できます．このメニューを使うには，FFactory プラグインが必要です．詳しい説明はフィルタファクトリーのヘルプを参照してください．

Filters Unlimited

画像メニューからフィルタを選択し，Filters Unlimitedをクリックしてください．このメニューを使うには，Funltdiv プラグイン (Filters Unlimited) が必要です．また，利用したいフィルタをhttp://www.icnet.deから入手してインストールしなければなりません．詳しい説明は，IrfanViewのPlugInsフォルダにあるFUnlimited_Readme.txtを参照してください．


 フィルタの設定

フィルタの設定/フィルタ一覧

画像メニューからフィルタを選択し，フィルタの設定をクリックしてください．ダイアログが開き，いろいろな特殊効果フィルタのオプションを，設定をすることができます．フィルタを利用するには，それぞれ対応するプラグインが必要です．

設定を終えたらOKを押してください．設定変更せずに終える場合はキャンセルを押してください．

Apply to original imageボタンで適用した効果は，編集メニューの元に戻すで取り消すことができます．

訳注：と書いてあるけど，元に戻らない気がする．設定ダイアログのUndoも利かない．

設定

Blur

ぼかしフィルタでどれぐらいの効果を適用するかを設定します．1 - 99までの値を指定でき，値が大きいほど粗くなります．初期値は30です．

Emboss

エンボスフィルタを適用した時の画像の浮き上がり/彫り込み加減を設定します．-255 - 255までの値を指定でき，値の絶対値が大きいほど深く彫り込んであるようになります．値をマイナスにすると色の明るい部分が盛り上がり，値をプラスにすると色の暗い部分が盛り上がります．

Oil Paint

油絵画フィルタでどれぐらいの効果を適用するかを設定します．0 - 255までの値を指定でき，値が大きいほどタッチが粗くなります．初期値は50です．

Edge Detection

油絵画フィルタで，どれぐらいの明暗差があったときに輪郭線と判断するかを設定します．0 - 5の値を指定できます．初期値は1です．

Median filter

中間値フィルタで，どれぐらいの効果を適用するかを設定します．3 - 9の値を指定でき，値が大きいほどピクセルの明るさを平均化し，ほとんどの領域で見た目がよりソフトになります．初期値は3です．値が大きいほど処理に時間がかかります．

Explosion

点描フィルタで，どれぐらいの効果を適用するかを設定します．1 - 99の値を指定でき，値が大きいほどピクセルの乱し方が大きくなります．初期値は3です．値が大きいほど処理に時間がかかります．

Pixelize

モザイクフィルタで，どれぐらいの効果を適用するかを設定します．2 - 50の値を指定でき，値が大きいほど粗いモザイクになります．初期値は5です．値が大きいほど処理に時間がかかります．

Sharpen

シャープで，どれぐらいの効果を適用するかを設定します．2 - 50の値を指定でき，値が大きいほど画像がよりシャープになります．初期値は30です．

3D Button

立体ボタンフィルタで作成するベベルの幅を設定します．1 - 99の値を指定でき，初期値は15です．

Red Eye Reduction

赤目補正で，赤色をどのぐらいの強度にするか設定します．-127 - 127の値を指定でき，値が大きいほど赤みが軽減する量は少なくなります．初期値は0です．

（その他いろいろ）


 フィルタファクトリー

フィルタファクトリー

注： フィルタファクトリーはプラグインによる機能です．以下からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

重要：IrfanView単体ではオリジナルのPhotoshop 8BFファイルは読み込めません．フィルタファクトリープラグインを利用できるのは，Filter Factoryで作成した8BFファイルです．以下のサイトなどで入手できます．
  • http://www.stevesdesktopphotography.com
  • http://hno.freeshell.org/download.htm

訳注：2009.8.30現在どちらもリンク切れ．

画像メニューからフィルタを選択し，Filter Factoryをクリックしてください．ダイアログが開き，読み込んだフィルタ効果をコントロールできます．

Parametersスライダでフィルタのコントロールをします．スライダを左右に動かして，該当するフィルタの画像への適用量を増減します．たいていのフィルタでは，右に動かすと効果加減が大きくなり，右に動かすと小さくなります．Default slider valuesボタンを押すと，フィルタの製作者が決めた初期値になります．

Filter groupsリストにはフィルタグループを保持しておくことができます．使用可能なフィルタグループの名前が全て表示され，グループを追加したり削除したりできます．

Filtersリストには選択したフィルタグループで使われているフィルタの名前が表示されます．また，リストにフィルタを追加することもできます．フィルタのパラメータ構成を見るためにはリスト上の名前をクリックしてください．プレビューでフィルタを適用した時の画像を見ることができます．フィルタを元の画像に適用するときは，Apply to imageボタンを押してください．適用した効果はUndo filterボタンか編集メニューの元に戻すで取り消すことができます．

訳注：と書いてあるけど，戻せない．

Add FF filterボタンでフィルタを追加します．ダイアログボックスが開きますので，フィルタを保存したフォルダを選択してOKボタンを押してください．指定したフォルダにあるフィルタグループが全てリストに反映されます．追加せずにダイアログを終える場合は，キャンセルを押してください．

Remove filterボタンを押すと，Filters中の選択したフィルタをリストから削除します．グループごと削除する時は，Remove groupボタンやRemove all groupsを使ってください．この操作は，フィルタをリスト上から削除するだけで，ハードディスク上に存在するフィルタファイル自体を削除するわけではありません．

Filter infoボタンで，選択したフィルタのファイル名，フィルタ名，フィルタの作者，著作権情報が表示されます．見終わったらOKを押してください．

Thanks to ...ボタンを押すと，IrfanViewで使用するライブラリを提供してくれたMichael Johannhanwahrへの謝辞が表示されます．

フィルタファクトリーの操作を終えたらExitを押してください．


 色の入れ替え

色の入れ替え

画像メニューから色の入れ替えを選択すると，サブメニューが表示されます．その中から色の変更パターンを選ぶと， allows you to select one of the color combinations to change the 画像の色が変更されます．

この操作はピクセルレベルで適用され，全色またはほとんどの色が選択に従って変更されます．

例
RGB -> RBGを選択すると，緑のピクセルは青になり，青のピクセルは緑になります．この組み合わせでは，赤のピクセルはそのままになります．

利用可能な色変更の組み合わせ

  • RGB -> RBG
  • RGB -> BGR
  • RGB -> BRG
  • RGB -> GRB
  • RGB -> GBR


 パレット

パレット

この操作は256色かそれ以下の画像にのみ適用できます．true color画像の場合，まず画像メニューから減色を行ってください．

パレットの編集

画像中で使用されている色がダイアログに表示されます。セルを1つクリックすると，色情報が表示されます．ダブルクリックすると色を編集できます．変更は画像に反映されていきます．納得のいく結果になったら，OKを押してダイアログを終了してください．

補足：メインウィンドウの画像をクリックすると，パレット内の該当するカラーインデックスが選択されます．

パレットの編集は編集メニューの元に戻すで取り消すことができます．

パレットのエクスポート

パレットの保存先ファイル/フォルダを指定してください．パレットはPaint Shop Proパレット形式のPALファイルとして保存されます．

パレットのインポート

PALファイル（Paint Shop Pro パレット）を指定すると，そのカラーパレットが画像に適用されます．

元のパレットに1:1で割り付けるか，近似色に割り付けるかは，詳細設定，ブラウジング / 編集であらかじめ設定してください．


 基本設定

基本設定

オプションメニューから基本設定を選ぶか， ツールバーの基本設定ツールを使うと，ダイアログが表示され，IrfanViewの基本的な機能を変更することができます．

設定項目は以下の通りです．ダイアログ左側のリストをクリックして表示してください．

  • 開始 / 終了
  • JPEG/PCD/GIF
  • ファイルの関連付け
  • 表示
  • ブラウジング / 編集
  • フルスクリーン / スライドショー
  • ビデオ / サウンド
  • ファイル操作
  • 言語
  • ツールバー
  • PlugIns
  • その他


基本設定－開始 / 終了

IrfanViewの開始フォルダを設定することができます．

IrfanViewを複数起動しない：チェックを外すと，同時に2つ以上のビューアーを開くことができます．チェックをすると，常にビューアーを1つしか開けなくなります．

フルスクリーンモードで起動する：画像をIrfanViewに読み込んだ際に，フルスクリーンウィンドウで表示します．フルスクリーンモードで画像を表示中にESCを押すと，プログラムが終了します．フルスクリーンモードで閲覧中にウィンドウモードに戻したい場合は，Enterキーを押してください．

ESCキーで終了する時に警告する：チェックを付けると，ESCキーでIrfanViewを閉じる時に警告メッセージが出るようになります．

終了時に変更を保存するか尋ねる：チェックを付けると，IrfanViewを閉じる時に，（画像やファイルに変更が加えられ）メモリーに未保存の画像や元に戻すための画像が残っていると，警告メッセージが出るようになります．

サムネイルウィンドウ表示時にビューアーをESCでしか閉じなくする：チェックを付けると，サムネイルウィンドウが表示されている時には，ESCキーでしかメインウィンドウを閉じることができなくなります．


 基本設定－JPEG / PCD / GIF

基本設定－JPEG / PCD / GIF

JPEG

画像方向の情報がEXIFに適切に保存されている時に，それに従ってJPGを自動的に回転させたい場合は,最初のオプションにチェックをしてください．

グレイスケールで表示にチェックを入れると，読み込んだJPGは全て白黒で表示されます．このオプションを有効にしたら，それを忘れないようにしてください．

Photo CD

どの表示サイズでPhoto CD画像を読み込むか選択できます．オプションボタンから1つ選んでください．

GIF

GIF設定を指定するチェックボックスが2つあります．1つめはアニメーションGIFを再生するかどうかで，デフォルトはONです．無効にした場合，最初の画像/フレームだけが表示されます．

2つめのチェックボックスでは，非アニメーションGIFの透過色の扱いを指定します．透過GIFファイルを透過状態で表示したい場合は，チェックを付けてください．このオプションを有効にしたら，それを忘れないようにしてください．メインウィンドウの色（デフォルト：黒）がGIFの透過色と同じ場合，画像によっては空（黒）の画像のように見えます．それを避けるには，このオプションを無効にするか，ウィンドウカラーを基本設定→表示で別の色にしてください．


 基本設定－ファイルの関連付け

基本設定－ファイルの関連付け

IrfanViewに関連づけするファイルタイプを指定します．関連付けたファイルはアイコンボタンで指定したアイコンになり，ダブルクリックしたときにIrfanViewを自動的に起動してファイルを読み込みます．

ファイルを関連付けるには，ファイルタイプの横にあるチェックボックスにチェックを入れてください．リスト上の全ファイルを選択したい場合は，全て選択ボタンを，全ファイルを関連付けから外したい場合は全て解除ボタンを，IrfanViewがサポートする画像形式だけを全て関連付ける場合は全ての画像ボタンを押してください．

ファイルリストの下には，リスト上にない拡張子を持つファイルのためのボックスがあります．その他にチェックを付け，拡張子を「|」で区切って入力してください．

Windows XPでは，全ユーザーに適用にチェックを付けて全ユーザーアカウントについて拡張子を指定することができます．初期設定はカレントユーザーのみになっています．

フォルダ内の連続閲覧は関連付けたファイルだけ表示を有効にすると，スペースやバックスペースキーでフォルダ内画像を移動した際，関連付けたファイルのみ表示されます．

補足：指定したファイル形式を表示オプションを選択し，テキストフィールド内の拡張子を編集すると，簡単に閲覧拡張子を除外することができます．（例：TXTを削除）

[送る]にIrfanViewを追加オプションは，ファイルを右クリックした際の「送る」にIrfanViewを追加します．ドライブやフォルダのシェルメニューに[IrfanViewで参照する]を追加オプションは，ドライブやフォルダを右クリックした際に，そのドライブやフォルダをIrfanViewで閲覧するためのメニューを追加します．

その他，USBイベントにアプリケーションとしてIrfanViewを追加，BMPサムネイルを使用，全てのファイルタイプのシェルメニューに[IrfanViewで開く]を追加の有効/無効をチェックボックスで指定できます．

アイコン

アイコンボタンをクリックすると，別のダイアログが開きます．

標準のアイコンエリアは，IrfanViewに関連付けた全ファイルタイプに使うアイコンを，選択で指定することができます．

別のアイコンを使用を選択すると，IrfanViewがサポートするファイル形式ごとに別々のアイコンを使用することができます．このオプションを使用するにはアイコン プラグインのインストールが必要です．


 基本設定－表示

基本設定－表示

カラーマネジメントを有効化：JPG/TIFファイルの中にはカラープロファイルが埋め込まれている物があり，このオプションを有効にするとその埋め込みプロファイルを使用する設定になります．Windowsのディスプレイ設定機能の中にある使用中のモニタプロファイルに設定するか，ICC/ICMカスタムプロファイルに設定するか選択できます．

組み込みカラープロファイルを使用せず画像に適用を有効にすると，カラーマネジメントが読み込む画像全て（！）に使用され，読み込みがとても低速になります．

元の色へのプロファイルの適用には，LCMSプラグインが必要です．

注：カラープロファイルを使用すると画像の読み込みがとても遅くなります．

PNG/TGA/DDSアルファ/透過色を表示：PNG/TGA/DDSの中には透過色やアルファチャンネルが設定されている物があります．このオプションを有効にすると，アルファチャンネルに定義されている領域はIrfanViewのメインウィンドウの色で表示されます．

組み込み TIF アノテーションを表示：Wang/Kodak Imagingで作成したTIF向け：保存されたテキストアノテーションを画像中に表示します．

16ビット色ディスプレイでは24ビット色画像をディザで表示：このオプションを有効にすると，65536色より少ない色数のディスプレイでもTrueカラー画像を多少良い画像で表示することができます．

ガンマ補正を適用する：このオプションを有効にすると，読み込み画像の明暗度を変更することができます．初期値は1.00（変更無し）で，0.01（とても暗い）から6.99（とても明るい）までの範囲で設定することができます．このオプションは露出アンダー/露出オーバーで撮った一連の画像を見るときに使用してください．また，このオプションは省電力モードでディスプレイが暗い設定なっているノートPCにも便利です．ガンマ値を1.00より高めの適切な値にすると，画像を実際の明るさで閲覧できるようです．

白黒画像のガンマ：初期設定で有効になっていて，白黒画像のリサンプル時の色強度設定に使用されています．初期値は0.50（暗め）で，0.01から6.99の間の値を設定できます．

ズーム表示のステップ：ズームインとズームアウトの刻みを設定します．初期値は10%で，ズーム操作をするごとに10%ずつ画像を拡大/縮小します．この量を変更する時は，テキストボックスに数値を入力してください．

ズームロジック：ズーム値をどう計算するか設定します．相対ステップ：次回のズーム値を現在/前回のズーム値やズームステップから計算します．
絶対ステップ：次回のズーム値は現在のズーム値にズームステップを絶対値として加算/減算して，元画像の大きさから計算し直します．
固定値：ズーム値は通常よく使われるズーム値のテーブルから計算します．

タイトルバーにフルパスを表示：チェックを付けると，フォルダを含んだフルファイルパスをメインウィンドウのタイトルバーに表示します．チェックを外すとファイル名＋拡張子だけの短い名前で表示します（初期設定）．

右クリックでコンテキストメニューを表示する：右クリックをスクロールに使う（初期設定）か，コンテキストメニューの表示に使うか選択します．

新しい画像の読み込み時は画面の中央にウィンドウを表示：チェックを付けると，ビューアーに新しい画像を読み込むたびにデスクトップ中央にメインウィンドウを表示します．

最後に閉じたウィンドウのサイズ/位置を保存：チェックを付けると，最後にウィンドウを閉じた位置でビューアーが開かれるようになります．このオプションは，ウィンドウモードが「画像をウィンドウに合わせる」か「そのままのサイズで表示」の時にのみ有効です．

メインウィンドウの背景色：IrfanViewメインウィンドウの背景色を設定できます．どんな色でも背景色にできます．初期設定は黒です．

ステータスバーテキスト：ステータスバーの一番右の列に表示するテキストを設定できます．テキスト/パターン オプションのページで使用できるテキストを確認してください．


 基本設定－ブラウジング / 編集

基本設定－ブラウジング / 編集

フォルダ内の全てのファイルを表示する：チェックを付けると，フォルダ内にあるIrfanViewがサポートする拡張子のファイルすべてを表示します．チェックを外すと，スペースやバックスペース，あるいはツールバーの矢印ボタンで，次や前のファイルに移れなくなります．

ディレクトリ参照時に隠し属性ファイルを表示する：フォルダ内の隠し属性ファイルを，表示するか非表示にするか選択できます．

連続表示中に最後(最初)のファイルに到達した場合ループする：ディレクトリ内の最後/最初の画像を閲覧しているときに，さらに次/前の画像に移動する操作をすると，通常は閲覧フォルダダイアログを表示して，別のフォルダやサブフォルダに移動します．このオプションにチェックを付けていた場合は，そのダイアログは表示せず，閲覧中のフォルダの最初/最後の画像にループします．

Pageキーかマウスホイールで常に次の画像を表示：矢印キーやページキーあるいはマウスホイールを使った際，大きな画像であってもスクロールはせずに常に前または次の画像に移動します．

Undoオプションを使用：チェックを外すと，編集メニューの元に戻すが使えなくなります．

パレットをインポート 最も近い色を使用：初期設定ではPALファイルの色を単に1:1で置き換えますが，このオプションを有効にすると，PALファイルの色から画像に使われている一番近い色を探し出して置き換えます．

選択範囲にペースト 選択範囲にフィット：初期設定ではペーストした画像は選択範囲に引き延ばして貼り付けられますが，このオプションを有効にすると，選択範囲にアスペクト比を保存できる限りで一番大きく貼り付けます．

切り取り：切り取り機能を使った際に使われる背景色を設定できます．

テキスト ファイル/ペースト設定：フォント，フォント（テキスト）カラー，背景色を設定できます．


 基本設定－フルスクリーン / スライドショー

基本設定－フルスクリーン / スライドショー

  1. 元の大きさのままで表示する：画像やムービーを常にサイズを補正せずに画面に表示します．画面より小さい場合，画像/ムービーは自動的に中央に表示されます．画像/ムービーが画面より大きい場合，画像の左上を表示可能な部分だけを表示します．その場合，キーボードの矢印キーで画像/ムービーの表示領域を移動させて他の部分も見ることができます．
  2. 画面より大きな画像/ムービーだけ画面に合わせる：フルスクリーンモードの推奨設定です．現在の画像解像度より大きな画像は，アスペクト比（比率）を変更しない範囲で全体が表示できるように縮小されます．小さな画像は1番目の設定と同様，画面の中央に元サイズで表示されます．
  3. 全ての画像/ムービーを画面に合わせる：2番目の設定に似ていますが，小さな画像/ムービーは，比率を変えない範囲でフルスクリーンサイズに拡大します．
  4. 全ての画像/ムービーを画面サイズに引き伸ばす：画面いっぱいになるように画像/ムービーを引き伸ばします．サイズ変更の際，アスペクト比は考慮されませんので，画像がかなり歪む可能性があります．
  5. 画像の幅を画面の幅に合わせる：画像の幅が画面の幅になるようにサイズ変更し，高さはそれに合わせて比が変わらないように調整されます．
  6. 画像の高さを画面の幅に合わせる：画像の高さが画面の高さになるようにサイズ変更し，幅はそれに合わせて比が変わらないように調整されます．パノラマ画像に適しています．

フルスクリーンモード中は，1, 2, 3, 4, 5, 6キーで，いつでも上記6つのオプションに切り替えることができます．キー操作による変更は一時的な物で，この設定ダイアログ中の設定には保存されません．

ディスプレイ乗数：このオプションで幅/高さのズーム乗数を設定でき，ワイドスクリーンディスプレイに便利です．

初回表示にリサンプルを使用：このオプションを有効にすると，画像のサイズ変更が必要な時，フルスクリーンモードで可能な限りの高画質で画像を表示することができます（その画像の初回表示時）．ただし，サイズ変更にリサンプルを使用すると，計算（読み込み）に時間がかかります．

ズームにリサンプルを使用：このオプションを有効にすると，画像のリサイズ/ズームが必要な場合，フルスクリーンモードで可能な限りの高画質で画像を表示することができます．ただし，サイズ変更にリサンプルを使用すると，計算（読み込み）に時間がかかります．

画像間でアルファブレンドを適用：このオプションを有効にすると，画像が切り替わる際に，表示していた画像をフェードアウトしつつ新しい画像をフェードインします．

右クリックドラッグでスクロール：通常，フルスクリーン時に右クリックすると次の画像に移りますが，このオプションを有効にすると，画面より大きな画像を右クリックドラッグでスクロールすることができるようになります．

複数画面モード：このオプションを有効にすると，接続された全画面に渡って画像が引き伸ばされ，1つの大きなスクリーンに映すように表示することができます．

背景色：画像を読み込んでいる時の画面の色や，フルスクリーンモードの表示設定に従って画像を表示した際の，残った部分の色を指定します．

文字列 色/フォント：表示テキストの，フォント，スタイル，サイズ，色を指定します．テキストを透過を有効にしていない場合の，文字背景色も設定することができます．この場合，テキストは選択した背景色上に表示されるので，どんな画像上でもテキストを読みやすくすることができます．テキストを透過にすると，テキストは画像上に単に表示されるので，表示はすっきりとしますが，画像によっては読みにくくなります．

最後の2つのオプションはフルスクリーンモードにのみ使用します．

マウスカーソルを隠すにチェックを付けると，画像表示中マウスカーソルが出なくなります．

テキストを表示にチェックを付けると，画像表示中にファイル情報をテキスト表示します．ファイルの名前，サイズ，日時，EXIF/IPTC/コメント情報など，さまざまな情報を表示できます．テキスト/パターン オプションのページで使用できるテキストを確認してください．


テキスト/パターン オプション

下記のダイアログ/機能で使える強力なテキスト生成オプションがあります．

  • 選択範囲にテキストを挿入
  • 一括変換 形式/名前
  • 印刷設定
  • スライドショー
  • フルスクリーン
  • サムネイルの設定
  • HTMLファイルの作成
  • コマンドライン変換

使用可能なファイル/画像プロパティ プレースホルダ

プレースホルダ | タグ名/機能
$D | ファイルのディレクトリ/フォルダ（パス全体）
$d | ファイルのディレクトリ/フォルダ（末尾のフォルダ名のみ）
$F | ファイル名（拡張子有り）
$N | ファイル名（拡張子無し）
$O | ファイルの拡張子
$S | ファイルサイズ
$T | ファイルの日時（付録A参照）
$U | システムの現在日時（付録A参照）
$X | ファイルディレクトリインデックス
$M | 複数ページ画像のページ番号
$Z | ズームサイズ（フルスクリーン/スライドショーで使用）
$W | 画像の幅
$H | 画像の高さ
$B | 画像のBPP（＝bits per pixel：色深度の単位）
$p | 画像のDPI
$C | （有効な場合）JPG/Webshotsファイルのコメント
$I | 全IPTCデータ
$Ix | （有効な場合）JPG IPTCタグx（xは数字．下記参照)（要IPTC プラグイン）
$E | 全EXIFデータ
$Ex | （有効な場合）JPG EXIFタグx（xは数字．下記参照)（要EXIF プラグイン）
| | 改行

重要なIPTCタグ/プレースホルダ（IPTC仕様書より）

訳注：仕様書未入手かつ定番訳語が分からなかったため，訳語が怪しいです．

プレースホルダ | タグ名/機能
$I5 | Object Name オブジェクト名
$I7 | Edit Status 編集状況
$I10 | Priority 優先度
$I15 | Category カテゴリ
$I20 | Supplemental Category 補足カテゴリ（カンマで区切る）
$I25 | Keywords キーワード（カンマで区切る）
$I30 | Release Date 公開日
$I35 | Release Time 公開時
$I40 | Special Instructions 説明
$I45 | Reference Service 提供サービス
$I47 | Reference Date 提供日
$I50 | Reference Number 参照番号
$I55 | Created Date 作成日
$I60 | Created Time 作成時
$I65 | Originating Program 発信プログラム
$I70 | Program Version プログラム バージョン
$I75 | Object Cycle オブジェクト サイクル
$I80 | Byline (Author) 撮影者
$I85 | Byline Title 撮影者肩書
$I90 | City 市町村名
$I92 | Sublocation 町名
$I95 | Province State 都道府県名
$I100 | Country Code ISO国コード（ISO 3166参照）
$I101 | Country 国
$I103 | Original Transmission Reference 送信元リファレンス
$I105 | Headline ヘッドライン
$I110 | Credit 著作権者
$I115 | Source 提供元
$I116 | Copyright 著作権情報
$I120 | Caption 見出し
$I121 | Local Caption
$I122 | Caption Writer 見出し作成者

重要なEXIFタグ/プレースホルダ（EXIF仕様書より）

訳注：訳語は日本電子工業振興協会 (JEIDA)の仕様書より．

プレースホルダ | タグ名/機能
$E270 | ImageDescription 画像タイトル
$E271 | Make 画像入力機器のメーカ名
$E272 | Model 画像入力機器のモデル名
$E274 | Orientation 画像方向
$E282 | XResolution 画像の幅の解像度
$E283 | YResolution 画像の高さの解像度
$E296 | ResolutionUnit 画像の幅と高さの解像度の単位
$E305 | Software 使用ソフトウェア名
$E306 | DateTime ファイル変更日時（付録A参照）
$E318 | WhitePoint 参照白色点の色度座標値
$E531 | YCbCrPositioning YCCの画素構成（YとCの位置）
$E532 | ReferenceBlackWhite 参照黒色点値と参照白色点値
$E33434 | ExposureTime 露出時間
$E33437 | FNumber Fナンバー
$E34850 | ExposureProgram 露出プログラム
$E34855 | ISOSpeedRatings ISOスピードレート
$E36864 | ExifVersion Exifバージョン
$E36867 | DateTimeOriginal（付録A参照）原画像データの生成日時
$E36868 | DateTimeDigitized（付録A参照）ディジタルデータの作成日時
$E37121 | ComponentsConfiguration 各コンポーネントの意味
$E37122 | CompressedBitsPerPixel 画像圧縮モード
$E37377 | ShutterSpeedValue シャッタースピード
$E37378 | ApertureValue 絞り値
$E37379 | BrightnessValue 輝度値
$E37380 | ExposureBiasValue 露光補正値
$E37381 | MaxApertureValue レンズ最小F値
$E37382 | SubjectDistance 被写体距離
$E37383 | MeteringMode 測光方式
$E37384 | LightSource 光源
$E37385 | Flash フラッシュ
$E37386 | FocalLength レンズ焦点距離
$E37510 | UserComment ユーザコメント
$E37520 | SubsecTime DateTimeのサブセック
$E37521 | SubsecTimeOriginal DateTimeOriginalのサブセック
$E37522 | SubsecTimeDigitized DateTimeDigitizeのサブセック
$E40960 | FlashPixVersion 対応フラッシュピックスバージョン
$E40961 | ColorSpace 色空間情報
$E40962 | PixelXDimension 実効画像幅
$E40963 | PixelYDimension 実効画像高さ
$E41483 | FlashEnergy フラッシュ強度
$E41486 | FocalPlaneXResolution 焦点面の幅の解像度
$E41487 | FocalPlaneYResolution 焦点面の高さの解像度
$E41488 | FocalPlaneResolutionUnit 焦点面解像度単位
$E41492 | SubjectLocation 被写体位置
$E41493 | ExposureIndex 露出インデックス
$E41495 | SensingMethod センサー方式
$E41728 | FileSource ファイルソース
$E41729 | SceneType シーンタイプ
$E41985 | CustomRendered 個別解像度処理
$E41986 | ExposureMode 露出モード
$E41987 | WhiteBalance ホワイトバランス
$E41988 | DigitalZoomRatio ディジタルズーム倍率
$E41989 | FocalLengthIn35mmFilm 35mm換算レンズ焦点距離
$E41990 | SceneCaptureType 撮影シーンタイプ
$E41991 | GainControl ゲイン制御
$E41992 | Contrast 撮影コントラスト
$E41993 | Saturation 撮影彩度
$E41994 | Sharpness 撮影シャープネス
$E41995 | DeviceSettingDescription 撮影条件記述情報
$E41996 | SubjectDistanceRange 被写体距離レンジ
$E400 | GPSVersionID GPSタグのバージョン
$E401 | GPSLatitudeRef 北緯(N) or 南緯(S)
$E402 | GPSLatitude 緯度（数値）
$E403 | GPSLongitudeRef 東経(E) or 西経(W)
$E404 | GPSLongitude 経度（数値）
$E405 | GPSAltitudeRef 高度の基準
$E406 | GPSAltitude 高度（数値）
$E407 | GPSTimeStamp GPS時間（原子時計の時間）
$E416 | GPSImgDirectionRef 撮影した画像の方向の単位
$E417 | GPSImgDirection 撮影した画像の方向（数値）
$E429 | GPSDateStamp GPS日付
注：メーカー独自使用の特殊なEXIFタグ（メーカーノート）にも利用できるものがあります．(ニコン，キャノン，富士フイルム，カシオ，オリンパス）

訳注：以下，メーカーノートは非公開らしく，また，翻訳者がカメラに詳しくないため，訳語が怪しいです．

ニコン製カメラのタグリスト（主なモデル）

プレースホルダ | タグ名/機能
$E1 | Data Version
$E2 | ISO Setting ISO設定
$E3 | Color Mode カラーモード
$E4 | Image Quality 画質
$E5 | White Balance ホワイトバランス
$E6 | Image Sharpening 輪郭強調
$E7 | Focus Mode フォーカスモード
$E8 | Flash Setting フラッシュ設定
$E9 | Flash Mode フラッシュ種類
$E11 | White Balance Adjustment ホワイトバランス補正
$E14 | Exposure Adjustment 露光補正
$E15 | ISO Selection ISO選択
$E18 | Flash Compensation フラッシュ補正
$E19 | ISO 2
$E128 | Image Adjustment 画像階調補正
$E129 | Tone Compensation トーン階調補正
$E130 | Auxiliary Lens コンバータ
$E131 | Lens Type レンズタイプ
$E132 | Lens レンズ
$E133 | Manual Focus Distance マニュアル焦点距離
$E134 | Digital Zoom デジタルズーム
$E135 | Flash Used フラッシュ使用
$E136 | AF Focus Position AF焦点位置
$E137 | Bracketing 段階露出
$E141 | Color Mode カラーモード
$E144 | Light Type 光源種類
$E146 | Hue Adjustment 色調補正
$E148 | Saturation Adjustment 彩度補正
$E149 | Noise Reduction ノイズリダクション

キャノン製カメラのタグリスト（主なモデル）

プレースホルダ | タグ名/機能
$E1 | Macro mode マクロモード
$E2 | Self timer セルフタイマー
$E3 | Quality 画質
$E4 | Flash mode フラッシュモード
$E5 | Sequence mode シーケンスモード
$E7 | Focus mode フォーカスモード
$E10 | Image size 画像サイズ
$E11 | Easy shooting mode 撮影モード
$E12 | Digital zoom デジタルズーム
$E13 | Contrast コントラスト
$E14 | Saturation 彩度
$E15 | Sharpness シャープネス
$E16 | ISO Value ISO値
$E17 | Metering mode 計測モード
$E18 | Focus type フォーカスタイプ
$E19 | AF point selected AF点選択
$E20 | Exposure mode 露光モード
$E25 | Focal length 焦点距離
$E28 | Flash activity フラッシュ
$E29 | Flash details フラッシュの詳細
$E32 | Focus mode 2 フォーカスモード2
$E40 | White Balance ホワイトバランス
$E41 | Sequence number 連番
$E42 | AF point used 使用したAF点
$E43 | Flash bias フラッシュ補正
$E44 | Subject Distance 被写体距離
$E60 | Image Type 画像の種類
$E70 | Firmware Version ファームウェアのバージョン
$E80 | Image Number 画像の名前
$E90 | Owner Name 所有者の名前
$E93 | File Number ファイル番号
$E120 | Camera Serial Number カメラのシリアル番号

付録A

既定では，日時に関するプレースホルダは全て，日時情報をフルテキストで表示します．もし，特定の値だけ利用したい場合は，以下のオプションを使ってください．（ANSI C準拠）

%Y | 西暦年 4桁表現
%y | 西暦年 2桁表現（00-99）
%m | 月
%d | 日
%H | 時
%M | 分
%S | 秒

以下は，EXIFやシステムの時刻が2005年11月29日だった場合の例です．

プレースホルダ | 置換結果
$T(%d.%m.%Y) | 29.11.2005
$T(%Y%m%d) | 20051129
$T(%d%m%y) | 291105
$E36868(%Y_%m_%d) | 2005_11_29
$T(%d_%m_%Y) | 29_11_2005
$T(day:%d, month:%m, year: %Y) | day: 29, month: 11, year: 2005


 基本設定－ビデオ / サウンド

基本設定－ビデオ / サウンド

ビデオ/サウンドの再生には，Videoプラグインが必要です．このダイアログではビデオ/サウンドの再生オプションを設定でき，メインウィンドウで再生する（初期設定）か，IV_Player プラグインを使って別ウィンドウで再生するかを選択できます．

DirectShowを使用する：このオプションはMJPGコーデックを使ったAVIファイルや, 一部のMPG, MP4, MOV, WMVファイルを再生する時に利用できます．このオプションを有効にすると，一時停止/再開にPauseキー，早送り/巻き戻しに左/右 矢印キーを使用できるようになります．

Apple QuickTime コンテンツの設定：IrfanViewはQuickTimeを利用できます．そのため，MOV, 3GP, MP4, QTIF, Mac PICT, FLI/FLC形式を読むことができ，こられのファイルをサポートするかどうかを切り替えることができます．QuickTimeファイルをIrfanViewで再生するには, Quicktime プラグインとApple QuickTimeが必要です．


 基本設定－ファイル操作

基本設定－ファイル操作

最初のセクションでは，ファイルのコピー元として使用するデフォルトディレクトリを設定できます．ディレクトリを入力するか，参照ボタンを使って選んでください．入力欄の下にあるコピー前に確認する チェックボックスを有効にすると，コピー前にオプション選択ダイアログを表示するようになります．

2番目のセクションでは，ファイルの移動元として使用するデフォルトディレクトリを設定できます．入力欄の下にあるl 移動前に確認するチェックボックスを有効にすると，移動前にオプション選択ダイアログを表示するようになります．

3番目のセクションでは，削除操作に関するオプションを設定します．

削除前に確認する
ファイルを削除する前に確認を求めます．
削除したファイルはゴミ箱へ
IrfanView上で削除したファイルはWindwosのゴミ箱に送られます．
削除/移動したら次のファイルへ
ファイルの削除や移動を実行した際，自動的に次のファイルを表示します．
ファイル削除後にIrfanViewを終了する
ファイルを削除した後は，直ちにIrfanViewを終了します．

4番目のセクションでは，保存やファイル名の変更に関するオプションを設定します．

[ファイル]→[保存]メニューで保存ダイアログを表示
上書保存メニューをクリックした際に，画像を保存するフォルダを選択するダイアログを表示します．チェックを外すと，上書保存メニューを選択した際，画像を元の画像と置き換えて保存するようになります．この設定は，上書保存メニューのみの設定で，名前を付けて保存メニューを使用した場合は，常に保存先選択ダイアログを表示します．
[保存]、[名前を付けて保存]時に上書き確認を行う
古いファイルを新しいファイルで上書きする場合に，確認を求めます．
誤った拡張子のリネームを確認する
間違った拡張子が付いたファイルを読み込んだ時に，正しく修正するかどうか確認します．チェックを外した場合は，何の変更も行わずファイルを読み込みます．
ファイル名変更後 画像表示の順番を変更しない
ファイル名を変更した場合でも，カレントディレクトリ内での順番を変更しません．チェックを外した場合は，新しいファイル名に従って，ディレクトリ内での順番が変更します．


 基本設定－言語

基本設定－言語

このダイアログでIrfanViewの言語を直ちに変更することができます．

開始時にUnicodeプラグインを読み込む：Unicodeプラグインを読み込むと，日本語，中国語，アラビア語，ヘブライ語，東欧諸語などのようなUnicode文字を名前に含むファイルを開くことができるようになります．

プラグインを有効化するにはIrfanViewの再起動が必要です．

訳注：なぜかUnicodeプラグインは読み込まない方が文字化けしません．

言語を変える時は，利用したい言語のDLLをIrfanViewの「Languages」フォルダにコピーしておかなければなりません．その上で，ダイアログ中の言語リストから言語を選び，OKを押して有効化してください．

以下のサイトで利用可能な言語ファイルと翻訳用SDKが入手できます．

http://www.irfanview.com/languages.htm


基本設定－PlugIns

DigiCam RAW形式の読み込みオプションがあります．CRW/CR2の読み込みにCanon DLLを使用する場合は，「i_plugins.txt」を読んで，詳細な情報とダウンロード先を確認してください．

TTFファイル用デフォルトでTrueTypeフォントを読み込んだ時にデモとして表示させる文字列を設定できます．TTFを比較したりサポートする文字を確認するために利用したいテキストを入力してください．

訳注：日本語未対応．文字化けします．


 基本設定－その他

基本設定－その他

最後に使用したスライドショーフォルダからスライドショーダイアログを開く：最後にスライドショーに使ったフォルダを記憶するか，閲覧中フォルダをスライドショーに使用するかを設定します．

最後に使用した一括変換フォルダから一括変換ダイアログを開く：最後に使用した一括変換フォルダを記憶するか，閲覧中フォルダを一括変換フォルダに使用するかを設定します．

[最近開いたフォルダ]の履歴を有効にする：ファイルメニューの最近開いたフォルダの有効/無効を設定します．

[最近開いたフォルダ]の履歴を消す：消去ボタンを押すと，[最近開いたフォルダ]リスト中のフォルダ名が全て削除されます．このボタンはいつでも使用できます．

デスクトップにIrfanViewのショートカットを作成：作成ボタンを押すと，Windowsのデスクトップ上にアイコンが作成され，ダブルクリックでIrfanViewを起動できるようになります．また，このボタンで作成したIrfanViewショートカットアイコンにはショートカットキーが設定されており，Ctrl + Shift + IでIrfanViewを起動できるようになります．ショートカットキーは，アイコン上を右クリック→プロパティ→ショートカットタブ→ショートカットキーで変更できます．

外部エディタを設定で，3つの外部エディタを設定できます．画像編集ソフトの場所をフルパスで指定してください．参照ボタンを利用して外部エディタの場所を指定することもできます．外部エディタを設定しておくと，メインウィンドウやサムネイルウィンドウのファイルメニューから外部エディタで開くを使用することができるようになり，選択した画像編集ソフトで閲覧中の画像を開くことができます．

ファイル名外部エディタに送るを有効にすると，閲覧中の画像のファイル名とパス名が8.3形式で送られるようになります．このオプションは，外部エディタが古い16ビットアプリケーションだった場合に必要になります．

例
「C:\Documents and Settings\User\My Documents\My Pictures\My Image.jpeg」
だった場合は，
「C:\DOCUME~1\USER\MYDOCU~1\MYPICT~1\MYIMAG~1.JPE」
になります．

補足：外部エディタに特殊な起動パラメータを送ることができます．

初期設定では，IrfanViewはファイル名のみを外部エディタに送ります．追加のパラメータを送る場合は，""とファイル名を表す%1を使用してください．

以下に外部エディタがIrfanView / Total Commanderの場合の例をいくつか挙げます．

path\i_view32.exe
初期設定の構文です．別のIrfanView（外部エディタ）で送られたファイル名のファイルを開きます．
path\i_view32.exe "%1"
初期設定と同じ結果になります．ファイル名のみをパラメータとして送ります．
path\i_view32.exe ""%1" /fs"
送られたファイル名のファイルをフルスクリーンモードで開きます．
path\i_view32.exe ""%1" /resize=(100,100) /aspectratio /resample /convert=d:\temp\thumb.jpg"
閲覧中の画像をサイズ変更して「d:\temp」に「thumb.jpg」という名前で保存します．
path\i_view32.exe ""%1" /convert=d:\temp\$N.jpg"
閲覧中の画像をJPGに変換して「d:\temp」 に「現在のファイル名の拡張子を抜いた部分.jpg」という名前で保存します．
path\totalcmd.exe "/O /T /R="%1""
Total Commanderにファイル名を送り，フォルダを右側の新しいタブで開きます．

訳注：Total CommanderはWindows向けシェアウェアのファイルマネージャ．公式サイトはhttp://www.ghisler.com/．


 マルチメディアプレイヤーの起動

マルチメディアプレイヤーの起動

注：マルチメディアプレイヤーはIV_Playerプラグインがないと使用できません．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

オプションメニューからマルチメディアプレイヤーの起動を選択してください．

マルチメディアプレイヤーでは，以下のビデオ，サウンド，オーディオCDファイルが再生できます．

AVI, ASF, CDA, MP3, MPG/MPEG, MOV, MID/RMI, WAV, WMA , WMV, etc.

左端のOptionボタンで，ファイルの再生にMCIインターフェイスを使うか，Microsoft Media Playerを利用する（推奨）か設定できます．

AVIファイルからフレームを抽出することもできます．また，オーディオCDプレイヤーも組み込まれています．

マルチメディアプレイヤーはESCキーで終了できます．


 アニメーション停止

アニメーション停止

オプションメニューからアニメーション停止を選択すると，動きのある画像を止めることができます．

このメニューはアニメーションGIF，アニメーションカーソル（ANI）, MNGアニメーションで使用します．動きを止めると，GIF/ANIは1フレームだけの画像となり，静止画像として保存することができます．

全フレームを保存したい場合は，静止画に分割して保存を使用してください．


 静止画に分割して保存

静止画に分割して保存

オプションメニューから静止画に分割して保存を選択すると，ダイアログが開き，動画の各フレームを保存するフォルダを指定できます．フォルダを指定し，OKを押すと，画像が保存されます．このメニューはアニメーションGIF, アニメーションカーソル (ANI)，MPG/AVIファイルを閲覧している時に使用できます．

画像から抽出したフレームは，次のような名前で保存されます．

imagename_frame_000.bmp

imagenameは元画像の名前，000はフレーム番号になります．

フレームを抽出せずに終える場合は，キャンセルを押してください．


 画像をメールで送信

画像をメールで送信

注：E-mail機能には，EMailプラグインがないと使用できません．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

オプションメニューから画像をメールで送信を選んでください．

最初にSMTPサーバーやE-mailアドレスなどの設定をしておく必要があります．また，送信にMAPIプロトコルを使用することもできます．プロバイダからの書類や，実際に利用しているメーラーの設定を参照し，正しいSMTP設定を確認してください．

注：この機能では，SMTPの送信にPort 25を利用しますが，中にはこのポートが自由に使えないようにしているプロバイダもあります．その場合は，MAPIを使用してください．

よく使うアドレスを保存しておく簡易アドレス帳も付属しています．

Sendボタンを押すと画像が送信されます．送信せずにダイアログを終了する場合はExitを押してください．


 JPGロスレス回転

JPGロスレス回転

注： JPGロスレス変換にはJPG_Transformプラグインが必要です．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

注：この機能は，JPGファイルを読み込んだときにのみ利用できます．

オプションメニューからJPGロスレス回転を選択するとダイアログが開き，回転・反転・最適化・コメント/EXIF/IPTCタグの削除を行うことができます．

注： サムネイルウィンドウで複数のJPGファイルを選択してからこのダイアログを起動すると，JPGファイルを一度に操作できます．
注：反転や回転のJPGロスレス変換は，画像の高さが16の倍数のときにのみ有効です（JPGの仕様）．それ以外の場合には，使用されなかった画像のラインが削除されます．
注：元のJPGファイルは処理と同時に上書きされます．

読み込みJPG画像の処理を開始する時は，Startを押してください．処理をせずにダイアログを終える場合はCancelを押してください．


 JPGロスレス切り抜き

JPGロスレス切り抜き

注： JPGロスレス変換にはJPG_Transformプラグインが必要です．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

注：この機能は，JPGファイルを読み込んだ上で，範囲指定を行っているときにのみ利用できます．

オプションメニューからJPGロスレス切り抜きを選択するとダイアログが開き，切り抜いた後のファイルをどこに保存するか指定できます．

注：画像を1つ表示して範囲指定を行った上で，サムネイルウィンドウを開き，複数のJPGファイルを選択してからこのダイアログを起動すると，JPGファイルを一度に操作できます．
注：JPGのロスレス切り抜きは，選択範囲の座標/サイズが16の倍数になるように指定すると，うまく機能します（JPGの仕様）．その他の場合，結果の画像のサイズが最初の指定と少しずれる可能性があります．

読み込みJPG画像の切り抜きを開始する時は，Startを押してください．切り抜かずにダイアログを終える場合はCancelを押してください．


 画面の取り込み

画面の取り込み

オプションメニューから画面の取り込みを選択すると，ダイアログが開き，モニタ画面の一部をキャプチャ（取り込み）することができます．

取り込む部分

オプションボタンで，キャプチャ範囲を選択します．

  • 全画面
  • デスクトップ部分 - 現在のモニタ（マウスカーソルが存在するモニタ）
  • アクティブウィンドウ全体
  • アクティブウィンドウのクライアント領域（ウィンドウのうち，キャプション，メニュー，ステータスバーを除いた部分）
  • 取り込み範囲カスタム設定（実行ボタンを押すか，ショートカット：メインウィンドウ表示中にCTRL + Print後に，マウスで範囲指定）

取り込み方法

取り込み方法として，自分で定義した取り込み実行キーを使用する方法と，連続自動取り込みを選択できます．

取り込み実行キーによる取り込みを実行した場合は，ショートカットが予約された状態になり，一度取り込みを終えないうちに新たに（取り込み実行キーによる）画面取り込みをしようとすると，エラーになります．

自動取り込みの場合は，取り込み時間の間隔も設定してください．この値は，モニタやウィンドウを取り込んでから次に取り込むまでの時間を，秒数で設定します．

キャプチャ処理

取り込み画像にマウスカーソルも含めたい場合は，マウスカーソルを含めるオプションにチェックを付けてください．

保存形式

取り込んだ画像をメインウィンドウに表示することもできますし，表示せずにディスクに直接保存することもできます．

取り込んだ画像をファイルに保存を指定した場合は，あわせて以下の項目も設定してください．

ファイル名
保存する画像のファイル名を設定します．固定文字列も指定できますし，タイムスタンプのパターンを指定することもできます．初期設定はcapture_%d%m%Y_%H%M%Sです．この設定では，システムの日時も参照し，「capture_29112005_123620」のようなファイル名になります．（%d = 日, %m = 月, %Y = 西暦年（4桁）, %H = 時, %M = 分, %S = 秒）
保存フォルダ
画像の保存フォルダを設定します．フォルダのパスを入力するか，参照ボタンを利用して希望のフォルダを探してください．
保存形式
取り込んだキャプチャ画像をどのファイル形式で保存するかを選択します．右側にある▼を押して，ファイル形式を1つ選んでください．初期設定はJPGです．詳細設定ボタンを押すと，ファイル形式によっては別なダイアログが表示され，それぞれのファイル形式の保存オプションを指定することができます．（補足: ほとんどの場合，スクリーンショットの保存にはPNGがおすすめです）

画面の取り込みを開始する時は，実行を押してください．画面を取り込まずにダイアログを終える場合はキャンセルを押してください．

実行を押すと，IrfanViewのウィンドウは最小化しますので，取り込み実行キーによる取り込み方法を選んだ場合は，定義した取り込み実行キーを使用してください．ダイアログで指定した部分が取り込まれます．連続して取り込み実行キーを押すと，押すたびに新たに画面を取り込み直します．

注：オプションメニューからもう一度画面の取り込みを選択すると，開始していた取り込みプロセスは中止されます．


 OCRを開始

OCRを開始

注：OCRにはOCR_KADMOSプラグインが必要です．下記からダウンロードしてインストールしてください．

http://rerecognition-download.ch/irfan/kadmos44/KADMOS.htm

訳注：KADMOS OCRは英語/ドイツ語版のみで，欧州諸語の文章は辞書ファイル選択で文字認識できる物も多いですが，日本語のテキストには対応していません．

注：OCRは，画像全体に適用するだけでなく，選択した一部分だけに適用することもできます．

オプションメニューからOCRの開始を選択してください．別ウィンドウが開き，OCR (Optical Character Recognition = 光学文字認識) を行って，画像からテキスト文字列を取得し，クリップボードにコピーしたりファイルに保存したりできます．


 ファイルの並べ替え

ファイルの並べ替え

オプションメニューからファイルの並べ替えを選択すると，サブメニューが表示され，ファイルを並べ替える順番を以下から選ぶことができます．

  • 名前
  • 名前 XPスタイル
  • 日付
  • サイズ
  • 拡張子

それぞれ，昇順と降順を選ぶことができます．また，そのままを選ぶと並べ替えしません．

名前と名前 XPスタイルの違いは，ファイル名の数字の扱いです．名前で並び替えるとFile10.jpgがFile1.jpgの前になりますが，名前 XPスタイルで並び替えると，File1.jpgがFile10.jpgの前になります．

ファイルの並べ替えを有効化すると，スペースバーでの前ファイルへの移動と，Back Spaceキーでの後ファイルへの移動も，設定した並べ替え順での移動になります．

補足： サムネイルウィンドウでは，さらにEXIF情報の撮影日付，画像の幅/高さ/DPI，ドラッグ & ドロップによる手動指定順などでの並べ替えを利用できます．


 壁紙にする

壁紙にする

オプションメニューの壁紙にするを選択すると，サブメニューが表示され，中央に表示，並べて表示, 拡大して表示，前の壁紙に戻すから1つ指定することができます．指定すると，閲覧中の画像がWindowsデスクトップの背景に設定されます．

中央に表示
デスクトップの中央に画像を1つだけ表示します．
並べて表示
デスクトップ全体を覆うように画像がタイル上に複数表示されます．デスクトップアイコンは，壁紙の上に表示されます．
拡大して表示
デスクトップ中央に画像を1つだけ表示しますが，画面全体を覆うように拡大して表示します．アスペクト比は保存されません．
拡大して表示（アスペクト比保存）
デスクトップ中央に画像を1つだけ表示しますが，アスペクト比を保存した上で，できるだけ大きく画面全体を覆うように拡大して表示します．
前の壁紙に戻す
このメニューで変更した壁紙を，変更前の壁紙に戻します．

IrfanViewはIrfanView_Wallpaper.bmpという名前のBMPファイルをIrfanViewのユーザー設定フォルダ (Documents and settings\User\Application data\IrfanView\) に保存し，そのファイルを壁紙に設定します．


 最小化

最小化

オプションメニューから最小化を選ぶと，ビューアーが最小化してWindowsのタスクバーに入ります．（いわゆる「ボスが来た」キーです．( ^ー°) ）

タスクバー上のIrfanViewをクリックすると，ビューアーは元に戻ります．

ビューアーウィンドウの右上隅にある最小化ボタン _ を押しても最小化することができます．


常に手前に表示

オプションメニューから常に手前に表示を選ぶと，他のプログラムを開いても，IrfanViewのウィンドウが常に画面に表示されます．止めたいときは，もう一度常に手前に表示をクリックしてください．

注：このオプションは保存され，次回IrfanViewを開いたときにも有効になります．


 ステータスバー

ステータスバー

ステータスバーは，メインウィンドウの下部にあり，表示中の画像の情報が表示されます．表示される情報は，画像メニューの画像の情報ダイアログで表示されるものです．

ステータスバーの表示/非表示は，表示メニューのステータスバーを選択するたびに切り替わります．

表示される情報

  • 現在の大きさ x 現在の色数
  • フォルダ内の順位
  • ズームの割合
  • ディスク上のサイズ / メモリ上のサイズ
  • ファイルの更新日時
  • 基本設定→表示→ステータスバーテキストで設定したテキスト．初期設定は，複数ページ画像のページ番号．
    画像/ファイルにタグが付けられている場合（ショートカットキー: X），ステータスバーの右端に「(X)」が表示されます．


 ウィンドウの外枠

タイトルバー/キャプション （ウィンドウの外枠）

Top Previous Next

タイトルバーは，メインウィンドウの上部にあり，表示中の画像の情報が表示されます．

タイトルバーの表示/非表示は，表示メニューのウィンドウの外枠を選択するたびに切り替わります．

表示される情報

  • 閲覧中のファイル名（基本設定→表示→タイトルバーにフルパスを表示でフルパスの表示にするかファイル名のみにするかを設定できます）
  • 画像の中をクリックした時－クリック中のピクセル情報を表示します．
    座標XY - 色情報（RGB 10進数表記 - GIFやBMPなどの場合 パレットインデックス，HTML向け16進数表記）
  • 範囲指定枠が表示されている時－選択範囲の情報を表示します．
    左上座標，大きさ，アスペクト比
  • ズーム中－ズーム中の画像サイズ．


 ディレクトリでの順位

ディレクトリでの順位

ツールバー上には，現在フォルダ内の画像の数と，表示中ファイルがその何番目かが表示されるテキストフィールドがあります．「1/5」という表示ならば，フォルダ内に5つファイルがあるうち表示中のファイルは1番目という意味です．

フィールド上に数字を入力すると，その順番の画像が開きます．

複数ページ画像を開いている場合は，このフィールドにはページ番号が表示されます．「1/5」は5ページあるうちの1ページ目を表示しているという意味になります．

マウスかSHIFT + Tでフィールドにフォーカスを移してください．数字を変更し，Enterを押すと，指定のファイルを表示します．指定の仕方は以下の通りです．

  • 「X」または 「X/Y」 = 現在フォルダの X 番目のファイル
  • 「ページ X」または「ページ X/Y」 = 複数ページファイル内の X ページ目（「ページ」は全角，数字の前の空白は半角）
  • テキスト/パターン：現在フォルダ内のファイルを，パターンでフィルタをかけたうえで数え，表示します．
    例
    *.jpg | JPGのみ
    cat*.jpg | 「cat」という名前で始まる全JPG
    cat* | 「cat」という名前で始まる全ファイル

パターン使用後は，F5 か U （update = 更新）を押すと，初期設定（元のフォルダ内順）表示に戻ります．


 フルスクリーン

フルスクリーン

表示メニューからフルスクリーンを選択すると，モニタ全体が黒くなり，その中央に画像が表示されます．スペースバーや右クリックで現在フォルダの次の画像に移動し，BackSpaceキーや左クリックで前の画像に移動します．

フルスクリーンモードを終えるときは，EnterかESCキーを押してください．また，モニタの左上隅や右上隅をクリックしてもフルスクリーンモードを終えることができます．

1, 2, 3, 4, 5, 6キーで，いつでも6つのフルスクリーン 表示オプションを切り替えることができます．

オプションメニューから基本設定を選択し，ダイアログ左側のリストからフルスクリーン / スライドショーを選ぶと，フルスクリーンモードの全設定を行うことができます．また，表示メニューからフルスクリーン設定を選んでも同じダイアログが表示されます．

関連情報

  • 基本設定－フルスクリーン / スライドショー


表示設定

注：表示設定（ウィンドウモード）は1つしか有効にできません．表示設定を変更した場合は，それを忘れないようにしてください．「問題」が起きた場合，まずは設定を確かめてください！

ウィンドウを画像に合わせる

ウィンドウを画像に合うようサイズ変更します．この設定が推奨設定です・

画像をウィンドウに合わせる

画像をウィンドウに合うようサイズ変更します．

大きい画像だけウィンドウに合わせる

ウィンドウより大きな画像のみ，全体が表示されるよう画像を小さくします．ウィンドウよりも小さな画像は変更されません．

画像をデスクトップに合わせる

ウィンドウ/画像の比を保存したままデスクトップの大きさに合わせてサイズ変更します．

大きい画像だけデスクトップに合わせる

（以前の初期設定）

デスクトップより大きな画像のみ，全体が表示されるよう画像を小さくします．デスクトップよりも小さな画像は変更されません．

デスクトップの幅に合わせる

ウィンドウ/画像の幅がデスクトップの幅に合うようサイズ変更します．

デスクトップの高さに合わせる

ウィンドウ/画像の高さがデスクトップの高さに合うようサイズ変更します．

そのままのサイズで表示

新たな画像を読み込んだときに，ウィンドウのサイズ/位置を変更しません．

サイズ合わせ時に「リサンプル処理」を使用

このオプションを有効にすると，ウィンドウやデスクトップに合わせるためにサイズ変更する場合の画質が向上しますが，通常よりも読み込みが遅くなり，メモリ消費も大きくなります．

ズーム時にリサンプル処理を使用

このオプションを有効にすると，画像をズームしたときの画質が向上しますが，通常よりも読み込みが遅くなり，メモリ消費も大きくなります．

画像をウィンドウの中央に表示

画像をウィンドウ中央に表示するか，左上に表示するかを選択できます．


 次のファイル

次のファイル

表示メニューから次のファイルを選ぶか，ツールバーの次のファイルツールを使うと，IrfanViewがサポートするファイルのうち次のファイルにあたるものを表示します．

スペースキーでも，フォルダ中の次のファイルに移ります．画像の右側に垂直スクロールバーが出ておらず，基本設定→ブラウジング / 編集の該当オプションを有効にしているときには，Page Downキーやマウスのホイールダウンでも次の画像に移動することができます．

関連情報

  • 前のファイル
  • 最初のファイル
  • 最後のファイル
  • ランダムなファイル
  • 基本設定－ブラウジング / 編集


 前のファイル

前のファイル

表示メニューから前のファイルを選ぶか，ツールバーの前のファイルツールを使うと，IrfanViewがサポートするファイルのうち前のファイルにあたるものを表示します．

Backspaceキーでも，フォルダ中の前のファイルに移ります．画像の右側に垂直スクロールバーが出ておらず，基本設定→ブラウジング / 編集の該当オプションを有効にしているときには，Page Upキーやマウスのホイールアップでも前の画像に移動することができます．

関連情報

  • 次のファイル
  • 最初のファイル
  • 最後のファイル
  • ランダムなファイル
  • 基本設定－ブラウジング / 編集


最初のファイル

表示メニューから最初のファイルを選ぶと，現在フォルダの中で最初にあたるファイル（IrfanViewがサポートするもの）を表示します．

関連情報

  • 次のファイル
  • 前のファイル
  • 最後のファイル
  • ランダムなファイル


最後のファイル

表示メニューから最後のファイルを選ぶと，現在フォルダの中で最後にあたるファイル（IrfanViewがサポートするもの）を表示します．

関連情報

  • 次のファイル
  • 前のファイル
  • 最初のファイル
  • ランダムなファイル


ランダムなファイル

表示メニューからランダムなファイルを選ぶと，現在フォルダの中からIrfanViewがサポートするファイルを，ランダムに表示します．

関連情報

  • 次のファイル
  • 前のファイル
  • 最初のファイル
  • 最後のファイル


 最新の情報に更新

最新の情報に更新

表示メニューから最新の情報に更新を選ぶと，表示中の画像を最新の状態に更新します．

フォルダの情報も更新され，ディレクトリでの順位もカウントし直します．

範囲指定枠が表示された状態で最新の情報に更新を行うと，範囲を指定していた枠は消去されます．


連続表示 実行/停止

表示メニューから連続表示 実行/停止を選ぶと，メインウィンドウで，現在フォルダ内の画像を使った連続表示を開始します．画像の表示間隔は，スライドショー設定で設定した間隔になります．

もう一度メニューを選ぶと，連続表示を停止します．


 ズームイン

ズームイン

表示メニューからズームインを選ぶか，ツールバーのズームインツールを使うと，画像の表示サイズが大きくなります．もう一度使うと，より大きくなります．

拡大量は，基本設定→表示のズーム表示のステップで設定できます．初期値は10%で，操作1回ごとに前のズーム量から再計算して表示します．

注：ズームは表示サイズのみ変更します．画像サイズは変更されません! 画像サイズを変更したい場合は，画像→リサイズ/リサンプルを利用してください．


 ズームアウト

ズームアウト

表示メニューからズームアウトを選ぶか，ツールバーのズームアウトツールを使うと，画像の表示サイズが小さくなります．もう一度使うと，より小さくなります．

縮小量は，基本設定→表示のズーム表示のステップで設定できます．初期値は10%で，操作1回ごとに前のズーム量から再計算して表示します．

注：ズームは表示サイズのみ変更します．画像サイズは変更されません! 画像サイズを変更したい場合は，画像→リサイズ/リサンプルを利用してください．


ズームを固定

表示メニューからズームを固定を有効にすると，現在のズーム設定が保存され，以降に読み込んだ画像にも適用されます．

このオプションは，IrfanViewを閉じるまで有効です．

もう一度メニューを選択するか，SHIFT + Lを押すと，無効化します．


スクロール位置を固定

表示メニューからスクロール位置を固定を有効にすると，スクロールバーが出るような大きな画像の表示部分が保存され，以降に読み込んだ画像にも適用されます．

スクロール位置は絶対位置で保存されるため，例えば右下隅に合わせた後で，表示中の画像よりも大きな画像を読み込むと，画像の中ほどの部分が表示されることになります．また，ウィンドウサイズよりも小さな（スクロールバーが出ない大きさの）画像を読み込むと，位置がリセットされ，通常通り左上部分が表示されるようになります．

このオプションは，IrfanViewを閉じるまで有効です．

もう一度メニューを選択すると，無効化します．


 元のサイズに戻す

元のサイズに戻す

表示メニューから元のサイズに戻すを選ぶと，ズームインやズームアウトの効果をリセットして，オリジナルの画像サイズに戻します．


 16進表示

16進表示

表示メニューから16進表示を選ぶと，閲覧中の画像のHEX形式を表示します．HEXViewウィンドウで，開いているファイルの全バイトの「アドレス」「Hex ダンプ」「ASCII ダンプ」を確認できます．

このオプションは上級ユーザー向けです．


 複数のページの画像

複数のページの画像

表示メニューから複数のページの画像を選択すると，サブメニューが表示され，以下のオプションを選ぶことができます．

複数ページのTIFを作成

単一画像または複数画像から，複数ページのTIF画像を作成します．ファイルリストに画像を追加/削除し，それぞれの（画像）ページについて圧縮形式を設定してください．全ページ同じ圧縮形式にしたい場合は，最初の入力ファイルを指定する前に，先に圧縮形式を設定してください．保存フォルダと出力ファイル名を指定したらTIF 画像を作成を押してファイルを作成してください．ファイルを作成せずにダイアログを終える場合は，キャンセルを押してください．

複数ページのPDFを作成

単一画像または複数画像から，複数ページのPDFを作成します．ファイルリストに画像を追加/削除し，それぞれの（画像）ページについて圧縮形式を設定してください．全ページ同じ圧縮形式にしたい場合は，最初の入力ファイルを指定する前に，先に圧縮形式を設定してください．保存フォルダと出力ファイル名を指定したらPDF 画像を作成を押してファイルを作成してください．ファイルを作成せずにダイアログを終える場合は，キャンセルを押してください．

注：PDF形式のファイルを作成するにはプラグインが必要です．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

複数ページのJPMを作成

単一画像または複数画像から，複数ページJPMを作成します．ファイルリストに画像を追加/削除し，それぞれの（画像）ページについてJPM save optionsを設定してください．全ページ同じ圧縮形式にしたい場合は，最初の入力画像を指定する前に，先に圧縮形式を設定してください．保存場所を Save directoryに，ファイル名をJPM nameに指定したらCreate JPM imageを押してファイルを作成してください．ファイルを作成せずにダイアログを終える場合は，Exitを押してください．

注：JPM形式のファイルを作成するにはプラグインが必要です．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

複数ページのLDFを作成

単一画像または複数画像から，複数ページLDFを作成します．IrfanViewでは，1ファイルに付き最大6ページまでのLDFを作成することができます．ファイルリストに画像を追加/削除し，それぞれの（画像）ページについてLDF save optionsを設定してください．全ページ同じ圧縮形式にしたい場合は，最初の入力画像を指定する前に，先に圧縮形式を設定してください．保存場所を Save directoryに，ファイル名をJPM nameに指定したらCreate LDF imageを押してファイルを作成してください．ファイルを作成せずにダイアログを終える場合は，Exitを押してください．

注：LDF形式のファイルを作成するにはプラグインが必要です．下記からダウンロードしてインストールしてください．

http://www.irfanview.com/plugins.htm

複数ページのTIFの編集

閲覧中の複数ページTIFファイルのページを編集（順番変更，削除，追加）することができます．変更は，元ファイルに適用することもできますし，新しいTIF ファイルとして保存 (推奨) することもできます．

現在の画像をTIFに追加

閲覧中の画像をTIFファイルに追加します．メニューを選択すると，開くダイアログが表示され，TIFファイルを選ぶと同時に閲覧中のファイルが新しいページとして追加・保存されます．保存設定は，現在のTIF保存ダイアログの物が使用されます．

注：以降のメニューは，複数ページ画像 (DCX/JPM/LDF/TIF) ファイルを読み込んでいるときにのみ利用できます．

次のページ

次のページを選ぶか，ツールバーの次のページツールを使うと，次の順番にあたるページが表示されます．

前のページ

前のページを選ぶか，ツールバーの前のページツールを使うと，前の順番にあたるページが表示されます．

最初のページ

最初のページを選ぶと，画像の最初のページが表示されます．

最後のページ

最後のページを選ぶと，画像の最後のページが表示されます．

ページを指定して開く

メニューを選択すると，ダイアログが表示されますので，開きたいページ番号を入力してください．

全てのページを印刷

全てのページを印刷を選ぶと，印刷設定ダイアログが表示され，設定に従って画像全ページをプリンタに送ります．

ページ毎に分割

ページ毎に分割を選ぶと，ページを抽出してそれぞれ単一画像ファイルとして保存できます．ダイアログが表示されるので，保存フォルダと保存形式を指定してください．

画像から抽出したページは，

filename_irfanview_extract_000.bmp

のような名前で保存されます．ここで，nameは元ファイルの名前，000はページ番号で，拡張子は指定した保存形式に対応したものになります． (例ではビットマップ(BMP)ファイル)

ページの連続表示

メニューを選択すると，ダイアログが表示されますので，表示間隔を入力してください．OKでファイルに含まれるページの連続表示が開始されます．

連続表示の停止

連続表示を停止します．


ヘルプを表示

ヘルプメニューからヘルプを表示を選ぶと，このヘルプファイル (今読んでいる物) が表示されます．

このヘルプの最初のバージョンはSteve Clarkが作成し，IrfanView 3.02以降はIrfanが更新しています．

バージョン3.97ではMichael Ofnerが更新しました．

Steve, Michael, ほんとにどうもありがとう!

訳注：この日本語版ヘルプは淙穂鶫箜（そうすいとうこう）が作成しました．誤字脱字，誤訳，より分かりやすい表現の提案などありましたら，ご連絡ください．
日本語ヘルプ入手先：http://irusuka.sakura.ne.jp/pc/irfanview.html
日本語ヘルプに関する連絡先：sousui@irusuka.sakura.ne.jp


 プラグイン情報

プラグイン情報

ヘルプメニューからプラグイン情報を選択すると，正しくインストールされたIrfanViewプラグインがダイアログに表示されます．

閲覧が終わったら，OKを押してください．


ご挨拶

ヘルプメニューからご挨拶を選ぶと，私 Irfan Skiljan からIrfanViewユーザーの皆さんへの感謝のメッセージが表示されます．

閲覧が終わったら，OKを押してください．


 ユーザー登録

ユーザー登録

ヘルプメニューからユーザー登録を選ぶと，ダイアログが表示され，名前とレジストレーションコードを登録できます．

IrfanViewは非商用利用では無料ですが，ユーザー登録してもらうにこしたことはありません．ちょっとしたお金が，WWW一番の画像閲覧/ツールを開発を続ける手助けになります．

登録が終わったら，OKを押してください．


アップデートチェック

ヘルプメニューからアップデートチェックを選ぶと，標準のブラウザが起動してIrfanViewホームページに接続し，最新バージョンとインストール済みバージョンをチェックして表示します．


 使用条件

使用条件

ヘルプメニューから使用条件を選ぶと，IrfanViewを無償利用できる条件や，ユーザー登録料の送り先の説明が表示されます．

また，バグレポートその他作者へのメッセージの送り先や，IrfanViewウェブサイトの説明もあります．

閲覧が終わったら，OKを押してください．


IrfanView について

ヘルプメニューIrfanView についてを選択するか，ツールバーのIrfanView についてツールを使うと，IrfanViewのバージョン，作者のメールアドレスと美しい故郷の写真 (一見の価値がありますので載せました) が表示されます．

閲覧が終わったら，Clickを押してください．


 ショートカットキー

ショートカットキー

キーボードショートカット

キー | 機能
+ ズームイン
- ズームアウト
↑ 上スクロール
↓ 下スクロール
→ 右スクロール / 次の画像
← 左スクロール / 前の画像
Page Up | 前の画像 / 画像を上にスクロール
Page Down | 次の画像 / 画像を下にスクロール
CTRL + Page Up | 前のページ (複数ページ画像) / 前の画像
CTRL + Page Down | 次のページ (複数ページ画像) / 次の画像
Space | 次の画像
Backspace | 前の画像
Shift + 方向キー | 選択範囲の枠を移動
ブラウジングモード
  • CTRLを押しながら: Space, Backspace, →,←等を使った時に，5ずつ 次/前 の 画像
  • CTRL + 数字 (0 - 9) : 数字分 次の 画像 (0 = 10, 1 = 1 等)
  • CTRL + SHIFT + 数字 (0 - 9) : 数字分 前の 画像 (0 = 10, 1 = 1 等)
ESC | 現在ウィンドウを閉じる (メインウィンドウ, スライドショー, フルスクリーン, サムネイル, ダイアログ)
Enter | フルスクリーンモードとウィンドウモードを切替
TAB | メインウィンドウとサムネイルウィンドウを切替 (それぞれが表示されている時)
CTRL + TAB | サムネイルウィンドウ内のコントロールペインを切替
Pause/Break | 自動スライドショーを一時停止．もう一度押すと再開
DEL | ファイルを削除
SHIFT + INSERT | クリップボードから画像を貼り付け (クリップボード内が文字列だった場合，それを画像として貼り付け)
Home | 画像の最初へ (水平スクロール) / 最初のファイル
CTRL + Home | 最初のファイル
End | 画像の最後へ (水平スクロール) / 最後のファイル
CTRL + End | 最後のファイル
F1 | ヘルプ表示
F2 / F6 | ファイル名変更
F3 | 16進表示
F4 | スライドショーにファイルを追加
F5 / U | 更新 (表示とフォルダ内リスト)
F7 | ファイルを移動
F8 | ファイルをコピー
F9 | OCRプラグインを起動 (画像全体/選択領域)
F11 | フルスクリーン/スライドショー中: マウスカーソルの表示/非表示
F12 | ペイントダイアログの表示
A | IrfanViewについて
B | 一括変換 形式/名前
C | 画面の取り込み設定
D | 画像を閉じる
E | EXIF情報（存在する場合）
F
  • ウィンドウモード中: 「画像をデスクトップに合わせる」と「ウィンドウを画像に合わせる」を切替
  • フルスクリーン/スライドショー中: 表示モードを順次切替
G | GIFやANIのアニメーションを停止
H | 左右反転
I | 画像の情報
K | フィルタファクトリ
L | 左回転
M | 最小化 - 「ボスが来た」キーです． ( ^ー°)
N | フルスクリーン/スライドショー中: テキストの表示/非表示
O | 開く
P | 基本設定
R | 右回転
S | 名前を付けて保存
T | サムネイル
V | 上下反転
W | スライドショー設定
X | ウィンドウモード/フルスクリーンモード中: 画像のタグ
CTRL + A | 全てのサムネイルを選択 (サムネイルウィンドウ)
CTRL + B | サブフォルダの参照
CTRL + C | 画像をクリップボードへコピー
CTRL + E | フィルタの設定
CTRL + F | ファイル検索
CTRL + H | 元のサイズに戻す
CTRL + I | ITPC情報 (JPGファイルの場合)
CTRL + K | Adobe8BFフィルタ
CTRL + M | ランダムなファイル
CTRL + N | 閲覧中のファイルを新しいIrfanViewウィンドウで開く
CTRL + P | 印刷
CTRL + Q | 複数ページのTIFの編集
CTRL + R | リサイズ/リサンプルの設定
CTRL + S | 上書保存
CTRL + T | 選択範囲にテキストを挿入
CTRL + U | カスタム回転
CTRL + V | クリップボードから画像を貼り付け (クリップボード内が文字列だった場合，それを画像として貼り付け)
CTRL + W | 現在のフォルダでスライドショーを開始
CTRL + X | 選択範囲の切り取り
CTRL + Y | 選択範囲を切り出す
CTRL + Z | 元に戻す
CTRL + number | ウィンドウモード/フルスクリーンモード中: 数字(0-9)分 次の画像
CTRL + Print | 画面取り込みの範囲指定を開始．
SHIFT + A | 連続表示 実行/停止
SHIFT + C | 選択範囲の指定
SHIFT + E | 1番目に設定した外部エディタで開く
SHIFT + F | 大きい画像だけデスクトップに合わせる
SHIFT + G | 色調補正
SHIFT + J | JPGロスレス回転
SHIFT + L | ズームをロック/ロック解除 (フルスクリーンモードでも有効)
SHIFT + M | 画像をメールで送信
SHIFT + N | 画像の新規作成
SHIFT + O | ウィンドウを画像に合わせる(1:1)
SHIFT + P | 閲覧中のファイル名をクリップボードにコピー
SHIFT + Q | ウィンドウモード/フルスクリーンモード中: JPGコメントのあるファイルのみをサムネイルウィンドウに表示
SHIFT + R | 更新 (表示とフォルダ内リスト)
SHIFT + S | シャープ
SHIFT + T | ツールバーのディレクトリでの順位フィールドにフォーカス
SHIFT + U | 自動色彩調整
SHIFT + V | 縁の追加 (キャンバスサイズ変更)
SHIFT + W | 画像をウィンドウに合わせる
SHIFT + X | ウィンドウモード/フルスクリーンモード中: 閲覧中ファイルのタグ表示を消去
SHIFT + Y | 赤目補正
Alt + SHIFT + S | ステータスバーの表示/非表示
Alt + SHIFT + T | ツールバーの表示/非表示
Alt + SHIFT + M | メニューバーの表示/非表示
Alt + SHIFT + C | タイトルバーの表示/非表示
CTRL + SHIFT + A | スキャン/一括スキャン
CTRL + SHIFT + J | JPGロスレス切り抜き
CTRL + SHIFT + M | JPGコメントの表示
CTRL + SHIFT + L | JPGロスレス回転 - 左回転
CTRL + SHIFT + R | JPGロスレス回転 - 右回転
CTRL + SHIFT + C | 壁紙にする - 中央に表示
CTRL + SHIFT + T | 壁紙にする - 並べて表示
CTRL + SHIFT + S | 壁紙にする - 拡大して表示
CTRL + SHIFT + P | 前の壁紙に戻す
CTRL + SHIFT + Y | 縁を自動切り取り
CTRL + SHIFT
+ number 		ウィンドウモード/フルスクリーンモード中: 数字(0-9)分 前の画像
CTRL + ALT + P | ダイアログを出さずに印刷 (ダイレクト印刷)
1 | フルスクリーンモード中: 元の大きさのままで表示する (1:1)
2 | フルスクリーンモード中: 画面より大きな画像/ムービーだけ画面に合わせる
3 | フルスクリーンモード中: 全ての画像/ムービーを画面に合わせる
4 | フルスクリーンモード中: 全ての画像/ムービーを画面サイズに引き伸ばす
5 | フルスクリーンモード中: 画像の幅を画面の幅に合わせる
6 | フルスクリーンモード中: 画像の高さを画面の幅に合わせる
テンキーの5 | 画像中央にスクロール

マウスショートカット

ウィンドウモード時

左クリック
  • タイトルバーに指定ピクセルの座標と色情報を表示
  • 選択範囲の中をクリック: ズームイン
左クリック + ドラッグ | 範囲指定
CTRL + 左クリック
+ ドラッグ 		範囲選択サイズを変更する時: 変更前のアスペクト比を保存してサイズ変更
右クリック + ドラッグ
  • 画像をドラッグ方向にスクロール
    （基本設定→表示のオプションにより「コンテキストメニューの表示」に変更可）
  • 選択範囲の中で: 選択範囲を移動
ダブルクリック | フルスクリーンモード
ホイール上回転 | 前の画像 / 画像を上にスクロール
ホイール下回転 | 次の画像 / 画像を下にスクロール
CTRL + ホイール上回転 | ズームイン
CTRL + ホイール下回転 | ズームアウト

フルスクリーン/スライドショー時

左クリック | 前の画像
右クリック | 次の画像
左上/右上 を 左クリック | フルスクリーン / スライドショーを閉じる

実行形式スライドショーのショートカット

E | 実行形式スライドショーから全ファイルを抽出
T / N | テキストの表示/非表示
F | 表示オプションの順次切替
F1 | ヘルプ
F11 | マウスカーソルの表示/非表示


最新版/連絡先

最新のIrfanViewは下記サイトでダウンロードできます．

  • http://www.irfanview.com
  • http://www.irfanview.net
  • http://www.irfanview.info
  • http://www.irfanview.at

or

  • http://irfanview.tuwien.ac.at

このプログラムの製作者Irfan SkiljanへのE-mailは下記のアドレス宛にお願いします．

  • irfanview@gmx.net

訳注：Irfanさんはドイツ語が母語で，英語も分かります．

プログラムを製作者に登録したい場合，現金で12米ドルか10ユーロを下記住所に送ってください．

Irfan Skiljan
Postfach 48
2700 Wiener Neustadt
Austria, Europe

あるいはPayPal（https://www.paypal.com）を使って次のE-mailアドレス宛に寄附をお願いします． irfanview@gmx.net

訳注：PayPalはインターネット上の送金サービスで，金額と受取人のメールアドレスを入力するとクレジットカード払いで送金できます．サイトは日本語でも表示できます．アカウント登録が必要です．

どうもありがとう！

商用使用：使用料や値引きについてE-mailでお問い合わせください．


編集メニュー

  • 元に戻す
  • ペイントダイアログ
  • 選択範囲の指定
  • 選択範囲を最大化と中央寄せ
  • 選択範囲にテキストを挿入
  • 選択範囲の切り取り / 選択範囲以外を削除
  • 選択範囲を切り出す / 縁を自動切り取り
  • 選択範囲をコピー
  • 選択範囲へ貼り付け
  • 画像を閉じる
  • クリップボードを消去


ファイルメニュー

Top Next
  • 開く
  • 再読み込み
  • 外部エディタで開く
  • 形式を指定して開く
  • サムネイル
    • サムネイル－HTMLファイルの作成
  • スライドショー
    • スライドショーCD
  • 一括変換 形式/名前
  • ファイル検索
  • 名前の変更
  • 移動
  • コピー
  • 削除
  • 上書保存
  • 名前を付けて保存
  • Web用に保存
    • JPEG/GIF 保存設定
    • JPEG2000 保存設定
    • JPM 保存設定
    • LDF 保存設定
    • LWF 保存設定
    • PNG / PBM/PGM/PPM / ICO 保存設定
    • TIFF 保存設定
  • 印刷
  • TWAIN対応機器の選択
  • スキャン/一括スキャン
  • コピー作業
  • 最近開いたフォルダ
  • 終了


ヘルプメニュー

Top Previous
  • ヘルプを表示
  • プラグイン情報
  • ご挨拶：謝辞
  • ユーザー登録
  • アップデートチェック
  • 使用条件
  • IrfanView について


画像メニュー

  • 画像の情報
  • 新規作成
  • パノラマ画像の作成
  • 左回転 / 右回転 / カスタム回転
  • 上下反転
  • 左右反転
  • リサイズ/リサンプル
  • 縁の追加
  • 増色
  • 減色
  • グレイスケールに変換
  • ネガ/ポジ 反転
  • 色調補正
  • ヒストグラム
  • 自動色彩調整
  • 赤目補正
  • フィルタ
    • フィルタの設定
    • フィルタファクトリー
  • 色の入れ替え
  • パレット


オプションメニュー

  • 基本設定
    • 基本設定－開始 / 終了
    • 基本設定－JPEG / PCD / GIF
    • 基本設定－ファイルの関連付け
    • 基本設定－表示
    • 基本設定－ブラウジング / 編集
    • 基本設定－フルスクリーン / スライドショー
    • テキスト/パターン オプション
    • 基本設定－ビデオ / サウンド
    • 基本設定－ファイル操作
    • 基本設定－言語
    • 基本設定－PlugIns
    • 基本設定－その他
  • マルチメディアプレイヤーの起動
  • アニメーション停止
  • 静止画に分割して保存
  • 画像をメールで送信
  • JPG ロスレス回転
  • JPG ロスレス切り抜き
  • 画面の取り込み
  • OCRを開始
  • ファイルの並べ替え
  • 壁紙にする
  • 最小化
  • 常に手前に表示


表示メニュー

  • ステータスバー
  • ツールバー
  • ウィンドウの外枠：タイトルバー / キャプション
  • ディレクトリでの順位
  • フルスクリーン
  • 表示設定
  • 次のファイル
  • 前のファイル
  • 最初のファイル
  • 最後のファイル
  • ランダムなファイル
  • 最新の情報に更新
  • 連続表示 実行/停止
  • ズームイン
  • ズームアウト
  • ズームを固定
  • スクロール位置を固定
  • 元のサイズに戻す
  • 16進表示
  • 複数のページの画像